?
Solved

openVPN client connects then drops on openSUSE 11.1

Posted on 2009-02-21
3
Medium Priority
?
1,104 Views
Last Modified: 2013-12-05
I am running the openvpn client (version 2.0.9-143.15) on openSUSE 11.1 (32-bit). I have the openvpn server running on the Astaro Security Gateway (version 7.306) and have the SSL VPN working just fine with windows clients connecting to the server. When I connect from my openSuse laptop the vpn tunnel is established successfully for a couple of seconds but it disconnects shortly thereafter.

It appears from the logs on the server that there is a decryption error that drops the connection after which it is reestablished again only to be dropped a couple of seconds later after receiving a soft-reset from the client.

The client log shows a plugin failure that seems to be responsible for the drop of the connection. I have upgraded the client to the latest openvpn client (openVPN 2.1_RC15) but then the connection fails right off the bat where as with version 2.0.9 I at least get an initial connection even if it is only for a few seconds.

Can anyone give me some direction on how I can resolve this issue? I have attached logs from both the server and the client with the details.

Thank you.
openvpnclient.log
openvpnserver.log
0
Comment
Question by:Ravelstaff
  • 2
3 Comments
 

Expert Comment

by:bekito
ID: 23709575
Is the SuSe firewall on?  What about Apparmor?  

Have you tried turning off Network Manager, and just using the traditional network management?
0
 

Author Comment

by:Ravelstaff
ID: 23713033
Hi bekito,

Thanks for responding. AppArmor is switched off and I get the same results even if I switch off the SuSe firewall. I have not yet tried it with ifup instead of Networkmanager; it will take me a bit of time  to get that tested I will post back my findings here in the next 24 to 48 hours.
0
 

Accepted Solution

by:
Ravelstaff earned 0 total points
ID: 23742169
Final update. ifup does not have any gui plugins to manage the openvpn connections (at least not any that I am aware of or could find) so I resorted back to activating the openvpn client directlly from the console. The vpn connection comes up and stays stable when I execute the following from the console:

openconfig --config <path_to_configfile>

I am happy with this solution since it works.
Thanks for your input.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
If you use NetMotion Mobility on your PC and plan to upgrade to Windows 10, it may not work unless you take these steps.
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question