[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

SETUP CISCO 877 WITH MY DSL PROVIDER

Posted on 2009-02-22
4
Medium Priority
?
1,321 Views
Last Modified: 2013-12-14
Hi,


I have CISCO871W-G-A-K9, I used AT&T as my DSL provider, I did the following

I un plugged the modem, and connected directly into the back of the CISCO router labeled ASDSL. THEN I used SDM GUI, to configure the DSL.


I FOLLOW THESE STEPS& I USED new connection, it asked me for an I.P&. I gave the IP 192.168.1.64 that what it shows before on my modem.

Then the subnet.255.255.255.0. Then my DNS. Which is 192.168.1.254.

Then it asked me for my CHAP/PAP authentication. Which I provide by my AT&T,&. After Im done it asked me to test the connection. The results I have, it said

Pinging to destination host. THEN IT FAILS.. this is the only item the fails. The rest of them passed, it looks like is testing the Ethernet and thats when it fails.

Any suggestions, my understanding is that I can use this CISCO 877 as a modem, to replace my DSL modem. And only use CISCO.

Using SDM, I figured out. How to put the IP, now it passed, but NOW this is the failing part.  Here is the message.



Failure Reason(s)
To test connectivity, SDM tries to ping the configured DNS servers. However, there is no configured route to any of the DNS servers through the selected interface.

HERE IS THE RECOMMENDATIONS.
Select 'User-specified' option or add a 'host specific/network specific/default' route through this interface and retest connection.
Please help.
0
Comment
Question by:gonzalez9334
3 Comments
 

Author Comment

by:gonzalez9334
ID: 23704617
Using SDM, I figured out. How to put the IP, now it passed, but NOW this is the failing part.  Here is the message.



Failure Reason(s)
To test connectivity, SDM tries to ping the configured DNS servers. However, there is no configured route to any of the DNS servers through the selected interface.

HERE IS THE RECOMMENDATIONS.
Select 'User-specified' option or add a 'host specific/network specific/default' route through this interface and retest connection.
0
 
LVL 9

Accepted Solution

by:
Press2Esc earned 1000 total points
ID: 23710566
Yes, the Cisco 877 can function as a DSL router..  However, be aware that any device that provides the DSL req'd PPP authentication (Cisco included) must ONLY provide the DSL user login name & pwd, along with the correct VPI/VCI (Virtual Path/Ciruit ID)
Do NOT try and assign a static IP to the outside (WAN, Dialer1) address of the router.  When properly authenticated, the router will receive an public IP and corresponding (2) DNS servers IPs from the ISP.
0
 

Assisted Solution

by:atnextc
atnextc earned 1000 total points
ID: 23772426
Below is a working config from a Cisco 1721 that si being used as a DSL modem. Of course you "have to" know the CLI, but if you edit the appropriate parts. IE just the "chap username and password" portion it should work just fine.

Let us know how it turns out.

FYI
ATT's VPI and VCI are 8/35
service timestamps debug datetime msec
 
service timestamps log datetime msec
 
service password-encryption
 
!
 
hostname R1
 
!
 
logging queue-limit 100
 
 
!
 
ip subnet-zero
 
!
 
vpdn enable
 
!
 
vpdn-group pppoe
 
!
 
interface ATM0
 
 no ip address
 
 no atm ilmi-keepalive
 
 dsl operating-mode auto 
 
 hold-queue 224 in
 
 no shut
 
!
 
interface ATM0.1 point-to-point
 
 pvc 8/35 
 
  pppoe-client dial-pool-number 1
 
 !
 
!
 
interface FastEthernet0
 
 ip address 192.168.1.1 255.255.255.0
 
 ip nat inside
 
 load-interval 30
 
 speed auto
 
 no shut
 
!
 
interface Dialer1
 
 ip address negotiated
 
 ip mtu 1492
 
 ip nat outside
 
 encapsulation ppp
 
 dialer pool 1
 
 ppp chap hostname user@att.net
 
 ppp chap password password
 
 ppp ipcp dns request
 
!
 
ip nat inside source list 1 interface Dialer1 overload
 
ip classless
 
ip route 0.0.0.0 0.0.0.0 Dialer1
 
no ip http server
 
!
 
!
 
access-list 1 permit 192.168.1.0 0.0.0.255
 
!
 
!
 
line con 0
 
line aux 0
 
line vty 0 4
 
 transport input telnet
 
!
 
no scheduler allocate
 
!
 
End

Open in new window

0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Working settings for French ISP Orange "Prêt à Surfer" SIM cards for data connections only. Can't be found anywhere else !
For Sennheiser, comfort, quality and security are high priority areas. This paper addresses the security of Bluetooth technology and the supplementary security that Sennheiser’s Contact Center and Office (CC&O) headsets provide.  
This tutorial will introduce the viewer to VisualVM for the Java platform application. This video explains an example program and covers the Overview, Monitor, and Heap Dump tabs.
This tutorial explains how to use the VisualVM tool for the Java platform application. This video goes into detail on the Threads, Sampler, and Profiler tabs.
Suggested Courses

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question