Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7258
  • Last Modified:

SQL service won't start

Hello,
I have a small..... or HUGE problem. I cannot get my mssmlbiz SQL server to start. Nothing has changed in the environment, except a QB update, and a reboot. I am running 2003 SBS, with a shared BCM database. It worked fine for the last month, and then died. I am getting the error code 10048 (0x2740) in the event log. Any advise from some of you really smart people would be greatly appreciated. Thanks.

Rob
0
rn0rd0
Asked:
rn0rd0
  • 5
  • 3
1 Solution
 
rn0rd0Author Commented:
Just found another interesting log entry....
Server TCP provider failed to listen on [ 'any' <ipv4> 5356]. Tcp port is already in use.
I don't know what this means... but it is associated with the MSSMLBIZ service
0
 
tigin44Commented:
sql server uses a dynamic port which is assigned when you restart the server and it can change in every restart. restart your machine, probably your problem will be resolved.
0
 
rn0rd0Author Commented:
I have restarted the server multiple times, to no avail. If I uninstall BCM, and then re-install BCM it will work just fine, right up until the point that I try to share the DB out to other users. At this point it gives the error. It doesn't appear as if this is a BCM specific issue, but rather a SQL express issue. One more small tid bit... I am also running full version SQL 2000 on the same box, I have disabled the other SQL services to try and rule that out, but still no dice. Thanks for your continued help.
0
Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

 
wantabe2Commented:
Look at the SQL service & re-enter the administrator username & password that enables the service to start.
0
 
rn0rd0Author Commented:
I did change that from "local account" to "specific account" using the admin user and pass. No luck
0
 
tigin44Commented:
the port number is stored under the registry key
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\EGTMRK\MSSQLServer\SuperSocketNetLib\Tcp
as TcpDynamicPort and TcpPort keys. try chnaging to a free port.
0
 
rn0rd0Author Commented:
Is there a specific "free port" O should change it to?
0
 
tigin44Commented:
try incrementing the port number by one...
0
 
rn0rd0Author Commented:
Thanks!!! Changing the port worked
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now