[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 697
  • Last Modified:

ASA Static route for RDP

Im having trouble setting up access to a internal server for RDP.

I have a Block of IPs on a /27.  .97-126
The router is on 12.55.199.97

I have a Internal server on 10.80.100.85, i want access to it from the internet on 12.55.199.101. To begin I want to add RDP access on 3389 to start, but i am stumped. I plan to open up other ports for web server...etc

For this i created these 3 config lines:
access-list rdp extended permit tcp any host 12.55.199.101 eq 3389
static (inside,outside) 12.55.199.101 10.80.100.85 netmask 255.255.255.255
access-group rdp in interface outside

When i ping the outside ip 12.55.199.101 I am not seeing any activity in the syslog. I must have something wrong.
ASA Version 7.2(3)
!
hostname B-ASA
domain-name xyzarms.com
enable password eQWIsP.AIf4tBrGw encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.80.100.6 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 12.55.199.116 255.255.255.224
!
interface Ethernet0/0
 switchport access vlan 2
 speed 100
 duplex full
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd eQWIsP.AIf4tBrGw encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name xyzarms.com
access-list rdp extended permit tcp any host 12.55.199.101 eq 3389
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 12.55.199.103-12.55.199.108 netmask 255.255.255.224
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 12.55.199.101 10.80.100.85 netmask 255.255.255.255
access-group rdp in interface outside
route outside 0.0.0.0 0.0.0.0 12.55.199.97 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 0.0.0.0 0.0.0.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 20
ssh version 2
console timeout 0
 
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:de55e74d845f46ffc9f9b51ea84b84b9
: end

Open in new window

0
gbosko
Asked:
gbosko
  • 3
2 Solutions
 
Alan Huseyin KayahanCommented:
Hello gbosko,
    Config looks fine, can you confirm if 10.80.100.85 can be RDPed from an inside host? If any software firewall enabled like windows firewall, please make sure you set the exceptions accordingly.
    If you have access to 12.55.199.97 router,run "telnet 12.55.199.101 3389" and check if it says open

Regards
0
 
gboskoAuthor Commented:
I do not have access to the Router. It is part of the managed T1 line.

The firewall on the OS is disabled.
I can RDP from the inside.
0
 
DonbooCommented:
Since ping isnt a part of tcp but IP you need to explicit allow ICMP.

This is the config I use to make ICMP traverse the ASA.
-----------------
object-group icmp-type Good-ICMP
 icmp-object echo
 icmp-object echo-reply
 icmp-object time-exceeded
 icmp-object traceroute
 icmp-object unreachable

access-list rdp extended permit icmp any any object-group Good-ICMP
0
 
gboskoAuthor Commented:
Donboo, thanks for the icmp config. however im still not able to connect. Its like the ASA doesnt know that it is supposto see outside IP 12.55.199.101.

When i PING or try to RDP nothing shows up in the sys log.
0
 
gboskoAuthor Commented:
Fixed. Another firewall was unknowingly using the external IP was was trying to use.
0

Featured Post

Identify and Prevent Potential Cyber-threats

Become the white hat who helps safeguard our interconnected world. Transform your career future by earning your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now