Error code 87 Windows xp Pro server service.

I need help to fix this error. I have recieved 2 replies and neither was the solution.Error code 87 Server service apaarameter is incorrect.
code 87

Open in new window

wl1516Asked:
Who is Participating?
 
johnb6767Commented:
Sorry Orangutang, but I would recommend one thing first.....
Maybe 2....

Replace winsrv.dll with one from a known good machine, prefereably the same Service P"ack level... Might have a good copy in c:\windows\system32\dllcache you can try with first.... Just rename it to winsrv.old in c:\windows\system32, and hit F5 and it should be replkaced if WFP is working....

Secondly.....

Go to the Network Connections in the control panel, and right click it>Properties.....

Highlight "Client for MS Networks", and select Uninstall.....

Do the same for "File and Printer Sharing"

Reboot and retest....

0
 
Dirtpatch-JenkinsCommented:
Hi, can you disable your firewall and antivirus for a short period to see if that could be the cause.

error code 87 is usually a proxy issue
0
 
wl1516Author Commented:
I disabled firewall and antivirus and still have error after reboot
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

 
Dirtpatch-JenkinsCommented:
i cant remember what the circumstances were... was it working then just stopped?  if so, were there any changes made preceding this behavior? updates, add software, new router?

0
 
wl1516Author Commented:
It has been like this for about 1 month.It is possible a result of a virus I had a while back I got cleaned up but only noticed when I could not connect with this computer with my other computer to listen to shared media in WMP.I have performed repair and reload with disk and still cannot get service to start.
0
 
orangutangCommented:
Try scanning with Malwarebytes' Anti-Malware (http://www.malwarebytes.org/mbam.php) and send us your HijackThis (http://www.trendsecure.com/portal/en-US/threat_analytics/hijackthis.php) log.
0
 
orangutangCommented:
Also, have you checked your event viewer for anything else related to your problem?
0
 
wl1516Author Commented:
I am having Service control manager errors event id 7023 in event viewer under system. I have also sent attachment from hijack this to analyze per your request. thank you for your time in trying to help me repair this problem.
hijackthis.log
0
 
orangutangCommented:
Do you have SP3?
0
 
wl1516Author Commented:
yes I have sp3 installed.
0
 
johnb6767Commented:
Dont like this entry....

O20 - Winlogon Notify: wdiznf - C:\WINDOWS\

Safe  to remove, although probably not the problem....
O2 - BHO: (no name) - {5C255C8A-E604-49b4-9D64-90988571CECB} - (no file)

Heres what I would do...

Start>run>MSConfig

Disable all on the Startup tab, and in the services. Reboot and see if you get the error after a while. Keep in mind, functionality is not the best after the reboot with most services disabled.... If you have made it past where you normally see the error, go back to MSConfig, and re enable half the services.

Then you can kee enabling until you reach the culprit....

Basically it seems like something running is interfering.....



0
 
wl1516Author Commented:
I deleted the 2 entries in question and rebooted server service still not start. I disabled all entries in startup and services tabs in msconfig, rebooted and still cannot start server service in services, still get error code 87.
0
 
orangutangCommented:
Maybe get HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver from a working computer and put it on yours.
0
 
wl1516Author Commented:
I went in to system32 and renamed winsrv.dll to winserv.old, hit f5 and icon changed to white icon and still named winsrv.old. I cannot find a file or folder named dllcache in windows\system32. I really appreciate all your help on this matter.
0
 
wl1516Author Commented:
Well I deleted client for microsoft networks and file and printer sharing and reloaded them and server service started automaticly. I can network with my laptop now. Thanks for all your help.
0
 
wl1516Author Commented:
Everybody who replied was very helpful but johnb6767 pointed me to the solution to the problem. Thanks johnb6767
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.