disable bpdu guard on cisco router

Hi,
How can I display BPDU guard on a router ?

Issue is this that as per my ISP, they say that my device (which is a cisco 1751 series router) sends BPDU's as a result of which the port on their switch gets error disabled and we loose our connectivity ... How can i disable BPDU's on my fastethernet 0/0 port so it stops sending BPDUs, thanks ...
nabeel92Asked:
Who is Participating?
 
Don JohnstonConnect With a Mentor InstructorCommented:
I guarantee you that the f0/0 interface is not sending out BPDU's.

Is there a switch between your router and the ISP?
0
 
Kamran ArshadIT AssociateCommented:
Hi,

Please read the below articles;

https://www.cisco.com/en/US/docs/routers/access/1700/1711/software/feature/guide/1711swm.html
tecun.cimex.com.cu/tecun/software/Soporte%20Tecnico%20de%20Redes/Cisco/Routers/MODULES/wanlan.pdf
0
 
nabeel92Author Commented:
there is surely heaps of information on this link but doesnt answer my question ... It does say about BPDU guard not supported on WIC-4ESW card slots which is fine but doesn't talk about the normal fastethernet interface on the 1751 router if that supports BPDU or not, and if yes, then i need to disable it ... Because as mentioned above, what happens is that my ISP tells me that my router is sending BPDU's to their switch which gets their switch port in error disabled state that connects our office to another site ...

Can I (if yes then how, whats the command) to disable BPDU guard on the router or individual fast ethernet port on the 1751 series router so that it doesnt send these BPDUs ? thanks ...
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
nabeel92Author Commented:
and my cross connect link to the ISP is on normal fast ethernet port (not on the WIC-4ESW slot) ...
0
 
Kamran ArshadIT AssociateCommented:
Thanks for the update.

interface fastethernet 0/0 port
>  switchport mode trunk
>  spanning-tree bpdufilter enable
0
 
nabeel92Author Commented:
Hi Mate, thanks for the update ...

It doesn't have an option to make it switchport (since its a layer 3 port) and so doesnt have an option of spanning tree ....

pasted below is when i tried your suggested config ...

AAPT(config)#interface fastEthernet 0/0
AAPT(config-if)#span
AAPT(config-if)#span?
% Unrecognized command
AAPT(config-if)#exit
AAPT(config)#span
AAPT(config)#spanning-tree ?
  backbonefast  Enable BackboneFast Feature
  portfast      Spanning tree portfast options
  uplinkfast    Enable UplinkFast Feature
  vlan          VLAN Switch Spanning Tree

It just gives me an option of spanning-tree command options in global configuration mode; not in interface mode ....
0
 
Kamran ArshadIT AssociateCommented:
Have you tried to disable spanning tree globally?
0
 
nabeel92Author Commented:
command please ?
0
 
Kamran ArshadIT AssociateCommented:
0
 
nabeel92Author Commented:
Ok, This is getting a bit annoying ...

I'm here to get a solution to my issue and you'r just redirecting me from one link to another ... What I asked in my question was something that is possible (yes or no) .. if yes, then how ? if no, then its a NO ....  

Rather, you are just telling me to disable spanning tree (which is not even what i asked for and it absolutely makes no sense at all to disable spanning tree since that is not what i even asked and i dont see how can you justify that disabling spannig tree is gonna stop sending bpdu from my fast ethernet ports ... It is someone else's ) ... Even for that, you are sending me a link rather than actually replying ........... I guess you're deviating from the actual question which was regarding BPDU's and how can i make my port stop sending them ?

Please dont send me links in response else I'll have to close this question

Thanks,
0
 
Don JohnstonInstructorCommented:
Your router shouldn't be sending BPDU's. They are sent by switches, not routers. Or have you enabled bridging on your router?

Can you post the config?
0
 
nabeel92Author Commented:
Exactly till the support person at ISP (Telstra) told me that it maybe our device .. So i just wanted to double check if really a fast ethernet (layer 3 port) can send BPDU's ? In the meantime, ive given the command "no spanning-tree portfast bpduguard" but am not sure of its impact and if its of any use ??
 
Thanks for your Post and given below is my configuration

AAPT#sh running-config
Building configuration...

Current configuration : 1814 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AAPT
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
multilink bundle-name authenticated
!
username admin privilege 15 password 0 xxx
archive
 log config
  hidekeys
!
!
!
track 1 rtr 1 reachability
!
track 2 rtr 2 reachability
!
track 3 list boolean or
 object 1
 object 2
!
!
!
interface FastEthernet0/0
(This is the interface to the ISP switch which they say sends BPDU's that causes their switch port to get into error disabled state)
 bandwidth 10000
 description CrossConnect-Telstra
 ip address 172.16.0.68 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description Power Tel MAN
 bandwidth 4000
 ip address 172.16.0.81 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
 switchport access vlan 20
!
interface FastEthernet0/0/3
 switchport access vlan 10
 bandwidth 4000
 shutdown
!
interface Vlan1
 ip address 10.0.16.1 255.255.255.0
!
interface Vlan10
 bandwidth 4000
 ip address 172.16.0.77 255.255.255.252
!
interface Vlan20
 ip address 172.16.0.73 255.255.255.252
!
router eigrp 1
 passive-interface FastEthernet0/0/3
 network 10.0.16.0 0.0.0.255
 network 172.16.0.64 0.0.0.7
 network 172.16.0.72 0.0.0.3
 network 172.16.0.76 0.0.0.3
 network 172.16.0.80 0.0.0.7
 no auto-summary
 eigrp event-logging
!
ip route 0.0.0.0 0.0.0.0 172.16.0.65 track 3
ip route 0.0.0.0 0.0.0.0 172.16.0.83 100
!
!
no ip http server
no ip http secure-server
!
ip sla 1
 icmp-echo 4.2.2.2 source-interface Vlan1
 frequency 15
ip sla schedule 1 life forever start-time now
ip sla 2
 icmp-echo 4.2.2.3 source-interface Vlan1
 frequency 15
ip sla schedule 2 life forever start-time now
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login local
!
scheduler allocate 20000 1000

!
webvpn cef
end
0
 
nabeel92Author Commented:
No Switch between router and ISP ...
Only the ISP has a switch in their premises on which the port gets error disabled everytime we change router at our end(or even the router's port) ...
0
 
Dheeraj DhallCommented:
I am facing the Same Issue. using a router in GNS connected to Nexus switch. the Switch is disabling the port under BPDU Guard.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.