• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 232
  • Last Modified:

Cannot access http (internet/intranet) from terminal server.

Half a year ago I created a policy to avoid users browsing internet on the terminal server. Now we need to allow again.

Tried to disable the policy "UserSettings/System/Internet Communication management/Restrict internet access" but nothin helps. Have rebooted the teminal server.

What to check for?
0
TANGLAD
Asked:
TANGLAD
  • 8
  • 7
1 Solution
 
Abhay PujariCommented:
Had this policy is applied from domain level?
0
 
TANGLADAuthor Commented:
It's a policy that affects users logging on to ther terminal server.  

The policy is linked to the Terminal Servers OU that I created.

DNS seems ok since I can do NSlookups

RDP sessions from the terminal server against an outside server works.

FTP against outside ftp sites works

It's only Internet Explorer that dosent show anything at all. It says " Internet Explorer cannot display the webpage

"


0
 
Abhay PujariCommented:
Have you tried installing and uninstalling IE? Also did your group policy update?
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
TANGLADAuthor Commented:
If I disable the RestrictCommunication in the policy the GPRESULT /V shows me this:

GPO: JN Terminal Server Bruger indstillinger
                KeyName:     Software\Policies\Microsoft\InternetManagement\RestrictCommunication
                Value:       0, 0, 0, 0
                State:       Enabled


If I enable the RestrictCommunication in the policy the GPRESULT /V shows me this:

GPO: JN Terminal Server Bruger indstillinger
                KeyName:     Software\Policies\Microsoft\InternetManagement\RestrictCommunication
                Value:       1, 0, 0, 0
                State:       Enabled

So the state is Enabled no matter what I do.???????
0
 
Abhay PujariCommented:
Sounds strange. What does GPUPDATE shows in the event viewer if you disable the policy?
0
 
TANGLADAuthor Commented:
Created a brand new user. Logged on and have same result.

GPUPDATE doesn't show any errors in eventlog

0
 
Abhay PujariCommented:
Can you reset the policy on terminal server?
0
 
TANGLADAuthor Commented:
How?
0
 
Abhay PujariCommented:
Try to follow this article on test server first (May be on virtual server) http://escapelogic.com/main/node/2.
0
 
TANGLADAuthor Commented:
Thanks for the link. I will try this later today.
0
 
Abhay PujariCommented:
Not a problem. But update me here again.
0
 
Abhay PujariCommented:
One more for the same http://www.freebyte.com/hjsplit/. It is better than previous tool.
0
 
TANGLADAuthor Commented:
Tried this linkand rebooted. But no luck http://escapelogic.com/main/node/2.

As mentioned earlier I can do this:
FTP to external or internal sites
HTTPS to external or internal sites

but CANNOT do any HTTP trafic? Strange I think.

Don´t even know if this is a Policy bugging me. Have looked in the firewall log and it tells me nothing, so I don't think the firewall is blocking.

What else can prevent this damn machine from doing http????
0
 
Abhay PujariCommented:
Sorry for my above post. It was just a mistake(About file splitter). Have you run gpresult on the server? Does it show any errors?
0
 
TANGLADAuthor Commented:
SOLVED. The problem was AVG8 WebShield. When I disabled it HTTP trafic worked perfect. But tahnks anyway for helping me checking the policy status.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now