[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Network and VLAN Problems with Cisco 2950's

Posted on 2009-02-23
30
Medium Priority
?
11,731 Views
Last Modified: 2012-05-06
Ok first thing is im in a real hurry! these are important links! Please help!!!

I seem to be having issues with these configs, can somebody just tell me if i have gone wrong somewhere... I have the feeling its due to the VLAN configurations, im used to HP and they are a hell of a lot easier! :)

All I really want to do is Tag both vlans over the trunk link and have the ports as untagged on each switch.  It works perfectly on the HP kit but it isnt as straight forward on the Cisco Gear.

Thanks
NETWORK.jpg
0
Comment
Question by:chesterzoo
  • 13
  • 7
  • 5
  • +3
30 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23711428
First off, don't use VTP.

conf t
vtp mode transparent   <--do this on all 3 cisco switches

Then create the VLAN's on each switch:

conf t
vlan 6
exit

Make sure you "no shut" the interfaces.

If that doesn't fix it, post a "show vlan" and a "show int trunk" from each Cisco switch.
0
 
LVL 2

Author Comment

by:chesterzoo
ID: 23711501
Thanks, ill go and give it a try now...
0
 
LVL 19

Expert Comment

by:lamaslany
ID: 23711518
Hmm... I think you might be missing the encapsulation type on the trunk connections.  

Try:

 switchport trunk encapsulation dot1q
0
Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

 
LVL 2

Author Comment

by:chesterzoo
ID: 23711535
sorry no i've done that... forgot to mention it...
0
 
LVL 19

Expert Comment

by:lamaslany
ID: 23711563
Ignore me - I'm not sure that is actually needed!  :)
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 23711808
If the text to the right are the commands that have been issued, that could be your problem.

On all switches, use the commands:

conf t
vtp mode trans
vlan 5
int range f0/1 -8
 switchport mode access
 switchport access vlan 1
int range f0/9 -24
 switchport mode access
 switchport access vlan 5
int g0/1
 switchport mode trunk
int g0/2 ! switch 2 only
 switchport mode trunk

Open in new window

0
 
LVL 4

Expert Comment

by:CCI_IT
ID: 23711812
Looking at your diagrams, I see a few problems (unless it wasnt noted)

You need to run a trunk link from the HP to the Cisco switches (either cascade or a link to each). if anything is critical on that HP switch, i advise you dont cascade as everything below the beak point will lose connectivity.

That said...

on each Cisco trunk port,
conf t
switchport
switchport trunk enc dot1q
switchport mode trunk
switch trunk allowed vlan x,y,z (only if you have more VLANS you dont need to allow)


on the access (non-tagged) port

conf t
sw
sw mode access
sw acc vlan x (or Y or Z)
spanning-tree portfast (only if you are sure they will nto be connected to another switch!!!!!) ~ removes the spanning tree process from the port.

make sure the Trunk port on the HP is configured the same way (Dot1q etc).

You will be ready to go from that point.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 23711962
>You need to run a trunk link from the HP to the Cisco switches

If there are only two VLAN's and you're willing to run two separate links, there's no "need" to run a trunk.

>switchport trunk enc dot1q
This is an invalid command on 2950 switches as 802.1q is the only encapsulation they support.

>switch trunk allowed vlan x,y,z (only if you have more VLANS you dont need to allow)
Not required. Optional... but recommended.

>removes the spanning tree process from the port.
Portfast does not remove spanning tree from a port. It simply bypasses the Listening/Learning stage.
0
 
LVL 3

Expert Comment

by:bmeyer1908
ID: 23712176
It's been said above,  Here's a working trunk interface.

interface FastEthernet0/2
 
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex full
 speed 100
0
 
LVL 2

Author Comment

by:chesterzoo
ID: 23712367
I was also under the impression that because I was running 2 separate links from the HP that I would not need to use Tagging or a trunk link...

and I take it the more i restrict the allowed VLAN;s the quicker it would be?

I have just been out to each switch and put the new commands up, I will post the new configs up now...
hostname Switch
ip subnet-zero
vtp domain CZOO
vtp mode transparent
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
vlan 2
 name VLAN2
!
vlan 4
 name VLAN4
!
vlan 5
 name VLAN5
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
 switchport access vlan 5
!
interface FastEthernet0/10
 switchport access vlan 5
!
interface FastEthernet0/11
 switchport access vlan 5
!
interface FastEthernet0/12
 switchport access vlan 5
!
interface FastEthernet0/13
 switchport access vlan 5
!
interface FastEthernet0/14
 switchport access vlan 5
!
interface FastEthernet0/15
 switchport access vlan 5
!
interface FastEthernet0/16
 switchport access vlan 5
!
interface FastEthernet0/17
 switchport access vlan 5
!
interface FastEthernet0/18
 switchport access vlan 5
!
interface FastEthernet0/19
 switchport access vlan 5
!
interface FastEthernet0/20
 switchport access vlan 5
!
interface FastEthernet0/21
 switchport access vlan 5
!
interface FastEthernet0/22
 switchport access vlan 5
!
interface FastEthernet0/23
 switchport access vlan 5
!
interface FastEthernet0/24
 switchport access vlan 5
!
interface GigabitEthernet0/1
 switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan5
 ip address 192.168.5.254 255.255.255.0
 no ip route-cache
!
ip http server

Open in new window

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 23712578
>I was also under the impression that because I was running 2 separate links from the HP that I would not need to use Tagging or a trunk link...

This is correct. As long as you don't have more than 2 VLANs.

Config looks okay to me... But where did VLAN 2 and 5 come from?

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23712619
That config looks fine.  I assume the others are the same?

How are you testing?  From a 192.168.5.x machine, you should be able to ping 192.168.5.1 or another 192.168.5.x machine on a different Cisco switch.

If still not working, can you post a "show vlan" and "show int trunk".
0
 
LVL 2

Author Comment

by:chesterzoo
ID: 23712641
how come you can't have more than 2 vlans?

they were manually setup for future use...

the problem seems to be when pinging from switch to switch the first packet drops out, its seems like a slow/failed arp request.
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 600 total points
ID: 23712691
If you are not doing trunks, you will need a separate link for each VLAN. So you can have as many VLANs as you want. But without additional access links or trunks between the switches, traffic from that VLAN will never leave the switch.

It's not unusual for the first ping packet to fail. I can timeout while ARP entries are created.
0
 
LVL 4

Expert Comment

by:CCI_IT
ID: 23712701
You can have as many vlans as the switch will handle.

If your Duplex or speed settings are off, you could have packet loss resulting in slower response times.
0
 
LVL 2

Author Comment

by:chesterzoo
ID: 23712738
Im testing by logging into the top cisco switch and pinging the gateway (192.168.5.1 - HP6108 port 5)

the cisco switch has 192.168.5.252 255.255.255.0 assigned to the VLAN5 Interface.

it drops the first packet and then pings <1ms forever after that... bloody weird!

the problem is, my tills that are sitting on that VLAN 5 are having problems with the chip and pin failing on the first few attempts... when pinging off the till the first couple of pings fail and then it seems alright after that.

If i put a static arp entry in, it seems to work fine...

from the 6108 i get 10 succesful pings to each switch... but from switch to switch it drops out!
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23712924
Are the tills communicating to another VLAN5 host or to something on VLAN1?

As a side note, configure the top switch in the diagram (the one that has the HP plugged into it) as the STP root:

conf t
spanning-tree vlan 1-4094 root primary

Then connect the bottom switch (Gig0/2) in the diagram to the top switch (Gig0/2) in the diagram.  This will provide some redundancy.
0
 
LVL 2

Author Comment

by:chesterzoo
ID: 23713061
Unfortunately I cant do that as there is about a 1km between the switches, they are connecting over GB Fibre.

And the tills are communicating with the Server that is on VLAN5 and its plugged into the Last Cisco Switch.

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 23713095
What's a "till"?
What switch is the server connected to?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23713100
Are there tills on the last Cisco switch (the same switch as the server)?  Any issues with those if there are?  Can you post a "show interface g0/1" from the last switch.  Which switch is the till on that you are working with?  Post a show int on the gig interface from that switch as well.
0
 
LVL 2

Author Comment

by:chesterzoo
ID: 23713158
I can only get to the first Cisco switch and the first HP at the moment.

There are tills on all of the switches.

So ill post a show int g0/2 from the first switch, thats the interface that goes to switch 2, I got the drawing ever so slightly wrong...


CedarHouse2950#show int gig 0/2
GigabitEthernet0/2 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 000f.24a6.dcda (bia 000f.24a6.dcda)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 2/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is SX
  output flow-control is off, input flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output 00:00:06, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 9255000 bits/sec, 2316 packets/sec
  5 minute output rate 5769000 bits/sec, 2300 packets/sec
     2370685535 packets input, 2831787528 bytes, 0 no buffer
     Received 210674360 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 73459 ignored
     0 watchdog, 39734267 multicast, 0 pause input
     0 input packets with dribble condition detected
     3566208645 packets output, 2136037758 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Open in new window

0
 
LVL 2

Author Comment

by:chesterzoo
ID: 23713172
heres the show vlan and show int trunk
CedarHouse2950#show vlan
 
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
2    VLAN2                            active    Fa0/24
4    VLAN4                            active    Fa0/17
5    VLAN5                            active    Fa0/22, Fa0/23
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
 
VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
4    enet  100004     1500  -      -      -        -    -        0      0
5    enet  100005     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0
 
Remote SPAN VLANs
------------------------------------------------------------------------------
 
 
Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
 
CedarHouse2950#show int trunk
 
Port        Mode         Encapsulation  Status        Native vlan
Gi0/1       on           802.1q         trunking      1
Gi0/2       on           802.1q         trunking      1
 
Port      Vlans allowed on trunk
Gi0/1       1-4094
Gi0/2       1-4094
 
Port        Vlans allowed and active in management domain
Gi0/1       1-2,4-5
Gi0/2       1-2,4-5
 
Port        Vlans in spanning tree forwarding state and not pruned
Gi0/1       1-2,4-5
Gi0/2       1-2,4-5

Open in new window

0
 
LVL 2

Author Comment

by:chesterzoo
ID: 23719459
Reply to Don,

a till is just basically a PC with Retail Point of Sale software running on it... and the server is in the Bottom Cisco

Cheers for all of your help guys!
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23720807
From the till, ping the server and post the output.

ping <server ip> -n 10
0
 
LVL 2

Author Comment

by:chesterzoo
ID: 23720910
C:\Documents and Settings\epos>ping 192.168.5.51 -n 10

Pinging 192.168.5.51 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.5.51: bytes=32 time<1ms TTL=128
Reply from 192.168.5.51: bytes=32 time<1ms TTL=128
Reply from 192.168.5.51: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.5.51:
    Packets: Sent = 10, Received = 3, Lost = 7 (70% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 23720937
Which switch does the till you pinged from reside on?

Is there a till on the bottom switch that has the server connected to it?   If so, do the same ping from that till to the server.
0
 
LVL 2

Author Comment

by:chesterzoo
ID: 23720989
This was on a till that sits in the same VLAN and on the same Switch as the server...

C:\Documents and Settings\groves>ping 192.168.5.51 -n 10

Pinging 192.168.5.51 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.5.51: bytes=32 time=285ms TTL=128
Reply from 192.168.5.51: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.5.51:
    Packets: Sent = 10, Received = 2, Lost = 8 (80% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 285ms, Average = 142ms

Im also going to attach a new visio drawing which shows the bits you might need!

So I was just pinging from EPOS31 to EPOS Server.  All on Cisco3.

Thanks
NETWORK.jpg
0
 
LVL 43

Assisted Solution

by:JFrederick29
JFrederick29 earned 1400 total points
ID: 23721027
Well, you can rule out your inter-switch links since its doing the same thing on a single switch.

Can you post a "show int fa0/10" (EPOS31) and a "show int fa0/22" (EPOS server).
0
 
LVL 2

Author Comment

by:chesterzoo
ID: 23721044
Give me half an hour, ill have to physically walk over to the switch and console into it...

I think i will enable telnet connections whilst im there! :)

Cheers
0
 
LVL 2

Accepted Solution

by:
chesterzoo earned 0 total points
ID: 23721818
right well I feel stupid now...

so I went to each switch and cleared the arp tables and then it turns out they all had a arp entry to the same little router, so i logged onto the router, and somebody had configured it as a bridge.

So all of the broadcast traffic was being being pushed through this little bridge when the other end of it was disconnected!

Needless to say thanks for everybodies hard work on this because without it I never would have found the culprit!

Thanks

Martin
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Suggested Courses
Course of the Month19 days, 4 hours left to enroll

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question