• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 208
  • Last Modified:

AVOID MESSAGE TO CONNECT TO SERVER TO RUN QUERYS

Hi,

Trought a remote conection with my server (SERVIDOR) I made an excel workbook whit five different querys (made with the get external data tool in excel) and all remote users that connect to my server could use the workbook without problem.

My problem starts when an user on the local network (not remote) try to open the same workbook. (I tried with a shorcut and with the file itself in the local computer)

The excel fail to connect to the database and a Window "SQL SERVER LOGIN" is open with the name of the server and all details for the conection and the box "use trusted connection" is selected...the only way to get the querys working is to uncheck this box and write "sa" in the user field....and this must be made 5 times (one for each query)...

How should I fix this in order that the computers in the local network could connect without have to login each time the workbook is opened ?

See attached picture of the windows I´m talking about.

Thank you for your help.
Roberto.
prompt.jpg
0
Pabilio
Asked:
Pabilio
  • 5
  • 2
1 Solution
 
J79123Commented:
Right click the query area and choose external data range properties.

There are two boxes 'save query definition' and 'save password'.. to be honest I don't know if you need both checked or only the password box, but on my queries have I both checked, and it never prompts me.
0
 
PabilioAuthor Commented:
Sorry J,

Where or when should I do that ?

If I right click on the query area at the excel spreadsheet the option: external data range properties there is no box for password or save query definition....only keep cell format and save password....

Maybe is due that I used New data base query instead of Import data ?

Any idea on how to change this will be really helpfull.
Thank for your time,
Roberto.
0
 
PabilioAuthor Commented:
help !!!
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
PabilioAuthor Commented:
These Querys are making me thirsty...
0
 
J79123Commented:
run the query.. set it up.. manually type in your password and all that. and have it shoot the data back to excel.
Even if it has no data.. you'll still get headers. Then right click near the headers.
0
 
PabilioAuthor Commented:
J,
The problem I think is not that Simple...
It has to be with this:
http://support.microsoft.com/kb/327572
And a problem to change in SQL SERVER that the conection from the local computers to get querys could use a TRUSTED CONNECTION.
Thanks for your time.
Roberto.
0
 
PabilioAuthor Commented:
The solution was trough the SERVER ENTERPRISE MANAGER in the Server.
Security > Loggins
And then adding the user with administratives rigths in the database where the excel is taking the data.

Thank you for your time,
Roberto.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now