• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4003
  • Last Modified:

OWA not redirecting from HTTP to HTTPS

For some strange reason my exchange is not redirecting correctly.
This website http://mail.amazingfacts.org  should automatically redirect to
https://mail.amazingfacts.org     but something happened in the last few days that broke the redirection.  I didn't make any changes to exchange or DNS, so I'm puzzeled why it's not redirecting anymore.  Any thougts would be much appreciated.
0
afacts
Asked:
afacts
  • 10
  • 4
  • 2
  • +1
1 Solution
 
afactsAuthor Commented:
internally, the redirecting is working correctly, when I type mail.amazingfacts.org, it's redirecting to https://mail.amazingfacts.org, but it's not working externally.
0
 
Syedm2Commented:
Check IIS,that does Redirection
0
 
afactsAuthor Commented:
where do I even begin, where exactly do I check?  IIS on my exchange server, or my web server?
What website?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Syedm2Commented:
Exchange virtual directories on Exchange 2003 server.
0
 
afactsAuthor Commented:
I have exchange 2007 SP1, not 2003.
0
 
afactsAuthor Commented:
I found this:  http://technet.microsoft.com/en-us/library/aa998359.aspx
But I already had that setup, so for some strange reason, it's not working, but it looks like I have everything in plase.
0
 
MesthaCommented:
How are you doing the redirection? It isn't done natively.
There are two ways it can be done - via file redirect or a error page redirect.

-M
0
 
afactsAuthor Commented:
Well, I guess the redirection is done via IIS.  I did exactly what the microsoft article said, and I had already had everything setup, it just wasn't working.  I stopped and started IIS, and it seems that it's working now.  Not usre what happeend.  Since I selected  "a redirection to a URL" and then it says "OWS", and then I have selected "A diretory below URL entered" is selected.
But then under HTTP Error 403;4, it points to the SSLRedirect.htm file.    So does that mean it's using the  error page redirect?  Is hte file direct better?  If so, how do I do that instead?
0
 
jacodaletCommented:
Try the following.
Open IIS Manager
Right click on website container and choose properties
Click the home directory page
Select the option A Redirection to a URL, this will enable the option Redirect To. Enter in the box the URL to which you want to redirect users that connect to the default website, we are redirecting the user to https://mail.amazingfacts.org/owa
Select the A Directory below the URl entered radio button.
Click ok
Note that in a mixed environment you should use the legacy / exchange virtual directory as /owa will not allow access to Exchange 2003 mailboxes.
0
 
afactsAuthor Commented:
I only have excahnge 2007, I decommissioned exchange 2003 a few months ago.
Yea, I got it to work last time as well, it took me to the redirect page, but it didn't automatically redirect, I have to click on the link listed. So it doesn't automatically redirect, but it does bring up the right page.
0
 
MesthaCommented:
This is the method that I use:

http://www.amset.info/exchange/owa-defaultpage.asp

However if you want to do both the https switch and the removal of the /owa from the URL then you will have to use redirect code - that is usually nothing more than a auto refresh html code in a page called index.htm in the root of the server.

-M
0
 
afactsAuthor Commented:
Thanks, I've already done what hte above link said to do.  That's already done.
So what does it mean if when I go to mail.amazingfacts.org it shows me the redirect page, but it doesn't actually take me to the mail login plage?
0
 
MesthaCommented:
You haven't put the refresh part in correctly then.
The raw HTML should be something similar to what I have placed below.

-M


<html>
 
<head>
<meta http-equiv="REFRESH" content="0; URL=/owa/">
<title>Redirect</title>
</head>
 
<body>
 
<p><a href="/owa/">Redirect</a></p>
</body>
</html>

Open in new window

0
 
afactsAuthor Commented:
here's what I have in mine, the only difference is between hte content = o and 1
Did I do something wrong?

<html>
<head>
<title>HTML Redirection to https:</title>
<META HTTP-EQUIV="Refresh"
CONTENT="1; URL=https://mail.amazingfacts.org/owa">
</head>
<body>
This page is attempting to redirect you to <a href="https://mail.amazingfacts.org/owa/">https://mail.amazingfacts.org/owa</a><br>
If you are not redirected within a few seconds, please click the link above to access Outlook Web Access.
</body></html>
0
 
MesthaCommented:
I don't know if you have changed something, but it redirects for me.
If it isn't redirecting for you then check that you haven't got anything that is stopping the auto refresh from taking effect.

-M
0
 
afactsAuthor Commented:
thanks, yes, I had someone else externally test it and it's working, so it's cool, thanks for your help!.
0
 
afactsAuthor Commented:
Thanks for your help!
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 10
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now