Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

CDRom window freezes after eject and crashes Explorer.exe - PLUGPLAYMANAGER 257 is logged

Posted on 2009-02-23
5
Medium Priority
?
1,298 Views
Last Modified: 2012-05-06
Ok guys... I have a client that runs a Dell Optiplex GX620 with XP SP3... he has no real issues in anything else other than an odd issue that has been ongoing...

Basically, he uses the CDROM to view PET/CT's and CT Scans via eFilm ... When he ejects the CD, it does not refresh My Computer and will then freeze explorer.exe after a few seconds... Even if you close and restart Explorer.exe, you will continue to have issues... IE sites don't come up, network places is trashed... a reboot will fix the issue, but it is troublesome to have to do this every time you need to use a CD... also, it doesn't do it everytime, but it definitely does it most of the time...

Every time this phenomenon occurs, Event Viewer logs an error:
Event Type:      Warning
Event Source:      PlugPlayManager
Event Category:      None
Event ID:      257
Date:            2/23/2009
Time:            11:20:45 AM

Description:
Timed out sending notification of target device change to window of "C:\WINDOWS\Explorer.EXE"

Any ideas as to what I should do?  I have updated the chipset drivers and BIOS from Dell... I also ran Windows Update and installed anything they had to offer... the symptoms are still the same...

Thanks!
0
Comment
Question by:CCG9980
  • 2
  • 2
5 Comments
 
LVL 1

Expert Comment

by:nabeel_co
ID: 23713801
Does it happen in all user accounts? Can you create a new user account to test to see if it still happens?
0
 
LVL 63

Expert Comment

by:☠ MASQ ☠
ID: 23715927
Are they closing the runtime before ejecting?
The only time I've had this problem it has either been leaving the runtime open and hitting eject or that the disk creation left off some files from the runtime.  Anecdotally it's worth seeing if it happens while the user is an admin for the local machine and if XML is installed correctly (although this shouldn't really affect the runtime CD version it does interfere with eFilm-lite).  Merge seem particularly unhelpful about runtime errors unfortunately.
0
 
LVL 1

Expert Comment

by:nabeel_co
ID: 23716455
What I would recommend is:

1. Create a new user account and see if it still happens in there. If the problem persists, continue to number 2.  If it now works properly, then your user account has some software, or some configuration that is causing the problem.

2. Right click on "My Computer" choose "Properties"

3. In the "System Properties" window choose the "Hardware" tab.

4. Click the "Device Manager" button.

5. Click the "+" to the right of "DVD\CD-ROM drives"

6. Right click the offending drive, and choose "Uninstall"

7. Click the "OK" button.

8. Restart your computer.


If that doesn't work, then that may indicate bigger problems.
0
 

Author Comment

by:CCG9980
ID: 23722825
I have not tested it on other user accounts... it is a domain machine, so he will eventually need to use his account... I will try to recreate his account if it works fine on another login...

I did not try to reinstall the cd-rom drive, but I will certainly try that...

MASQUERAID:  I cannot confirm that he is closing the runtime before ejecting, but when I saw it last, the runtime was not on the screen when he called me to look at it... I will ask him... I'm not sure it is a Merge thing in particular, though... I believe it happens on audio or data cd's in general...

Thanks for the thoughts guys... I go onsite tomorrow... I will check it out and let you know...
0
 

Accepted Solution

by:
CCG9980 earned 0 total points
ID: 23734879
Ok, so I'm looking at the machine again today... the doctor already told me that he finished running efilm from a cd and it didn't crash this time... Unless the cd itself is the issue, I don't think it is related to JUST efilm at this point... I did however, run through some of the steps above:

1.  I uninstalled all the cd-rom devices from device manager... he has 2 devices... one is a DVD+RW the other is a DVD-ROM ... uninstalled both... I got this error in event viewer after the reinstall:
The driver detected a controller error on \Device\CdRom1.
Upon further inspection, the DVD-RW is in location 1... the other is location 0...
2.  I am about to reboot and try it with the administrator... I have no doubt that it will work fine, though, if his last attempt was fine too...

He did admit that he is definitely closing the software before hitting eject... he said that this time when he did the eject, he did it from windows explorer instead of the button... I don't know if that is the solution, but it may work for now... I will try the other user and write back my findings...

Thanks again!
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
The business world is becoming increasingly integrated with tech. It’s not just for a select few anymore — but what about if you have a small business? It may be easier than you think to integrate technology into your small business, and it’s likely…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
Suggested Courses
Course of the Month13 days, 15 hours left to enroll

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question