RWW File access issue

I have external users accessing our Intranet from outside the office and when they go to access any documents in the general documents folder. They are asked for their signon credentials every time they access a file. This even happens to me and I'm a administrator on the site. How can I change this?
DjrobluvAsked:
Who is Participating?
 
DjrobluvAuthor Commented:
I have a SBS2003 server setup at home and I am seeing the same issue with my server, leading me to think the problem is with the domain trust.
0
 
DjrobluvAuthor Commented:
Update: Looks like it has something to do with whether your computer is part of the domain. I had a user in the office who's PC is a member of the domain and she does not get the signon screen every time she opens a file. But my laptop which is not a member of the domain gets asked every time I go to open a file.
0
 
Fr0zTCommented:
Go into IIS and go to your web-site and then right click on the file/directory you are trying to share and then go to the Directory Security tab and check your settings here.  The behavior will depend on how you want people to authenticate, if at all.  If you don't require any authentication then just enable anonymous access. If you want public users to use their windows accounts then chances are you want to enable Basic Authentication, and set it up like this:
Default Domain:
\
Realm:
<Your Domain Name eg: domain.local>

But make sure you are using HTTPS for this otherwise you are sending passwords in clear text.

Use Integrated Windows Authentication for local users.
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

 
DjrobluvAuthor Commented:
Integrated Windows Authentication is selected. But it seems like this problem is happening with users who access the site with a PC that is not a member of the domain.
0
 
Fr0zTCommented:
Use Basic Authentication for them.  Make sure you are using SSL.
0
 
DjrobluvAuthor Commented:
That didn't work. I'm getting the same issue with opening a file.
0
 
DjrobluvAuthor Commented:
Now I created a file and put it into the General Documents folder and I can access it without being prompted to sign on.
0
 
Fr0zTCommented:
Did you setup the Realm and Domain?
0
 
DjrobluvAuthor Commented:
Please clarify setting up Realm and Domain. I'm dealing with 2 different domains. The only domain I see in the list is the domain the RWW runs on.
0
 
Fr0zTCommented:
In Directory Security when you enable basic authentication, you must specify the Realm, which translates to the domain name that you want to be responsible for authenticating users.
0
 
DjrobluvAuthor Commented:
Yes, I did that and it still doesn't work. Like I said I'm finding that if your PC is not a member of the domain that is hosting the RWW you have to login to access the files. Otherwise if your PC is a member you don't have to login you can just access the files.
0
 
Fr0zTCommented:
If all you want is totally anonymous access then you just enable anonymous access.  This may require that the directory has granted full control to NETWORK SERVICE.
0
 
DjrobluvAuthor Commented:
Problem I think I would run into is that this Server goes through a PCI Compliance Scan every 3 months and if I was to allow anonymous access to this system I guarantee they will fail PCI Compliance.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.