• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6617
  • Last Modified:

Unable to add user to log on as a service

I'm trying to have a user log on as a service. I'm unable to figure how to do this from Administrative tool>Local Security Policies, as the instructions for my software instruct me. The following error appears when I try to edit log on as a service:

 this setting is not compatible with computers running windows 2000 Service Pack 1 or earlier. Apply Group Policy objects containing this setting only to computers running a later version of the operating system.

This happens on a server that is running Windows 2003 SP2. Any ideas?
0
mdoten
Asked:
mdoten
  • 5
  • 4
2 Solutions
 
oBdACommented:
The message you're seeing is just a general informaiton. If you can't edit the local policy because the settings are greyed out, then this policy is defined by a domain group policy. You'll have to change the domain policy and add the account there, or make sure that the domain GPO setting this isn't applied to this machine.
0
 
mdotenAuthor Commented:
I'm not very familar with Active Directory, could you provide me the steps to complete this task and what steps to take to in order to allow for the user to log on as a service
0
 
oBdACommented:
Well, somebody must have configured a GPO defining this user right. You can check using either the Group Policy Management, "gpresult.exe /v", or rsop.msc from which GPO this setting is coming from; but if you didn't create this GPO, and you're not familiar with group policies, then you better ask the admin responsible for the group policies to change this setting.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
mdotenAuthor Commented:
I created the user, I'm simply looking for the easiest way to allow for "log on as a service" to be allowed for this single user. I'm familar enough with Active Directory to create GPO, but am unaware of where this option is.
0
 
oBdACommented:
I meant the creation of the *GPO*, not the user. You have an *existing* GPO defining this setting, and exactly this GPO needs to be changed.
The setting would be under Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignments.
0
 
wazoo9000Commented:
The issue is a policy effecting the computer, not the user.  What i mean is that it is not a user paramater that needs to be changed, but a setting in the GPO for this particular machine like oBdA stated above me.  I just wanted to clarify that point for you.
0
 
mdotenAuthor Commented:
Thank you, I moved the server into it's own OU and set it to allow the user to "log on as a service". I checked on the server and the user was included on the list.
0
 
oBdACommented:
On a side note: if you change the service account through services.msc, then this user right will be automatically given. But if, as in your case, this right is controlled by a domain GPO, then it's only good for a maximum of 90 minutes ...
0
 
mdotenAuthor Commented:
Will that cause any side affects to this?
0
 
oBdACommented:
No, that was just a general hint that you usually don't need to set this user right explicitly.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now