[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1453
  • Last Modified:

HTTP 403.1 Forbidden: Execute Access Forbidden

Hello expert,

Asked this question last week. Got a fairly vague answer about web server extensions under the iis MMC console. Have been through all the tabs and sections of the attached properties section of the web site and cannot find anything. I did find on the web site properties in IIS a tab called HTTP Headers that has a Mime Types, File Types, and I tried adding type extension ASP
but that did jot work and there is no such input on the other ASP sites that work fine but this new one I have added and checked against all the settings to make them identical still resuts in the 403 error.  

Question last week:

Need to relocate four web sites from Morrisville to Dallas. The guys that went before built the
the web sites as folders within the same web site and so when we took one down we had to take them all down.Planned to build four web sites on the web server. Went to new web service and opened IIS. Right clicked on the name of the machine at the top of the  tree, on the left, and chose New, Web Site.  This opens the Web Site Creation Wizard which allows one to name the site, set the IP address and browse to the directory which will be the root.  With this done I tried to go to the web site which is on the LAN
with http:\\ServerName\WebName and got.

The page cannot be displayed
There is a problem with a program on the page you are trying to reach, and the page cannot be displayed.
--------------------------------------------------------------------------------
Please try the following:
Open the labswirvg001 home page, and then look for links to the information you want.
Click the Refresh button, or try again later.
HTTP 403.1 Forbidden: Execute Access Forbidden
Internet Information Services
--------------------------------------------------------------------------------
Technical Information (for support personnel)
Background:
You have attempted to execute a CGI, ISAPI, or other executable program from a directory that does not allow programs to be executed.
More information:
Microsoft Support

So I tried localhost and got the same message. Any idea what might be casuing this?

Thanks.

Allen in Dallas

I added and html page to the web site and it resolves fine bu the ASP files resolve to the 403.
Other web sites in subfolders on the same web site work fine. But the local host and the new web site result in a 403.

Allen
Anonymous-user-account.gif
Athentication-Methods.gif
Web-site-properties.gif
0
Allen Pitts
Asked:
Allen Pitts
  • 3
  • 2
  • 2
1 Solution
 
cj_1969Commented:
Without knowing what it is trying to execute there are a few things you can try ...
1. In this last screen shot, change the execute permissions to Scripts and Executables
*** Restart IIS and see if this works
2. Change the Application Protection from Medium to Low
*** Restart IIS and see if this works
3. Check the permissions on the directory and share you are accessing the files on
- If this is a network share then you have a couple of things to look at.
   a. The Share permissions ... this is going to have to allow access to the credentials that IIS is passing from the server to the network resources
   b. The NTFS file permission ... same as point a

It appears you are trying to use anonymous access to the site to access a network share.  To do this you are going to have to grant the generic computer account access as the above mentioned areas.  I would also recommend that you use the local service account as I have had problems with the Network Service account and running executables.
0
 
wolfman007Commented:
First check that ASP pages are enabled as a Web Service Extension

To enable ASP pages
1. In IIS Manager, expand the local computer, and then click Web Service Extensions.
2. In the details pane, click Active Server Pages, and then click Allow.

Enabling ASP Pages in IIS 6.0 (IIS 6.0)
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/453cbc7c-942d-42c7-a10d-cf8703cc526b.mspx?mfr=true
0
 
wolfman007Commented:
Here is a screenshot of the Web Service Extensions.
web-service-extensions.JPG
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
cj_1969Commented:
Another thing to check ... DESPITE what you see if the IIS manager ... go to the add/remove program file and go into the Windows Components ... drill into the Web Server option and make sure that ASP is selected there also.  If it is not selected in the install it will still show up in the IIS Manager (it is considered part of the Windows install but will not be enabled for IIS be default).
0
 
Allen PittsBusiness analystAuthor Commented:
Had to create user at Web Server, My Computer, Manage, Users and Groups. Then, following the go-by from a working web site, include that user in the Administrator's group. Then go to IIS services manager and give permissions to the user in the folder taht houses the web site.
0
 
Allen PittsBusiness analystAuthor Commented:
AT the propperties f the folder in the web site in IIS manager grant Execute Permissions drop down choose Scripts Only instaed of the default None
0
 
cj_1969Commented:
IIS 7 must have changed the default ... the default used to be Scripts Only.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 3
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now