[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3392
  • Last Modified:

Acer Aspire M1610 Network Controller Issue

I have an Acer Aspire M1610 desktop that has Windows Vista Home Premium Edition. The PC was just restored using a brand new set of Acer Restore Disks. After swappng CDs and rebooting a few times, Windows Vista was back up and running fine. When I tried to connect to the internet, I find I can't. I check Device Manager and it shows Other Devices with 'Network Controller' with a yellow exclamation point. Just above it is the Network adapter showing as SiS191 Ethernet Controller. No colored marks. Shows working fine. I have done an IPCONFIG /ALL and it shows the static IP address that I gave it which is the exact same as the rest of the networked PCs. I am using a LinkSys wireless router WRT54G. I can ping loopback, I can ping the adapter, but I can't ping the router. The PC is connected to the wireless router via a cable. I have changed cables and also changed ports on the router. There is only a solid green light in the back of the PC. When connected to the router, the front shows a solid green light like the rest of them. I have uninstalled the controller and then rebooted, but it can find it, nor can I direct it to the correct location on the hard drive. I have even turned off the firewall trying to rule that out.

I really need help my fellow experts! This one has been on my desk for waaay tooo many hours!!

thanks in advance for all suggestions.
0
RSchierer
Asked:
RSchierer
  • 2
1 Solution
 
wantabe2Commented:
Sounds like you need to go to another computer, get online, download the NIC driver &/or the MB chipset & then manually install it on the other computer. Before you try this though, you can go into device manager, delete the one with the exclamation mark, then reboot. If it don't automatically install when rebooted, the driver is not on the install disk.
0
 
RSchiererAuthor Commented:
I have tried to find this missing 'Network Controller' file on ACER's website but to no avail. I also looked for an update to the chipset, but could not find that either. The PC's on the motherboard NIC may not be working properly or there is just something else at play. I read one thread on another board that mentioned that when you tried to connect to the internet, that instead of using the ethernet controller it defaulted to a WAN something. Don't remember the correct reference.

I am going to go buy a cheap NIC card and put it in and see if I can get the PC to recognize it and then I can connect to the internet, download my updates and get this thing back to the owner.

If you think of anything else, please let me know.

0
 
wantabe2Commented:
That might be your best bet. It sounds like some kind of hardware or driver issue.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now