Where to put WAR file? for top level URL

iI want my Tomcat app to run at  http://127.0.0.1/index.jsp instead of http://127.0.0.1/appname/index.jsp.

Right now it lives in the C:\Program Files\Apache Software Foundation\Tomcat 5.5\webapps\appname  folder, but I want it to see "appname" in the URL.

appname (obviously) is the name of the application. Seems like an easy one, but if the points are nto right, let me know.

what er the "gotchas" and how can I tell if the code it relative ( besides trying it)
stiavettiAsked:
Who is Participating?
 
objectsConnect With a Mentor Commented:
no worries. Perhaps check the context xml. It may have some answers

0
 
objectsCommented:
can your post your context xml

0
 
objectsCommented:
> Where to put WAR file?

rename it to ROOT.war

0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
stiavettiAuthor Commented:
First...thank you for taking interest. Guys like yourself make the IT world go around.

Here is the: context xml


 <?xml version="1.0" encoding="UTF-8" ?>
- <!--
  Licensed to the Apache Software Foundation (ASF) under one or more
  contributor license agreements.  See the NOTICE file distributed with
  this work for additional information regarding copyright ownership.
  The ASF licenses this file to You under the Apache License, Version 2.0
  (the "License"); you may not use this file except in compliance with
  the License.  You may obtain a copy of the License at

      http://www.apache.org/licenses/LICENSE-2.0

  Unless required by applicable law or agreed to in writing, software
  distributed under the License is distributed on an "AS IS" BASIS,
  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
  See the License for the specific language governing permissions and
  limitations under the License.


  -->
- <!--  The contents of this file will be loaded for each web application
  -->
- <Context>
- <!--  Default set of monitored resources
  -->
  <WatchedResource>WEB-INF/web.xml</WatchedResource>
- <!--  Uncomment this to disable session persistence across Tomcat restarts
  -->
- <!--
    <Manager pathname="" />
   

  -->
  </Context>
0
 
objectsCommented:
you should just be able to rename the war and redeploy it to t=omcat

0
 
stiavettiAuthor Commented:
Ok, I am going to try this tonight...possibly tommorow, and let you know. Once again, thanks for sticking with me..
0
 
stiavettiAuthor Commented:
This did not actually work, but I believe your answer to be correct.  I ended up just putting in a redirect instead, from the root...seems like a deficiency in the product.

So points are awarded, sorry for the delay.
0
 
stiavettiAuthor Commented:
Close enough for goverment work - "Objects Rocks!"
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.