Job Execution

I keep getting this error anytime i try to excute a job to run an SSIS package, can anyone tell me what im doing wrong?

Executed as userXXX\sqlservice. ...ion 9.00.3042.00 for 32-bit  Copyright (C) Microsoft Corp 1984-2005. All rights reserved.    Started:  12:07:16  Error: 2009-02-24 12:07:16.56     Code: 0xC0016016     Source:       Description: Failed to decrypt protected XML node "DTS:Password" with error 0x8009000B "Key not valid for use in specified state.". You may not be authorized to access this information. This error occurs when there is a cryptographic error. Verify that the correct key is available.  End Error  Error: 2009-02-24 12:07:17.11     Code: 0xC0202009     Source: refresh_style_colour_dims Connection manager "SourceConnectionOLEDB"     Description: SSIS Error Code DTS_E_OLEDBERROR.  An OLE DB error has occurred. Error code: 0x80040E4D.  An OLE DB record is available.  Source: "Microsoft OLE DB Provider for Oracle"  Hresult: 0x80040E4D  Description: "ORA-01017: invalid username/password; logon denied  ".  End Error  Error: 2009-02-24 12:07:17.11     Cod...  The package execution fa...  The step failed.
M_Boy76Asked:
Who is Participating?
 
chapmandewConnect With a Mentor Commented:
you may have to go into the package, and set the passwordencryption option to "do not save"
0
 
vinurajrCommented:
its purely invalid username/password; better try to reolve the username
0
 
M_Boy76Author Commented:
is it the account used to login into the other system or the account used to run the job?
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
M_Boy76Author Commented:
How do i do that?
0
 
nmcdermaidConnect With a Mentor Commented:
Right click on a blank spot in the designer and press properties.
In the properties pane, go to Security/ProtectionLevel
You probably have 'EncryptSensitiveWithUserKey' selected.
When the developer account (yourself) doesn't match the execution account (sql agent), it cant find the key to decrypt passwords.
There is a whole topic around package protection levels, but here are some solutions:
1. Only use trusted connections in your package, and pick a protection level of DontSaveSensitive
2. If you must use passwords in your package (i.e. if you have an AS400 source), pick EncryptSensitiveWithPassword and enter a password. Then use that password when scheduling it.
0
 
chapmandewCommented:
thank you nmcdermaid, I accidentally skipped over this response.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.