[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

SBS 2008 Outlook Anywhere RPC Error

Posted on 2009-02-24
67
Medium Priority
?
3,426 Views
Last Modified: 2012-05-06
I am testing my Outlook Anywhere connection using the Exchange Remote Connectivity Tester and am having issue with the RPC.  I keep getting the following error:
Attempting to ping RPC Endpoint 6001 (Exchange Information Store) on server j(servername.domain.local
  Failed to ping Endpoint
I have read a few other places that IPV6 needs to be disabled, but then I read that that is a bad idea on SBS 2008 because of how tied in it is.  Any thought on this or help with the connection issues would be much apprieciated.

Thanks
0
Comment
Question by:lahma35
  • 33
  • 27
  • 6
  • +1
67 Comments
 
LVL 40

Expert Comment

by:Philip Elder
ID: 23723304
You are trying to connect from the internal network.

Are you using the self-issued SBS certificate? For any remotely connecting Outlook Anywhere non-domain machine, you need to take a copy of the certificate file out of the Public\Downloads folder and put it on a USB stick to install on the remote machine.

Test it from outside the network after the certificate is installed on that machine.

Did you run the Internet Address Wizard and set your URLs up?

Philip
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23723311
you do NOT need to disable IPv6:
http://blogs.technet.com/sbs/archive/2008/10/24/issues-after-disabling-ipv6-on-your-nic-on-sbs-2008.aspx


try this:

Modifiy the Web.Config filder under C:\Program Files\Windows Small Business Server\Bin\webapp\SBS Web Applications\ as follows
Replace:
                 add name="HttptoHttpsRedir" precondition="" type="Microsoft.WindowsServerSolutions.IWorker.IIS.Modules.HttpToHttpsRedir,HttpToHttpsRedir,Version=6 .0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
To:
               remove name="HttptoHttpsRedir"
Do IISRESET.

References:

http://blogs.technet.com/asksbs/archive/2008/12/10/intermittent-outlook-anywhere-connectivity-in-sbs-2008.aspx

Intermittent Outlook Anywhere Connectivity issue in SBS 2008

http://blogs.technet.com/sbs/archive/2009/01/28/slow-connectivity-for-outlook-anywhere-and-sites-that-use-the-sbs-web-applications-app-pool.aspx

Slow Connectivity for Outlook Anywhere and Sites that use the SBS Web Applications App Pool

0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
LVL 1

Author Comment

by:lahma35
ID: 23723373
I have an SSL certificate that I purchased from GoDaddy installed on the server, and I am trying to setup the client to access the server from and external site.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23723392
0
 
LVL 1

Author Comment

by:lahma35
ID: 23723420
I did follow his directions when I installed it, and OWA and remote workplace not longer give me the certificate error so I am assuming that it is installed right.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23723556
and did you try to modify the web.config? (but first make a backup!)
0
 
LVL 1

Author Comment

by:lahma35
ID: 23723674
Is there a reason why I wouldn't be able to change the file?  My rights are administrator, but it won't let me save to that file.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23723753
hm, that should be possible though ... so that user is domain admin?
0
 
LVL 1

Author Comment

by:lahma35
ID: 23723780
yes user is a member of Domain Admins
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23723804
not that it matters, but maybe try stopping the IIS admin service.
I can easilly edit this file though ...
0
 
LVL 1

Author Comment

by:lahma35
ID: 23723809
NVM I was trying to save the copy file there and it was restricting me...the save worked fine.  I will let you know the results.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23723815
you are trying this with the C:\Program Files\Windows Small Business Server\Bin\webapp\SBS Web Applications\Web.config  , right?
0
 
LVL 40

Expert Comment

by:Philip Elder
ID: 23723841
You may need to elevate your Windows Explorer Window prior to editing, and then you will be prompted several times with no success.

Copy the file onto your desktop, make the changes there, then copy it back over the original file to get the changes back there. You will be prompted several times by UAC during the copy back process.

This behaviour is by design in Windows Server 2008 to protect system data.

Philip
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23723875
god I hate that UAC on an SBS :-)
0
 
LVL 1

Author Comment

by:lahma35
ID: 23723914
After the restart I can no longer remote desktop to my server.  And now I get a  RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime
Using the Exchange tester tool.
0
 
LVL 1

Author Comment

by:lahma35
ID: 23723960
Should have said I cannot remote the server using the Remote Work Place link.  I can remote it using the VPN connection.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23723974
hm, that fix should SOLVE that issue, not create it, damn microsoft.
can you copy paste the web.config?
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23723984
btw, port 443 is open and forwared to the server, is it?
is this woring internally btw? (rww that is)
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23724047
grmbl, I hate it that we can't edit our posts in EE, so another reply ...
the sbs blog says:
Updated 2/10/2009: Included new resolution.  If you already implemented the original resolution we recommend that you also implement the new resolution.  There is no need undo the previous fix.
0
 
LVL 1

Author Comment

by:lahma35
ID: 23724222
I just noticed that the file didnt save.  I am having issues saving that file.  I tried running Windows Explorer as Administrator with no luck.  Still get the permission error when I try to save the web file.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23724280
hm, you should be able to save that webfile though.
Did you check the permissions on that file?
maybe do a resart, could be that the file is open somewhere.
on my sbs servers I can just rename it, edit it etc.
0
 
LVL 1

Author Comment

by:lahma35
ID: 23724388
Got the file to save by saving it to the desktop and following the directions posted by MPECSInc.  I think I am getting closer because now the error that I am receiving is the following:

A network error occurred while communicating with remote host: Exception Details: Message: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond xx.xxx151.26:443 Type: System.Net.Sockets.SocketException Stack Trace: at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port) at Microsoft.Exchange.Tools.ExRca.Tests.TcpPortTest.PerformTestReally()

I know that port 443 is open because OWA works fine. So could it just be timing out?
0
 
LVL 40

Expert Comment

by:Philip Elder
ID: 23724391
Again:
 Copy file to desktop.
 Open file with Notepad.
 Make changes to file.
 Save Changes.
 Copy file back to original location.
 UAC --> Yes, Yes, and Yes to Copy and Replace.

Done.

Philip
0
 
LVL 40

Expert Comment

by:Philip Elder
ID: 23724411
May I suggest using an actual Outlook 2003/7 on a remote machine to connect to your profile using Outlook Anywhere? If you have a problem then, Outlook /RPCDiag will show you a window with status reports on its various steps during the hookup.
Philip
0
 
LVL 1

Author Comment

by:lahma35
ID: 23724454
I think I spoke to soon.  Now when I run the tester I get the same results as before.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23724459
I'me just wondering here ... did you change anything manually, because these errors are not normal ...
Did you change IIS setings, rpc dir, certificate, .... ?
and as philip said, are you trying this from an external location?
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23724468
and another thing ...
did you install all latest windows updates, inlcuding rollup 6 for exchange?
0
 
LVL 1

Author Comment

by:lahma35
ID: 23724475
Yes I am trying it from an external location.  The onlu thing I did was add a certificate to the server yesterday.  But I am not sure if Outlook Anywhere was working before that since it is a new install.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23724507
hm, so you are 100% sure you did everything correcly using this guide?
http://sbs.seandaniel.com/2009/02/installing-godaddy-standard-ssl.html
did you also configure the autodiscover?
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23724528
0
 
LVL 1

Author Comment

by:lahma35
ID: 23725478
I know I did have some issue installing the cert using the method explained.  I basically got the cert and added it using the cert wizard on the SBS.  Is there a way I can check to make sure it is correct?
0
 
LVL 40

Expert Comment

by:Philip Elder
ID: 23725665
MMC --> UAC (Continue) --> Add/Remove Snap-in --> Certificates (Computer) --> OK.

In the Personal certificate store folder you should see the attached two screenshots.

The Store shot is what you should see in the actual certificate store. Those are the pool of certificates that the SSL wizard will pull from once you ran the install portion of the wizard to get the cert in.

The second shot shows that the cert is properly installed as it indicates that the Private Key status is shown at the bottom of Certificate Information. I am assuming that your GD certificate shows the same?

Philip
09-02-24-SBS-Certificate-Store.PNG
09-02-24-SBS-Certificate-Store--.PNG
0
 
LVL 1

Author Comment

by:lahma35
ID: 23726044
The Cert is correct.  I think I will try and reboot the server tonight and see if that resolves the issues.
0
 
LVL 40

Expert Comment

by:Philip Elder
ID: 23726647
Okay, next step:
 Check that the ceritificate is correctly bound in IIS.
Screenshot attached.

Philip
09-02-24-SBS-IIS-SSL-Binding-for.PNG
0
 
LVL 1

Author Comment

by:lahma35
ID: 23726907
Yes the certificate is correclty bound in IIS.
0
 
LVL 1

Author Comment

by:lahma35
ID: 23734659
After a reboot then Outlook Anywhere is working, but I had a different issue arise.  I used to be able to use internet explorer and type in the certificate registered name and have RWW come up.  Now it gives me a forbidden error and the only way for me to get it to come up is the type cert name, https://remote.(domain).com\remote.  The links on the RWW do not work either.  They are trying to get to https:\\sites\xxx.  Let me know if I need to open a new question for this or if you have any insight as to how I can fix this.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23734714
that is normal behaviour.
the default url for RWW is: https://remote.yourdomain.com/remote
it's also normal that the links are pointing to /sites/xxx
0
 
LVL 1

Author Comment

by:lahma35
ID: 23734750
is there a way to change the two so that I can type https://remote.mydomain.com and have RRW come up?  Also, with the sites link it makes me log in again.  I know it was working differently earlier this week.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23734762
or no, that is not normal (the /sites), I had this issue also, forgot the solution, need to look it up
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23734773
" https://remote.mydomain.com", normally that should work by default.
it should redirect you to  https://remote.mydomain.com/remote automatically
0
 
LVL 1

Author Comment

by:lahma35
ID: 23734795
Yes that was what used to happen and now the redirect is not happening.  I tried redoing the Internet wizard thinking this would recreate the IIS pages and correct the problem but that did not work.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23734813
and the fix my network wizard?
0
 
LVL 1

Author Comment

by:lahma35
ID: 23734840
Haven't tried that.  Let me give that a try and I will post the results.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23734896
aaaaaah, I knew I saw this befor, and it was Philip who solved it :)µ
http://blog.mpecsinc.ca/2008/08/sbs-2008-wizard-cannot-configure-remote.html
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23734912
phew this is getting a long one :-)
I forgot one major question ...
was this a clean install or a migration?
0
 
LVL 1

Author Comment

by:lahma35
ID: 23735011
Clean install and the repair network did not resolve the issue.  Any other thoughts?
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23735032
Have to think about this ... we WILL find this, but now I'me goint to eat smth :-)
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23735498
did you read my article?
http://sbs.editme.com/sbs2008certprobs
check your bindingsagain, what are they pointing to? not to http://sites, are they?
still the wizard(s) should solve this issue .... strange
0
 
LVL 1

Author Comment

by:lahma35
ID: 23735691
Bindings are all correct.  Could it be related to the web.config file changes I did?
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23735713
you -could- change them back to the way it was, although I don't know that would help.
I still think it has smth to do with your Godaddy cert.
I would remove it and reinstall it completely by the guide I gave you.
0
 
LVL 1

Author Comment

by:lahma35
ID: 23735731
Do I follow a wizard to remove it or manually remove it?
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23735748
always the wizards in sbs, always the wizards
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23735755
actually ... I wonder if it works with the self signed cert, do that test too please.
0
 
LVL 1

Author Comment

by:lahma35
ID: 23735947
I will try it tonight since I do not want to mess with the working Outlook Anywhere now.  There are 5 remote users using that today.  I appriciate your help and will post my results tonight.  Thanks again.
0
 
LVL 1

Author Comment

by:lahma35
ID: 23771641
Well still no change.  I am still getting the errors and I get the same errors with the self served cert also.  Any other ideas as to what is going on?  I reinstalled the cert, fixed the network, reinstalled the internet connection, and setup the internet domain.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23772045
can you give me the error(s) again please?
So you are gettings these erros on ANY external pc, right?
So this is OWA and RWW that aint working, right?
0
 
LVL 1

Author Comment

by:lahma35
ID: 23772061
No they are working, but if I do not type the exact address like https://remote.domain.com/remote it give the attached error.  This error is gotten from the server, so it has a bit more information on it.
error-from-server.PNG
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23772076
aaaaaaaaaah, off course you are getting that error.
you need to type in the exact address as the cert says.
if your cert is 'remote.yourdomain.com' you need to type:
https://remote.yourdomain.com/remote for rww
and
https://remote.yourdomain.com/owa for exchange

but you cAn change this:
http://www.sbstraining.net/post/2009/01/SBS-2008-remotedomain-prefix.aspx
0
 
LVL 1

Author Comment

by:lahma35
ID: 23772098
Shouldn't https://remote.mydomain.com forward to RWW?  Before I installed the certificate this forward was done. Or is there a way I can do this with a dns setting?  I really appriciate your help on this. :)
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23772416
yes, it should forward indeed, by default.
So it works with https://remote.mydomain.com/remote
but not with https://remote.mydomain.com  ??
in the DNS tool you should see a remote.mydomain.com which has a SOA, A and NS record.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23772420
actually, it should redirect you to:
https://remote.mydomain.com/Remote/logon.aspx?ReturnUrl=%2fremote%2fdefault.aspx
0
 
LVL 1

Author Comment

by:lahma35
ID: 23772458
I see those 3 entries in the DNS.  That all looks correct.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23772522
hm, so it doesn't resolve to https://remote.mydomain.com/Remote/logon.aspx?ReturnUrl=%2fremote%2fdefault.aspx, does ot?
what happens then when you type in https://remote.mydomain.com/  ??
and does it work with https://remote.mydomain.com/Remote/  ??
0
 
LVL 1

Accepted Solution

by:
lahma35 earned 0 total points
ID: 23772602
https://remote.mydomain.com/Remote/logon.aspx?ReturnUrl=%2fremote%2fdefault.aspx - This resolves
https://remote.mydomain.com/ - This does not resolve. I get the 443 error
https://remote.mydomain.com/Remote/ -  This does resolve.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 23774000
hm, not sure about the resolving .... that I'll need to look into.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
Steps to fix error: “Couldn’t mount the database that you specified. Specified database: HU-DB; Error code: An Active Manager operation fail”
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
Suggested Courses

872 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question