• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2064
  • Last Modified:

Internet Explorer 7.0 reports cipher strength: 0bit

I have got a version of Internet Explorer that will not go to any secure websites.  It is also reporting a cipher strength of 0 bit.  I have tried everything I can find online to solve this.

I've restored windows to a previous date when IE was working, I've tried removing IE7 and re-installed it, I've even tried IE8 against my better judgment.  I've used a program called dial-a-fix to re-register all of the IE dll files.  I'm sure there are other things I'm forgetting at this point.

This is a computer that I am really trying not to re-install Windows on.  As a last resort that will happen, but I'd rather find a solution to the problem.

The problem initially started when the machine semi-crashed(I believe due to malware/viruses).  I've since cleaned it up and have everything back to normal except IE7 and oddly enough iTunes will not launch either.  Any help would be greatly appreciated.
ie7about.JPG
systemproperties.JPG
0
1scs
Asked:
1scs
  • 4
  • 2
1 Solution
 
mayank_chaudharyCommented:
Perform the following:
1. Delete cookies, History and offline files and folders in internet options
2. on content tab (in internet option) clear ssl slate
3. On advanced option check SSL 2 and 3 both, check TSL also
4. On same tab (advance) uncheck 3rd party browser extension
5. click ok and restart computer
6. Once done download the attached file.
7. open and save as "a.bat"
8. run the batch file
Problem will be take care off
0
 
johnb6767Commented:
How long have you had SP3 installed, and did this start happening when this was installed?
0
 
1scsAuthor Commented:
Windows was actually originally installed with a Service Pack 3 CD.  There is no way to uninstall SP3.
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
1scsAuthor Commented:
**6. Once done download the attached file.
**7. open and save as "a.bat"

I don't see an attached file here...
0
 
1scsAuthor Commented:
Thanks for the help guys, unfortunately I've run out of time for an easier solution.  I'm going to have to bite the bullet and do a repair-reinstall of windows, or just a regular re-install of windows.
0
 
mayank_chaudharyCommented:
start>run > regsvr32 softpub.dll
start > rum >regsvr32 jscript.dll
start > rum >regsvr32 vbscript.dll
0
 
1scsAuthor Commented:
I just ended up doing a repair install of windows and it solved the problem. Thanks for the help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now