[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cisco Advanced security IOS will not load on a 2810 router using TFTP

Posted on 2009-02-24
6
Medium Priority
?
679 Views
Last Modified: 2012-05-06
I was attempting to update the standard ISO to c2800nm-advsecurityk9-mz.124-20.YA.bin on a 2810 router using TFTP.  I verified connection from the host machine to the router and verified that we had enough RAM and Flash.  Using the copy tftp flash command everything looks and runs well, until about 46 to 50% the command line prompt changes from !!!!!!!! to 00000000000 on a consistent basis.  If I watch the TFTP services window on my local machine it will continue to load the ISO file past the 100% mark.  I tried this a few times and on another computer and a different router with the same results.  At that point I even tried a lower version of the advance security IOS.

We were able to send back the original standard ISO via TFTP to get the routers working.  I have not seen this before especially the 0000000000 instead of the !!!!!!! on the router during installation.  Any ideas.
0
Comment
Question by:ctrav505
  • 3
  • 2
6 Comments
 
LVL 5

Expert Comment

by:ionut_mir
ID: 23725500
I had this situation with a switch, but I think this is the same. In my case tha problem was that there were not enough room.
Tho "OOO" I think it means time out.
Try to erase the current image on the flash and then start the transfer.

Hope it works!
0
 
LVL 11

Expert Comment

by:donmanrobb
ID: 23726037
You can also use show version and show flash to see how much free space you have.
0
 

Author Comment

by:ctrav505
ID: 23728094
We did verify that there was plenty of room before we started with the IOS upgrade.  I saved a copy of the old IOS and then deleted it before we started the upgrade.  So the 000000000 may mean that it was timing out.  I did not get any 00000000 when I replaced the old IOS to get the routers working, nothing but !!!!!!!!!!!!!!!.  I thought that ......................... meant that it was timing out.  In any case I have not seen the 0000000000 before.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 11

Accepted Solution

by:
donmanrobb earned 1500 total points
ID: 23729067
If its a large IOS image the tftp might not be able to handle it, you might have to use FTP instead
0
 

Author Comment

by:ctrav505
ID: 23730367
The file is 35 MB twice the size of the standard IOS.
0
 

Author Comment

by:ctrav505
ID: 23902703
Looks like the issue was a older version of Solar Winds TFTP server.  We downloaded the newer version and it worked.  It must have been an issue with the file size.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
How does someone stay on the right and legal side of the hacking world?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…

872 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question