Avatar of CLL
CLL
 asked on

Convert MBR to GPT

Hi All,

We have just purchased a new SAS attached storage system which has been configured in RAID 5 and a logical drive has been created of 7.5TB

When we go into Disk Manager on the server the disk appears as a 7.5TB disk but when we initialize the disk it shows a 2TB partition (usable) and a 5.5TB partition that cannot be used.

If we try using diskpart to convert the disk to GPT we get the following error message "The disk you specified cannot be converted to GPT Please select an empty basic MBR disk to convert."

The server is running Windows Server 2003 SP2 (See attached Winmsd)

Any help in resolving this would be greatly appreciated.
winmsd.txt
StorageWindows Server 2003

Avatar of undefined
Last Comment
NetRolller3D

8/22/2022 - Mon
CLL

ASKER
I forgot to mention that if we format the 2TB partition this works fine but we then do not have access to the remaining 5.5TB.  I would also prefer not to create 4 x 2TB Logical drives in the storage system and than join them together in Windows.
andyalder

Strange that a 2TB partition appeared all by itself when you initialized the disk, have you tried deleting it and then converting the disk to GPT after that?
CLL

ASKER
Attached is a screen shot of what the disk looks like after it is initialized but before we attempt to convert to gpt. If I remove the disk, reboot and try converting the disk to gpt before the initialize while it is still showing as a single 7.5TB partition I get an error stating that the disk must be initialized first.

When I initialized the 7.5 TB disk and that resulted in it splitting it into two parts, a 2 TB and 5.5 TB part. They are not partitions because when I right click on the 2 TB part, it gives me an option to create a
partition.
With-split-partitions.jpg.bmp
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
andyalder

Most strange, but you do have perfect disk installed, maybe that's doing it.
CLL

ASKER
Still no luck after uninstalling perfectdisk. Going to try installing windows server 2008 and see if that works.
ASKER CERTIFIED SOLUTION
andyalder

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
xG5

This happened to us also.  You need to convert to GPT to be able to see drives bigger that 2TB. The problem is that you cant convert a drive to GPT if it has any data or partition information on it.
We added another drive outside the RAID5 array as the Operating system then converted the RAID5 to GPT when we loaded into the OS.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
CLL

ASKER
Problem was a compatibility issue between the Adaptec SAS HBA and either the server or the storage system. As soon as we switched to an LSI SAS HBA we could easily convert to GPT and use the entire LUN.
NetRolller3D

There is an open-source tool called gptgen (https://sourceforge.net/projects/gptgen/ - yes, it's my project), which can convert an MBR disk to GPT, while preserving data on the disk. The only requirement is that there must be enough space at the beginning and end of the disk/array (beginning is usually not a problem because in MBR, partitions must be aligned on cylinder boundaries, and a cylinder is usually larger than the 34 sectors needed for conversion; the end can be tricky, but if the data is already on a disk/array larger than 2 TB, as in your case, it's unlikely that you will have problems), and that the disk must not be dynamic. (If anyone can point me towards documentation of the dynamic disk format, I will be grateful.)

So, this is what you need to do:

-Backup the MBR & partition table of your HDD (just in case something goes wrong).
-Download gptgen (package contains source code and a precompiled Windows binary)
-Run "gptgen -w \\.\physicaldriveX" (X is the number you get from diskpart's "list disk" command). If it complains about free space, resize your partitions with a partition manager (Gparted is an excellent open-source tool), and run gptgen again.
-Reboot, and Windows should recognize your disk as GPT.
-Expand the GPT partition to the desired size (diskpart is recommended, but Gparted can also do this).

(Note that this merely converts the existing partitions to GPT format, and does not create Microsoft's required partitions, e.g. EFI system partition, MS Reserved partition, etc. - you need to create those partitions yourself after the conversion if you need them.)
AviationAce

@NetRolller3D
I tried running gptgen.exe on my machine.
I got the following error message: "The subsystem needed to support the image is not present"

NOTE: I had booted from a Windows 10 CD.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
NetRolller3D

The prebuilt exe is IIRC compiled for 32-bit Windows. It will run on a full install of 64-bit Windows, but likely not on 64-bit WinPE, which may not have the required WoW64 subsystem.