Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

WSUS Corrupted on SBS. Cannot open databse "SUSDB" requested by the login.

Avatar of compuchicks
compuchicksFlag for United States of America asked on
SBS
4 Comments1 Solution17309 ViewsLast Modified:
Hi Experts.  There's a major problem with the WSUS configuration on our SBS R2 with SP2.  We rebuilt the server last month and since then have had frequent errors in the Application log.  
The majority of the errors are as follows:
1.  Event ID 421 - Windows Server Update - Connection to the database failed. Reason=Cannot open database "SUSDB" requested by login. The login failed. Login failed for user 'NT AUTHORITY\SYSTEM'. Connection string: Net=dbnmpntw;Data Source=\\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query;;Initial Catalog=SUSDB;Connection Timeout=60; Application Name=WSUS SQL Connection; Trusted_Connection=Yes;Pooling='true'
2. Event ID 18456 - Source: MSSQL$MICROSOFT## - Category (4) - Login failed for user 'NT AUTORISTY\NETWORK SERVICE'. [CLIENT:<named pipe>]

In the beginning of Feb 2009, we had to reconfigure drive partitions so backed up the entire server, reinstalled SBS from CD, installed updates from Microsoft and restored data.  We had some problems but everything was repaired except Monitoring and Reporting and WSUS.  Last week, Monitoring and Reporting was fixed by Maintenance, Uninstall and Reinstall procedures.  

A couple of other specifics:
In the original install of SBS in 2007, WSUS 2.0 was installed.  It worked but we didn't use it.  The original DB's were on the C: drive.  When we started running out of space, the DB's were moved to the D: partition using commands.  After the move, WSUS still worked.  Then we did an upgrade to WSUS 3.0.  After that, we could see the WSUS 3.0 MMC, could connect to the server DB but couldn't add devices.  BTW, WSUS was installed using Windows Internal DB.  One other thing, Update Services 3.0 doesn't show up on Add/Remove programs.  I've tried to uninstall 3.0 using WsusSetup on Program Files\Update Services\setup but that fails, too.

This is the last thing outstanding and just can't seem to figure out what the login issue is.  Can anyone please assist?
ASKER CERTIFIED SOLUTION
Avatar of Don
DonFlag of United States of America imageNetwork Administrator

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 4 Comments.
See Answers