Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

DCOM error 10009 causes REM to stop and the backup to fail.

Avatar of andyrob-davis
andyrob-davis asked on
Programming Languages-OtherWindows Server 2003
2 Comments1 Solution500 ViewsLast Modified:
On a Windows 2003 SP2 domain controller I have a backup script which runs as a scheduled task most nights when it runs immediately after the script initiates a DCOM error appears in the event log

"DCOM was unable to communicate with the computer %Computer Name% using any of the configured protocols"

The computer does not exist in the network though I did find an entry for the server FHC_2K3 in the scheduler registry entry under the Oldname entry which I changed. there was also an entry under ShellNoroam though I doubt this was causing the problem. I have checked all the DNS entries and nothing appears for FHC_2K3.

I have also flushed the DNS cache in DNS and using ipconfig.

About 30 mins later another event log shows the RSM service has stopped and thus the backup fails.
If however, I connect from home and set the scheduled backup task to run say in five minutes time it works perfectly with no DCOM error.

This is a complete pain as I have to dial in every night and manually start the backup so any help greatly appreciated.

Non of the suggested fixes so far have worked.
ASKER CERTIFIED SOLUTION
Avatar of andyrob-davis
andyrob-davis

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 2 Comments.
See Answers