Link to home
Create AccountLog in
Avatar of sqlagent007
sqlagent007Flag for United States of America

asked on

SQL server 2005 on windows 2003 server with 16GB of RAM /3GB switch cauasing problems

With very large SQL 2000 installs, I always put the following switches in the boot.ini file:

/3GB /PAE

I have just brought up a new SQL 2005 instance on a Windows 2003 server with 16GB of RAM. I added the /PAE, rebooted, and everything worked fine.

Once I added the /3GB switch, I started getting wierd errors like: "cannot connect to SQL server, not enough system resources". So I removed the /3GB switch and now things seem to work fine.

Is /3GB still needed to allow SQL server 2005 to allocate more than 3GB of RAM to the instance? What has changed that I am not aware of?

thanks all!
Avatar of reb73
reb73
Flag of Ireland image

IS AWE enabled on the server?

If yes, have the max server memory in SQL Server configuration properties been restricted to say about 14GB?? If not, restrict the maximum memory available to SQL Server to around 14GB..

It looks like SQL is grabbing all the memory with memory available to OS and other applications being depleted
This is the advice I followed when I needed our SQL Server 2005 server to run 8GB:

[quote]
Set AWE to enabled.
Run SQL Server under a Windows account that has Lock Pages in Memory enabled.
The Maximize data throughput for network application option of Network Connection in Control Panel must be selected.
Add the /PAE switch to the boot.ini OR the /3GB switch (not both).  Test both to see which works better.  The /PAE switch is generally considered better.
[/quote]

Taken from: http://www.sqlservercentral.com/Forums/Topic412378-146-1.aspx
The /3GB switch needs to be removed only if addressing more than 16GB memory, otherwise it is recommended that it be included in the boot.ini.. This enables SQL Server to take up 3GB of the 4GB base memory and will aid performance..

The /PAE is required to address memory beyond 4GB, so you need both /3GB and /PAE
Avatar of sqlagent007

ASKER

OK, I configured AWE, then re-added the /3GB switch and rebooted node1. On reboot I had the same issues: cluster service did not start, I could not log in through terminal service, node1 could not talk to the domain.

I removed the /3GB from the boot.ini and rebooted and everything worked fine.

I am truly stumped on this one.....
ASKER CERTIFIED SOLUTION
Avatar of sqlagent007
sqlagent007
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account