Link to home
Create AccountLog in
Avatar of Jonathan Mellon
Jonathan MellonFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Service Pack 2 for Exchange 2003 Fails to install with "A fatal setup error has occured..."

The error message reads "A fatal setup error has occured. Look at C:\Documents and Settings\Administrator\Local Settings\eventlog.txt for more details. Cancelling setup.

Microsoft Update offers no updates for Exchange.  Under system Manager the Server version is clearly Service Pack 1.

EVENTLOG.TXT
[02/26/09,19:08:28] Setup.exe: GetGlobalCustomProperty(B51015E7-26A5-4c8f-B871-26ABA9BEFB65)
[02/26/09,19:08:28] Setup.exe: LoadSetupDatabase()
[02/26/09,19:08:28] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:28] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:28] Setup.exe: IsRunningUnattended
[02/26/09,19:08:28] Setup.exe: AddGlobalCustomProperty
[02/26/09,19:08:28] Setup.exe: IsRunningUnattended
[02/26/09,19:08:28] Setup.exe: inside ISetupManager::LoadHelpManager()
[02/26/09,19:08:28] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:28] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:28] Setup.exe: ISetupManager::LoadCommandLineMgr() completed
[02/26/09,19:08:28] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:28] Setup.exe: ISetupManager::LoadSetupLog() completed
[02/26/09,19:08:28] Setup.exe: ISetupManager::RunIntro() starting
[02/26/09,19:08:28] Setup.exe: inside ISetupManager::LoadDependencyMgr()
[02/26/09,19:08:28] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:28] Setup.exe: inside ISetupManager::LoadCDInfoMgr()
[02/26/09,19:08:28] Setup.exe: GetCustomProperties()
[02/26/09,19:08:28] Setup.exe: get_CustomProperties()
[02/26/09,19:08:28] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:28] Setup.exe: inside ISetupManager::LoadTemplMgr()
[02/26/09,19:08:28] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:28] Setup.exe: inside ISetupManager::LoadDiskInfoMgr()
[02/26/09,19:08:28] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:28] Setup.exe: inside ISetupManager::LoadUIManager()
[02/26/09,19:08:28] Setup.exe: in RegisterSetupService()
[02/26/09,19:08:28] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:28] Setup.exe: GetGlobalCustomProperty({0DC70217-9545-11D2-ACD4-00C04F8EEBA1})
[02/26/09,19:08:29] Setup.exe: IsRunningUnattended
[02/26/09,19:08:29] Setup.exe: GetGlobalCustomProperty({AA62DF98-3F2C-11D3-887B-00C04F8ECDD6})
[02/26/09,19:08:29] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:29] Setup.exe: inside ISetupManager::LoadAccountManager()
[02/26/09,19:08:29] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:29] Setup.exe: inside ISetupManager::LoadValidationManager()
[02/26/09,19:08:29] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:29] Setup.exe: inside ISetupManager::LoadDependencyManagerUI()
[02/26/09,19:08:29] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:29] Setup.exe: inside ISetupManager::LoadServerGroupManager()
[02/26/09,19:08:29] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:29] Setup.exe: inside ISetupManager::LoadChangeFolder()
[02/26/09,19:08:29] Setup.exe: in InternalRegisterSetupService()
[02/26/09,19:08:29] Microsoft Search: Initialize, Search not installed.
[02/26/09,19:08:29] setup.exe: ***ERRORLOG EVENT*** : ModuleID not found in map in GetSetupComponentByModuleID() -- [{DA943894-7A14-4FFF-BBDC-C004FAE2310B}]
[02/26/09,19:08:29] setup.exe: ***ERRORLOG EVENT*** : ModuleID not found in map in GetSetupComponentByModuleID() -- [{94B7AD3E-0B63-42AC-A542-082ED1F78787}]
[02/26/09,19:08:29] setup.exe: ***ERRORLOG EVENT*** : ModuleID not found in map in GetSetupComponentByModuleID() -- [{ECD1A63D-DBAF-442C-BF46-904364A96B00}]
[02/26/09,19:08:29] Setup.exe: inside ISetupManager::LoadActionOverrides()
[02/26/09,19:08:29] setup.exe: ***ERRORLOG EVENT*** : ISetupComponent had an InstallProblem while trying to set install action override
[02/26/09,19:08:30] Dependency Manager: ***ERRORLOG EVENT*** : CDependencyManager::ValidateDependencyStates() : The dependency of Microsoft Exchange Messaging and Collaboration Services on Microsoft Search is not satisfied.
[02/26/09,19:08:30] Dependency Manager: ***ERRORLOG EVENT*** : Component default action settings do not satisfy dependencies. Components are being set to IR_NOTHING.
[02/26/09,19:08:30] setup.exe: ***ERRORLOG EVENT*** : Run() : RunLoadSetup(), an exception has occured.
[02/26/09,19:08:30] Setup.exe: IsRunningUnattended
[02/26/09,19:10:49] Setup.exe: RunUnLoadSetup()
[02/26/09,19:10:49] Setup.exe: UnloadSuiteComponents()
Avatar of Jonathan Mellon
Jonathan Mellon
Flag of United Kingdom of Great Britain and Northern Ireland image

ASKER

Can anyone help with this one as I need SP2 to install a OWA fix for Vista.  I have installed Windows Desktop Search 4.0 on the server and have been at this for days now.  Any help is very much appreciated.
ASKER CERTIFIED SOLUTION
Avatar of Mestha
Mestha
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Hi Mestha,

I tried SP1 first, that didn't work.  So I was going to reinstall Exchange using the SBS CD, however as part of this process it mentioned a component was missing so it repaired this.  Then I cancelled the setup.  SP2 installed correctly.

Thanjks for your help it wolved my issue.