Avatar of cyanidex
Flag for Malaysia

asked on 

Problem setting up DotNetNuke in IIS 7

Hi, I'm very new to DotNetNuke. I've just downloaded DotNetNuke v5.0 Starter Kit and installed it into my Visual Studio 2008 Team Suite.

My system consist of Vista Ultimate x64 SP1, IIS 7, Visual Studio 2008 Team Suite SP1, and SQL Server 2008 Developer Edition.
Using Visual Studio I created a new DotNetNuke website from the DotNetNuke Web Application template and named the new website as "TryOut" and choosing File System as the Location.

Next I went on and created a new empty database in SQL Server and named it "DotNetNuke" with Compatibility Level : SQL Server 2005 (90).
I modified the connection strings in web.config to
<add name="SiteSqlServer" connectionString="Server=(local); Database=DotNetNuke; Integrated Security=True;" providerName="System.Data.SqlClient" />
<add key="SiteSqlServer" value="Server=(local); Database=DotNetNuke; Integrated Security=True;" />

In IIS 7, under Default Web Site, I added a new Application with the Alias "TryOut" which points to the location where VS2008 extracted the template to. I left the Application Pool to DefaultAppPool. Then I pressed the "Test Settings..." button and I got 2 results. The first is Authentication which is okay and the other is Authorization which has a warning to it. The details of the warning is
"The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again."
I don't know what that is but I just closed it anyway and have that application created. Next I edit the permission of the new application created. Since there is no ASPNET account, I granted NETWORK SERVICE account to full control.

After everything seems to be in order, I launched my web browser and typed in the address
http://localhost/TryOut/Default.aspx and was redirected to http://localhost/TryOut/Install/InstallWizard.aspx
Here I can select my Installation Method and I chose Auto and pressed the Next button. And here is where the problem comes in.
I got a "ERROR: Could not connect to database specified in connectionString for SqlDataProvider" message.
I tried to Rebuild the website from within VS2008 and relaunched my browser but same thing happens.

So I went back into my VS2008 and press Ctrl + F5 (Start without debugging), VS2008 default webserver kicks start and my web browser was launched and redirected to http://localhost:8148/TryOut/Install/InstallWizard.aspx. As usual I selected Auto as my installation method and pressed the Next button. The installation proceeds as normal and after the installation has completed, I clicked on the "Click Here to Access Your Portal" link and I was redirected to http://localhost:8148/TryOut/Default.aspx which is the home page. Everything is normal and I can even login from here.

Then I tried to access the home page using my IIS 7 instead of VS2008 default webserver by http://localhost/TryOut/Default.aspx and all I got was "This site is currently Unavailable. Please check back later" message. Why can't I access DotNetNuke from IIS 7 but yet I'm able to do that from VS2008 default webserver?
I even changed the Application Pool to Classic .NET AppPool for the TryOut Application in IIS 7 but to no avail.

How do I get DotNetNuke to run under IIS 7? Please help. Thanks in advance.
Microsoft IIS Web ServerWeb-Based CMSASP.NET

Avatar of undefined
Last Comment

8/22/2022 - Mon