Link to home
Create AccountLog in
Avatar of robclarke41
robclarke41

asked on

Does Access work with DFS?

Hi there,
I'm having some trouble using Microsoft Access 2003 through a DFS setup.  I can only open access .mdb files (frontend) by going to file>open> and selecting the database.  If I double click on them or use a shortcut nothing happens.  Strangely if no one else is in the database I it works fine, which would lead me to believe it is to do with lock files but then why can I open the file by going to file>open?  Is there some kind of issue with DFS,mdb files and the way they are used?
Avatar of TextReport
TextReport
Flag of United Kingdom of Great Britain and Northern Ireland image

Problems with the LDB file is normally a loack of rights for the user, every user needs full rights to the folder the database is in.
If you are running from a shortcut then ensure the shorcut doesn't have /EXCL in it.
Finally ensure the default open mode is shared.
Cheers, Andrew
Avatar of robclarke41
robclarke41

ASKER

Hi Andrew,
Thanks for getting back to me so soon.  The user does have full access rights to the folder that the database is in.  I'm not just trying to run the database from shortcuts but even if I double click the original file nothing happens.  Also the default open mode is already set to shared!  If I access this from a normal mapped drive ie \\server\share\test.mdb it is fine the problem seems to arise when I open it from a DFS location ie \\domain.local\share\test.mdb.  I'm wondering if perhaps Microsoft did not intend for their DFS to be used with .mdb files?
"I'm wondering if perhaps Microsoft did not intend for their DFS to be used with .mdb files?" I doubt it but that doesn't mean it would work either. I have not used DFS but the above are the common areas of concern with access data files.

"The user does have full access rights to the folder that the database is in" I hear that from IT departments many time but they fail to notice that the user doesn't have create rights, this could be a restriction through DFS that is different from the file share but I don't know. If you can double click the MDB file in the DFS location then try and create a text file to ensure they have create rights.

Finally what version of Access are you running.

Cheers, Andrew
Hi Andrew,

I have double checked the permissions and the users do have full write permissions to the necessary folders and can create files inside them.  What do you make of the fact that I can open via file>open but not double click?

I'm running Access version 11.8166.8221

Cheers
Rob
If you can do a File Open then the problem must be with the default open mode. This is stored with the user in the System.MDW file that is in use.
Cheers, Andrew
Thanks Andrew, I'll check this out and get back to you
Avatar of Scott McDaniel (EE MVE )
The "Default Open Mode for Databases" option isn't stored in the workgroup file, but is instead stored in the Registry, under HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Access\Settings, in a key named "Default open Mode for Databases". The option is defaulted to "Shared", so if you've never changed from Shared to Exclusive, you'll not see this reg key.

This is a DWord value, and value for Shared is 0, the value for Exclusive is 1.

Be VERY careful if you decide to edit the registry. Always make a backup first. Problems in the registry can cause catastrophic Windows failures.
Hi Andrew,
When I opened Access and login to the workgroup I checked the path to the system.mdw file and all was correct I also checked the default open mode and this was set to shared?
Hi All,
The key didn't exist so we must have been defaulting to shared, I did add it anyway but it didnt make any difference so I still cant open access files by double clicking on them!
I'm not up on DFS, but as Andrew pointed out in his first post, issues like you're describing invariably result from permissions issues (and I can't tell you how many posts I've seen where the asker says "I am 100% confident the permissions are correct" only to come back later and report that they were not). That said, you seem to be confident this isn't the case, but you're also apparently not sure how Windows manages permissions in the DFS structure ... this would be an important area to explore.

First - are you working with a split application (i.e. tables in a separate file) or are you working with a single file (i.e. tables, forms, reports etc in the same file)? If you're not, then with a DFS and "logical drives", I'm not sure how you'll go about effectively working with this.

When you open via the File - Open method, where is the lockfile created (i.e. the .ldb file that Access opens anytime you work with a database)? It should be in the same folder as your Tables, assuming a split file architecture.

If you open the file via File - Open, can other users then open this same file?

Ok, I'll go and check and double check the permissions although DFS is supposed to work like any other share in which the rights granted over the share are those of the logged on user.  

I am working with a SQL backend and we just use access for the front end.

When I use file>open the .ldb file is created in the same folder as the .mdb and other users can access the same file with no problems - unless they are accessing it via a DFS path!
<I am working with a SQL backend and we just use access for the front end.>

Can you not deploy the FE to each user, as is the norm for any application? When you think about it - would you put a copy of Office on a share, and then expect every user to be able to run it directly from that share? Your Access app is very much like any other application, in that it should be installed on the enduser machine and run from there.

As to why it works with File - Open ... I'm not sure ... using either method should bring the same results, but working within the Access environment may force different behavior.

I realize this can be troublesome from the standpoint of deployments and such, but who every said the life of an Access developer was easy? ;) ;)
strangely it now works on my machine and another one but none of the others in the company! I can't think what can differ between these machines to cause this to happen?! I haven't actually changed anything either!
This sounds more and more like permissions ... when you fire off an Access app, it will create a lockfile somewhere. If it cannot create that lockfile in the folder where the database "lives" (i.e. your DFS share), it will create it somewhere else (often the Temp folder on your workstation, but it can vary). Needless to say, other users would NOT have permission to those locations, and since Access would report that the database is "in use", then other users wouldn't be able to open it once this has happened.

That said, unless you deploy a copy of the FE to each user, you'll continue to have these sorts of issues. For example, when your IT dept decides to, say, move the server to a new machine, or when Windows issues a security update that affects the DFS system ... or just when the moon in in the 3rd phase rising, and the temperature is exactly 78.2 F!!
I understand what you're saying and it all makes perfect sense, but I asked another user to login on my machine and it worked for them too? They have permissions to write to the folder where the mdb file is but otherwise is just a domain user.  They tried it on their machine again and it definately doesnt work, it also didnt work for me on their machine.  I cant see what is different from my machine to theirs, the machines are all a standard image!
ASKER CERTIFIED SOLUTION
Avatar of Scott McDaniel (EE MVE )
Scott McDaniel (EE MVE )
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account