Link to home
Start Free TrialLog in
Avatar of szwy
szwy

asked on

CME incoming external call problem

the problem is with the incoming call from FXO, if the outside user stop calling the phone number after only two rings the CME still holds the call and keep ring even thought the caller has hung up!
is there any way to force CME to disconnect the call if the caller stop has call,  
I have got CME in cisco router 2600 Version 12.4-12.
any help please!
Avatar of dgboyd
dgboyd
Flag of United States of America image

When I've seen this in the past, it has been the telco.  They didn't have disconnect supervision on the line and wern't telling CME when the caller went on hook.  Have you tried calling their help line?

David
please record the disconnect tone and send it to me and i will send you the frequency and cadence for this tone then you have to apply it to CME after that the CME will recognize the disconnect tone and it will stop ringing the phone.

OR go to
http://www.3amsystems.com/wireline/tone-search.htm
and search for your region and apply the frequency and cadence to your CME.

i had the same issues in all the customer sites but i solved them.

Best,
Hussam  
Avatar of szwy
szwy

ASKER

hussam, let me try it and ill get back to you
Avatar of szwy

ASKER

what you mean by record the disconnect tone? i didn't quite catch that

if you have CIPC run it and run windows recorder and enable Stereo Mix to record internally and make call to your phone from PSTN but dont answer then close the PSTN phone and answer the phone will give you the disconnect tone. save it and send it to me and i will solve it for you.

Best,
Hussam
Avatar of szwy

ASKER

ok i understand now, get back to you then
Avatar of szwy

ASKER

please find the attached,
incoming.zip
Avatar of szwy

ASKER

ohh forget to tell you, please change the file Ext to .wav
thanks
this is not the tone that i need!!!
i need the busy tone it should be like tooooot toooot tooooot something like this.
Avatar of szwy

ASKER

here you are.
thanks,
call.zip
ASKER CERTIFIED SOLUTION
Avatar of hus1984
hus1984
Flag of Saudi Arabia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of szwy

ASKER

Im still having problem when applying the commands,
is this the right commands:
voice class custom-cptone <NAME>
dualtone disconnect
frequency <freq1> <freq2>
cadence <ON1> <OFF1> <ON2> ...

when I put the candence line I got the following error:
router(cfg-cp-dualtone)#cadence 0.28 0.28 0.28 0.28
                              ^
% Invalid input detected at '^' marker.

any idea?
are you sure that the cadance will accept 0.28 ??
Avatar of szwy

ASKER

no it doesn't, below you can see the allowed options:

router(cfg-cp-dualtone)#cadence 0.28
                               ^
% Invalid input detected at '^' marker.

router(cfg-cp-dualtone)#cadence ?  
  <50-10000>  First On cadence
  continuous  Configure continuous cadence

any idea?
use 280
Avatar of szwy

ASKER

great! after some research in the web i managed to get it to work correctly this time!
this what I did for those who wants to know:

voice class custom-cptone test
dualtone disconnect
frequency 425      
cadence 375 375    

voice-port 1/0/0
supervisory custom-cptone test
supervisory disconnect dualtone mid-call

thanks for your help hus1984, appreciate it!