ahmedjoo
asked on
ASA 5505 VPN won't pass traffic
I have configured a VPN on a Cisco ASA firewall, and my client software (Cisco VPN Client) is connecting with no problems. The split tunneling works, i.e. I can still browse the net on my own connection whilst connection, however, no traffic for the VPN can be sent over the connection.
I don't use ASDM, only CLI. Thank you in advance.
interface Vlan1
nameif inside
security-level 100
ip address 192.168.40.250 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 190.146.231.25 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit intra-interface
access-list vpnsplit extended permit ip 192.168.0.0 255.255.0.0 192.168.40.0 255.255.255.0
access-list LAFAYETTE extended permit ip 192.168.40.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list LAFAYETTE extended permit ip 192.168.40.0 255.255.255.0 192.168.5.0 255.255.255.0
access-list nonat extended permit ip 192.168.40.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list nonat extended permit ip 192.168.40.0 255.255.255.0 192.168.5.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool BogotaVPNPool 192.168.40.226-192.168.40. 244 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 190.146.231.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 10 match address LAFAYETTE
crypto map outside_map 10 set peer 24.249.90.67
crypto map outside_map 10 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 65535
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
!
group-policy BogotaVPN internal
group-policy BogotaVPN attributes
dns-server value 192.168.40.10 192.168.40.1
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value vpnsplit
username fredyparada password FR8OAcOkZv07pqzz encrypted
username danielmurcia password 1WRZPEvFPQkQCvjo encrypted
username leonardocuellar password 4HdpIk9xZQqoTFcN encrypted
username doug password OkJTvN7P3DBNiyQy encrypted
username jaimeacero password jBUtZ/Tp72be5YHb encrypted
username nancyquintana password p7CaFUCTXqI5Uu95 encrypted
tunnel-group BogotaVPN type ipsec-ra
tunnel-group BogotaVPN general-attributes
address-pool BogotaVPNPool
default-group-policy BogotaVPN
tunnel-group BogotaVPN ipsec-attributes
pre-shared-key *
tunnel-group 24.249.90.67 type ipsec-l2l
tunnel-group 24.249.90.67 ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
I don't use ASDM, only CLI. Thank you in advance.
interface Vlan1
nameif inside
security-level 100
ip address 192.168.40.250 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 190.146.231.25 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit intra-interface
access-list vpnsplit extended permit ip 192.168.0.0 255.255.0.0 192.168.40.0 255.255.255.0
access-list LAFAYETTE extended permit ip 192.168.40.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list LAFAYETTE extended permit ip 192.168.40.0 255.255.255.0 192.168.5.0 255.255.255.0
access-list nonat extended permit ip 192.168.40.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list nonat extended permit ip 192.168.40.0 255.255.255.0 192.168.5.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool BogotaVPNPool 192.168.40.226-192.168.40.
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 190.146.231.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 10 match address LAFAYETTE
crypto map outside_map 10 set peer 24.249.90.67
crypto map outside_map 10 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 65535
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
!
group-policy BogotaVPN internal
group-policy BogotaVPN attributes
dns-server value 192.168.40.10 192.168.40.1
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value vpnsplit
username fredyparada password FR8OAcOkZv07pqzz encrypted
username danielmurcia password 1WRZPEvFPQkQCvjo encrypted
username leonardocuellar password 4HdpIk9xZQqoTFcN encrypted
username doug password OkJTvN7P3DBNiyQy encrypted
username jaimeacero password jBUtZ/Tp72be5YHb encrypted
username nancyquintana password p7CaFUCTXqI5Uu95 encrypted
tunnel-group BogotaVPN type ipsec-ra
tunnel-group BogotaVPN general-attributes
address-pool BogotaVPNPool
default-group-policy BogotaVPN
tunnel-group BogotaVPN ipsec-attributes
pre-shared-key *
tunnel-group 24.249.90.67 type ipsec-l2l
tunnel-group 24.249.90.67 ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
Try changing your BogotaVPNPool to an address range off your local local subnet, this is usually best practice.
As I know, splittunnel access-lists must in standart mode, not extended. Try to change vpnsplit access-list as an example.
access-list vpnsplit standard permit 10.1.1.0 255.255.255.0
access-list vpnsplit standard permit 10.1.2.0 255.255.255.0
access-list vpnsplit standard permit 10.1.3.0 255.255.255.0
etc.
Where 10.1.x.x your VPN subnets.
access-list vpnsplit standard permit 10.1.1.0 255.255.255.0
access-list vpnsplit standard permit 10.1.2.0 255.255.255.0
access-list vpnsplit standard permit 10.1.3.0 255.255.255.0
etc.
Where 10.1.x.x your VPN subnets.
Change your nonat access-list to this:
conf t
no access-list nonat extended permit ip 192.168.40.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list nonat extended permit ip 192.168.40.0 255.255.255.0 192.168.0.0 255.255.0.0
conf t
no access-list nonat extended permit ip 192.168.40.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list nonat extended permit ip 192.168.40.0 255.255.255.0 192.168.0.0 255.255.0.0
ASKER
Thanks! I've tried the suggestions but it still will not pass traffic. Here is the latest config:
access-list vpnsplit standard permit 192.168.0.0 255.255.0.0
access-list LAFAYETTE extended permit ip 192.168.40.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list LAFAYETTE extended permit ip 192.168.40.0 255.255.255.0 192.168.5.0 255.255.255.0
access-list nonat extended permit ip 192.168.40.0 255.255.255.0 192.168.5.0 255.255.255.0
access-list nonat extended permit ip 192.168.40.0 255.255.255.0 192.168.0.0 255.255.0.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool BogotaVPNPool 192.168.44.226-192.168.44. 244 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 190.146.231.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 10 match address LAFAYETTE
crypto map outside_map 10 set peer 24.249.90.67
crypto map outside_map 10 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 65535
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 15
console timeout 0
dhcpd dns 192.168.40.2 192.168.40.250
dhcpd option 150 ip 192.168.5.1
!
dhcpd address 192.168.40.100-192.168.40. 200 inside
dhcpd enable inside
!
group-policy BogotaVPN internal
group-policy BogotaVPN attributes
dns-server value 192.168.40.10 192.168.40.1
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value vpnsplit
username fredyparada password FR8OAcOkZv07pqzz encrypted
username danielmurcia password 1WRZPEvFPQkQCvjo encrypted
username leonardocuellar password 4HdpIk9xZQqoTFcN encrypted
username doug password OkJTvN7P3DBNiyQy encrypted
username jaimeacero password jBUtZ/Tp72be5YHb encrypted
username nancyquintana password p7CaFUCTXqI5Uu95 encrypted
tunnel-group BogotaVPN type ipsec-ra
tunnel-group BogotaVPN general-attributes
address-pool BogotaVPNPool
default-group-policy BogotaVPN
tunnel-group BogotaVPN ipsec-attributes
pre-shared-key *
access-list vpnsplit standard permit 192.168.0.0 255.255.0.0
access-list LAFAYETTE extended permit ip 192.168.40.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list LAFAYETTE extended permit ip 192.168.40.0 255.255.255.0 192.168.5.0 255.255.255.0
access-list nonat extended permit ip 192.168.40.0 255.255.255.0 192.168.5.0 255.255.255.0
access-list nonat extended permit ip 192.168.40.0 255.255.255.0 192.168.0.0 255.255.0.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool BogotaVPNPool 192.168.44.226-192.168.44.
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 190.146.231.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 10 match address LAFAYETTE
crypto map outside_map 10 set peer 24.249.90.67
crypto map outside_map 10 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 65535
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 15
console timeout 0
dhcpd dns 192.168.40.2 192.168.40.250
dhcpd option 150 ip 192.168.5.1
!
dhcpd address 192.168.40.100-192.168.40.
dhcpd enable inside
!
group-policy BogotaVPN internal
group-policy BogotaVPN attributes
dns-server value 192.168.40.10 192.168.40.1
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value vpnsplit
username fredyparada password FR8OAcOkZv07pqzz encrypted
username danielmurcia password 1WRZPEvFPQkQCvjo encrypted
username leonardocuellar password 4HdpIk9xZQqoTFcN encrypted
username doug password OkJTvN7P3DBNiyQy encrypted
username jaimeacero password jBUtZ/Tp72be5YHb encrypted
username nancyquintana password p7CaFUCTXqI5Uu95 encrypted
tunnel-group BogotaVPN type ipsec-ra
tunnel-group BogotaVPN general-attributes
address-pool BogotaVPNPool
default-group-policy BogotaVPN
tunnel-group BogotaVPN ipsec-attributes
pre-shared-key *
ASKER CERTIFIED SOLUTION
membership
Create a free account to see this answer
Signing up is free and takes 30 seconds. No credit card required.