We help IT Professionals succeed at work.

SQL Server 2005 Upgrade Advisor error during upgrade from SQL 2000

I am in the process of upgrading the default instance of SQL Server 2000 to SQL Server 2005 on Windows Server 2003 SP2 machine.  This server is set to mixed authentication and all passwords fall under the "strong password" requirements.  I get to the step where it asks for logon information.  I selected Windows authentication and am logged in with a Domain Admin account that is also set up in the server as sysadmin.  I then click Next and it launches Ugrade analyzer and then a message pops up: UpgradeAdvisor returned -1.  I went into the ?(help button) of the error message and it took me to microsoft's website stating that: "You selected Mixed Mode authentication, but did not provide a strong password. To continue you must provide a strong sa password."

I have repeated these steps trying to use sql authentication with the sa account.  I have reset the sa account password to an even stronger password with the same result.  I tried changing the server from Mixed mode to Windows authentication only, restarted the server and tried again with the same result.

I installed the SQL 2005 Upgrade Advisor seperately and tried to run it to analyze the databases. It starts analyzing and then shows error with no error message or detail included.

I've gone through the logs with no avail.

Any suggestions on what may be the problem?
Comment
Watch Question

Author

Commented:
As an extra bit of info, this is SQL 2000 Standard Edition being upgraded to SQL 2005 Standard Edition.
Commented:
I went through each of the log files and apparently the upgrade advisor does not log in it's process.  The first link that you posted to a search for this error shows "no results found".  The second link did not supply any resolution as well.  

I ended up having to contact Microsoft support to get the problem resolved.  Apparently the upgrade placed a dll in the wrong folder that applies to the upgrade advisor thus the upgradeadvisor error.  They had no explanation other than sometimes this happens.

Here is the resolution:

Copy C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\BPA\bin\BPAClient.dll to C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\BPA.

That's it.  Once the dll is in the bpa folder, upgrade advisor works successfully and the upgrade runs through successfully.

Commented:
Thanks so much for this post
That helped me out! Thanks!
I was this close [......] to banging my head against the wall.  Brilliant!!!!

Commented:
Thanks edfreels, you rock!!
thankyou thankyou thankyou
+1 ... just saved me about an hour or more of doing things the long way (uninstall, install, reattach, set permissions, etc....).

Thanks!

Commented:
Amazing THANKS!!!!!!!!!!!!!!!!!

Commented:
wow this just saved us major time. thanks, So much!!!!!!!!!

Commented:
Thanks you very much for the post. Frustration was getting hold of me. Format was becoming an option.