Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Inter Vlan routing on switch ports on Cisco 877 Router

Avatar of BJMagill
BJMagill asked on
RoutersSwitches / Hubs
5 Comments1 Solution2176 ViewsLast Modified:
I have a Cisco 877 router which I want to use as a Switch only in conjunction with netflow.
I have configured as below.

I have a PC plugged into fe1 with an IP of 192.168.20.100

I have another PC plugged into fe0 with an IP of 192.168.1.100

I can't ping the PCs from either end.

I can ping 192.168.1.234 from the PC in the 192.168.20.0 subnet  but not the 192.168.20.1 from the 192.168.1.0 subnet which means some sort of routing is working.

Frankly i'm stumped!

Any ideas?

Regards,



interface FastEthernet0
 switchport access vlan 10
 no cdp enable
!
interface FastEthernet1
 switchport access vlan 20
 no cdp enable
!
interface FastEthernet2
 switchport access vlan 30
 no cdp enable
!
interface FastEthernet3
 switchport access vlan 40
 no cdp enable
!
interface Vlan10
 description SVI for VLAN-10
 ip address 192.168.1.234 255.255.255.0  
!
interface Vlan20
 description SVI for VLAN-20
 ip address 192.168.20.1 255.255.255.0  
!
interface Vlan30
 description SVI for VLAN-30
 ip address 192.168.30.1 255.255.255.0
!
interface Vlan40
 description SVI for VLAN-40
 ip address 192.168.40.1 255.255.255.0
!
ip route 192.168.1.0 255.255.255.0 FastEthernet0
ip route 192.168.20.0 255.255.255.0 FastEthernet1
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
!
snmp-server community public RO
no cdp run
!
ASKER CERTIFIED SOLUTION
Avatar of cstosgale
cstosgaleFlag of United Kingdom of Great Britain and Northern Ireland image

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 5 Comments.
See Answers