Link to home
Create AccountLog in
Avatar of dissolved
dissolved

asked on

Enabling ssh on 1841 router

I have the advanced IPK9 feature set IOS. How do I enable ssh properly?  Below is my line info. Which one do I change? We want to adminster this router via SSH remotely
line con 0
 login local
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet

Open in new window

Avatar of ChopperCentury
ChopperCentury
Flag of United States of America image

ASKER CERTIFIED SOLUTION
Avatar of ChopperCentury
ChopperCentury
Flag of United States of America image

Link to home
membership
Create a free account to see this answer
Signing up is free and takes 30 seconds. No credit card required.
See answer
Avatar of dissolved
dissolved

ASKER

still having trouble, help!
SDNROU01#sh run
Building configuration...
 
Current configuration : 3912 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname SDNROU01
!
boot-start-marker
boot system flash:c1841-adventerprisek9-mz.124-23.bin
boot-end-marker
!
logging buffered 4096 errors
enable secret 5 $1$gx2a$snq3bbG101FjAZY0./ncn.
!
aaa new-model
!
!
!
aaa session-id common
no ip subnet-zero
no ip source-route
ip cef
!
!
!
!
ip domain name cpk.chpk.com
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
username peake privilege 15 secret 
!
!
! 
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!         
interface FastEthernet0/0.1
 description Inside_Interface
 encapsulation dot1Q 1 native
 ip address 172.16.35.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 description 
 ip address 172.17.35.2 255.255.255.0
 encapsulation ppp
 shutdown
!
router ospf 1
 log-adjacency-changes
 redistribute static metric-type 1 subnets
 network 172.16.35.0 0.0.0.255 area 6
 network 172.17.35.0 0.0.0.255 area 5
!         
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.17.35.1
!
ip flow-export source FastEthernet0/0.1
ip flow-export version 5
ip flow-export destination 172.16.1.94 2055
!
no ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
logging trap errors
logging source-interface FastEthernet0/0.1
logging 172.16.1.20
access-list 1 permit 0.0.0.0 255.255.255.0
access-list 99 remark SNMP ACL
access-list 99 permit 172.16.1.20
snmp-server community n@tg@s RO 99
snmp-server ifindex persist
snmp-server enable traps tty
!         
!
!
!
control-plane
!
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------
 
Cisco Router and Security Device Manager (SDM) is installed on this device and 
it provides the default username "cisco" for  one-time use. If you have already 
used the username "cisco" to login to the router and your IOS image supports the 
"one-time" user option, then this username has already expired. You will not be 
able to login to the router with this username after you exit this session.
 
It is strongly suggested that you create a new username with a privilege level 
of 15 using the following command.
 
username <myuser> privilege 15 secret 0 <mypassword>
 
Replace <myuser> and <mypassword> with the username and password you want to 
use.
 
-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device. 
This feature requires the one-time use of the username "cisco" 
with the password "cisco". The default username and password have a privilege level of 15.
 
Please change these publicly known initial credentials using SDM or the IOS CLI. 
Here are the Cisco IOS commands.
 
username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco
 
Replace <myuser> and <mypassword> with the username and password you want to use. 
 
For more information about SDM please follow the instructions in the QUICK START 
GUIDE for your router or go to http://www.cisco.com/go/sdm 
-----------------------------------------------------------------------
^C
!
line con 0
 exec-timeout 15 0
 password 7 020514502B050C725F5D
 logging synchronous
line aux 0
line vty 0 4
 access-class REMOTE in
 exec-timeout 15 0
 privilege level 15
 password 7 094F5E0239061441181F
 logging synchronous
 transport input ssh
line vty 5 15
 access-class REMOTE in
 exec-timeout 15 0
 privilege level 15
 logging synchronous
 transport input ssh
!
scheduler allocate 20000 1000
ntp clock-period 17180314
ntp server 172.16.1.1
end
 
SDNROU01#

Open in new window

When you ran ...crypto key generate rsa
Did the crypto key generate or did you get an error?
it generated