We help IT Professionals succeed at work.
Get Started

OSPF

mikey250
mikey250 asked
on
458 Views
Last Modified: 2012-05-06
Ive configured 3 routers:

Main router: westaman
sanjose1 & sanjose2 router
- sanjose 1 & sanjose2 are plugged directly into single switch.  no configurations are on it, just opened the port.
- I can ping from westaman router all the way through network to: 10.0.0.3


Ive entered on the westaman router for both serial interfaces: "no ip route-cache" in order that when I do a "sh ip route" on the westaman router, i will see 2 routes to the 10.0.0.0 network via both sanjose1 & sanjose2.  For some reason Im only seeing one which is pointing via sanjose1 - 192.168.64.1

1. why i should see both: 192.168.64.1 & 192.168.64.5?
------------------------------------------------------------------------------------------------------------------------
Building configuration...

Current configuration : 860 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname westaman
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
!
ip audit po max-events 100
!
!
interface Serial0/0
 ip address 192.168.64.2 255.255.255.252
 no ip route-cache cef
 no ip route-cache
 clockrate 56000
!
interface Serial0/1
ip address 192.168.64.6 255.255.255.252
 no ip route-cache cef
 no ip route-cache
 clockrate 56000
!
interface Serial0/2
 no ip address
 shutdown
!
interface Serial0/3
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 1
 network 192.168.64.0 0.0.0.3 area 1
!
ip http server
no ip http secure-server
ip classless
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

westaman#
------------------------
Building configuration...

Current configuration : 614 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sanjose1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 10.0.0.1 255.255.255.0
!
interface Serial0
 ip address 192.168.64.1 255.255.255.252
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 1
 network 192.168.64.0 0.0.0.3 area 1
!
ip http server
ip classless
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end

sanjose1#
---------------------------
Building configuration...

Current configuration : 666 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sanjose2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 10.0.0.2 255.255.255.0
!
interface Serial0
 no ip address
 no fair-queue
!
interface Serial1
 ip address 192.168.64.5 255.255.255.252
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 1
 network 192.168.64.0 0.0.0.3 area 1
!
ip http server
ip classless
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

sanjose2#
----------------------
westaman#sh ip int brief
Interface                  IP-Address      OK? Method Status                Prot
ocol
Serial0/0                  192.168.64.2    YES manual up                    up

Serial0/1                  192.168.64.6    YES manual up                    up

Serial0/2                  unassigned      YES NVRAM  administratively down down

Serial0/3                  unassigned      YES NVRAM  administratively down down

westaman#
---------------------------
westaman#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.64.0/30 is subnetted, 2 subnets
C       192.168.64.0 is directly connected, Serial0/0
C       192.168.64.4 is directly connected, Serial0/1
     10.0.0.0/24 is subnetted, 1 subnets
O       10.0.0.0 [110/791] via 192.168.64.1, 00:16:05, Serial0/0
westaman#
Comment
Watch Question
Top Expert 2009
Commented:
This problem has been solved!
Unlock 1 Answer and 3 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE