Avatar of WoodstockIT
 asked on

How do I fix Microsoft Access 'Cannot Lock File' error

I have an existing Microsoft Access 2000 database that is split with front end/back end. It is on a network file server and is accessed via network shares. There is a current group of users who have been successfully accessing it simultaneously; some using Windows 2000 Pro/Office 2000 and some using Windows XP Pro/Office 2003. I am now adding 2 new users, 1 2000 Pro/Offc 2000 + 1 XP Pro/Offc 2003, who each get the 'cannot lock file' message if anyone of the original group is using the database, otherwise they can access the file. Further if either of the 2 new users log on first, any of the original users can use the database but only as read-only. Both original and new users all have the same NTFS permissions to the database and folders on the network.  Any help to solve this will be most appreciated.
Microsoft AccessServer HardwareActive Directory

Avatar of undefined
Last Comment

8/22/2022 - Mon

" Both original and new users all have the same NTFS permissions to the database and folders on the network. "

No they don't.
Absolutely 99.9% guaranteed.

The only other possibility is that the new users have their default database open mode set to exclusive.  Since this is not the installation default it is very unlikely to be so.
(Tools>Options Advanced tab)
Jim Dettman (EE MVE)

I would first check that all users have full read, write, and delete priv for the directory where the BE resides.
Then with everyone out of the app, make sure there are no .LDB files hanging about (if so, delete them).
Also if using a custom workgroup file, it must not be the same name as the database (ie.  myApp.MDW and myApp.MDB) if it is in the same directory.
Those issues there cover 99% of the problems with multi-user access to a DB file.


I guess I am the 00.1%

On the File Server, in Windows Explorer, from the highest foilder level to the individual database files, 'Sharing & Security-Security-Advanced-Effective Permissions' displays Full Control for the 2 new users.  On each PC, in Windows Explorer, accessing the mapped network drive, all levels also display Full Control.

However, in trying to further troubleshoot, I tried to copy a file from the user's desktop to the mapped drive, and received the following error message:
    "Cannot save (file name) The folder is marked as 'Read Only'"

PLEASE advise - I am totally stumped - this just does not make sense.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Jim Dettman (EE MVE)

<<PLEASE advise - I am totally stumped - this just does not make sense.>>
  That's the other thing I should have mentioned; make sure the folder and files are not marked read only.  That mainly happens when you copying something off a CD.
 In explorer, right click on the folder and make sure the read-only attribute is not set.  Also do that for the files.  But given that this is only with 2 users, it sounds more like a security problem then the folder actually being read-only.

View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.


I re-applied user permissions on the File Server during off-hours and that solved the issue.
Apparently they did not completely apply correctly the first time even though 'Effective Permissions' showed that they had.

THANKS for your help !