Acrobat Pro 9 doesn't embed postscript fonts in pdfs

We have around 30 Windows XP pcs with Acrobat 8 Professional, and 6 with Acrobat 9 Professional.

Apart from a select few, all work the way they should when people convert Word 2003 documents into PDF files.

We have 3 pcs with either Acrobat Pro 8 or 9 (it has happened in both applications on the same pcs) where postscript fonts in the Word document are not being embedded into the created PDF. This basically is resulting in a blank PDF being created.

I have checked the Font usage in the PDF and none of the fonts are listed or even replaced. These fonts are our main corporate fonts so we can't replace them with opentype fonts.

The fonts are installed on the pcs using Adobe Type Manager Deluxe 4.1

The only obvious difference between the majority of the working pcs and these ones is SP3 (however one other PC also has SP3 and works fine).

The only way I have managed to get the fonts embedding again is to remove the Acrobat software, and XP SP3. Then reapply SP3 followed by Acrobat.

However the problem has returned on one pc since i did this, so I need to get to the bottom of why Acrobat is doing this and find a quicker permanent fix.
bsteynAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

GlennHarrisCommented:
Not sure what to say, but in my experience most users incorrectly generate pdfs. The method of last-resort is to use the file menu > print > pdf command.
The correct method is to use the Acrobat menu > Convert to PDF command, which utilizes the conversion settings that embed those fonts. The conversion settings are stored in distiller, a separate app.
The acid test: Install any postscript print on file, not lpt1, (i tend to use a generic hp laserjet with postscript, some users prefer to use the tektronix driver, i doubt it really matters unless you also need color); From Word, print a document to your new postscript printer on file (name it something like C:\Test.ps). Open distiller (if you don't have a separate program icon you can find distiller in Acrobat under the Advanced menu > Print Production > Acrobat Distiller command. In distiller select a job option from the dropdown, then use the File menu > Open command and open C:\Test.ps to distill to a pdf. RSVP with the outcome, i'd imagine that the postscript fonts will appear.
bsteynAuthor Commented:
Thanks for the suggestion - i've tried it on a computer i know works and it's fine, but on the computer we are having problems with the fonts are still not appearing in the pdf file.

I also tried distilling the same file on both computers - with same result - so I think the problem lies in when the machine prints these fonts (to a file or to a postscript printer).

I have tried printing a Notepad text file with the same results.

I don't think you can tell much from it, but here is the log from distiller. The fonts not embedding are American Typewriter, Akzidenz Grotesk and Blacksunfont.

/AmericanTypewriter-BoldCondA
/AmericanTypewriter-BoldCond
/AmericanTypewriter-Bold
/AmericanTypewriter-CondA
/AmericanTypewriter-Cond
/AmericanTypewriter-LightA
/AmericanTypewriter-LightCondA
/AmericanTypewriter-LightCond
/AmericanTypewriter-Light
/AmericanTypewriter-MediumA
/AmericanTypewriter-Medium
/Blacksunfont
/Mojo
/AkzidenzGroteskBE-BoldIt
/AkzidenzGroteskBE-Bold
/AkzidenzGroteskBE-It
/AkzidenzGroteskBE-LightOsF
/AkzidenzGroteskBE-Light
/AkzidenzGroteskBE-MdIt
/AkzidenzGroteskBE-Md
/AkzidenzGroteskBE-Regular
/AkzidenzGroteskBE-Super
/Khaki-Two
/Nyx
/OCRA-Alternate
/Ouch
/GreymantleMVB
/Shuriken-Boy
/BermudaLP-Squiggle
/SpumoniLP
/Pompeia-Inline
/Giddyup
/Myriad-Tilt
/Cutout
/Chaparral-Display
/Postino-Italic
/BookAntiqua-Bold
/BookAntiqua-BoldItalic
/BookAntiqua-Italic
/Arial-BlackItalic
/ArialMT
/Arial-BoldMT
/Arial-BoldItalicMT
/Arial-ItalicMT
/ArialNarrow
/ArialNarrow-Bold
/ArialNarrow-BoldItalic
/ArialNarrow-Italic
/ArialUnicodeMS
/Arial-Black
/Batang
/BookAntiqua
/BookmanOldStyle
/BookmanOldStyle-Bold
/BookmanOldStyle-BoldItalic
/BookmanOldStyle-Italic
/BookshelfSymbolSeven
/Calibri
/Calibri-Bold
/Calibri-Italic
/Calibri-BoldItalic
/Cambria
/CambriaMath
/Cambria-Bold
/Cambria-Italic
/Cambria-BoldItalic
/Candara
/Candara-Bold
/Candara-Italic
/Candara-BoldItalic
/Century
/ComicSansMS
/ComicSansMS-Bold
/Consolas
/Consolas-Bold
/Consolas-Italic
/Consolas-BoldItalic
/Constantia
/Constantia-Bold
/Constantia-Italic
/Constantia-BoldItalic
/Corbel
/Corbel-Bold
/Corbel-Italic
/Corbel-BoldItalic
/CourierNewPSMT
/CourierNewPS-BoldMT
/CourierNewPS-BoldItalicMT
/CourierNewPS-ItalicMT
/EstrangeloEdessa
/FranklinGothic-Medium
/FranklinGothic-MediumItalic
/Garamond
/Garamond-Bold
/Garamond-Italic
/Gautami
/Georgia
/Georgia-Bold
/Georgia-Italic
/Georgia-BoldItalic
/CenturyGothic
/CenturyGothic-Bold
/CenturyGothic-BoldItalic
/CenturyGothic-Italic
/Haettenschweiler
/Impact
/Kartika
/Latha
/LucidaSans
/LucidaSans-Demi
/LucidaSans-DemiItalic
/LucidaSans-Italic
/LubalinGraphStd-Book
/LubalinGraphStd-BookOblique
/LubalinGraphStd-Demi
/LubalinGraphStd-DemiOblique
/LucidaConsole
/LucidaSansUnicode
/Mangal-Regular
/MapInfoShields
/Map-Symbols
/MicrosoftSansSerif
/MS-Mincho
/MonotypeCorsiva
/MVBoli
/MSOutlook
/PalatinoLinotype-Roman
/PalatinoLinotype-Bold
/PalatinoLinotype-BoldItalic
/PalatinoLinotype-Italic
/PMingLiU
/Prosper-Bold
/Prosper-BoldItalic
/Prosper-Book
/Prosper-BookItalic
/ProsperBlack-Italic
/ProsperBlack
/ProsperLight-Italic
/ProsperLight
/ProsperMedium-Italic
/ProsperMedium
/Raavi
/MSReferenceSansSerif
/MSReferenceSpecialty
/SASMonospaceBT-Roman
/SASMonospaceBT-Bold
/Shruti
/SimSun
/Sylfaen
/SymbolMT
/Tahoma
/Tahoma-Bold
/TimesNewRomanPSMT
/TimesNewRomanPS-BoldMT
/TimesNewRomanPS-BoldItalicMT
/TimesNewRomanPS-ItalicMT
/TrebuchetMS
/TrebuchetMS-Bold
/Trebuchet-BoldItalic
/TrebuchetMS-Italic
/MapInfoArrows
/MapInfoCartographic
/MapInfoMiscellaneous
/MapInfoOil&Gas
/MapInfoSymbols
/MapInfoRealEstate
/MapInfoTransportation
/MapInfoWeather
/Tunga-Regular
/Verdana
/Verdana-Bold
/Verdana-Italic
/Verdana-BoldItalic
/Vrinda
/Webdings
/Wingdings-Regular
/Wingdings2
/Wingdings3
/ZWAdobeF
/AdobeArabic-Bold
/AdobeArabic-BoldItalic
/AdobeArabic-Italic
/AdobeArabic-Regular
/AdobeHebrew-Bold
/AdobeHebrew-BoldItalic
/AdobeHebrew-Italic
/AdobeHebrew-Regular
/AdobeHeitiStd-Regular
/AdobeMingStd-Light
/AdobeMyungjoStd-Medium
/AdobePiStd
/AdobeSongStd-Light
/AdobeThai-Bold
/AdobeThai-BoldItalic
/AdobeThai-Italic
/AdobeThai-Regular
/BellGothicStd-Black
/BellGothicStd-Bold
/BellGothicStd-Light
/CourierStd-Bold
/CourierStd-BoldOblique
/CourierStd-Oblique
/CourierStd
/EuroSig
/KozGoPr6N-Medium
/KozGoProVI-Medium
/KozMinPr6N-Regular
/KozMinProVI-Regular
/LetterGothicStd-Bold
/LetterGothicStd-BoldSlanted
/LetterGothicStd-Slanted
/LetterGothicStd
/MinionPro-Bold
/MinionPro-BoldIt
/MinionPro-It
/MinionPro-Regular
/MinionPro-Semibold
/MinionPro-SemiboldIt
/MyriadPro-Black
/MyriadPro-BlackIt
/MyriadPro-Bold
/MyriadPro-BoldIt
/MyriadPro-It
/MyriadPro-Light
/MyriadPro-LightIt
/MyriadPro-Regular
/MyriadPro-Semibold
/MyriadPro-SemiboldIt
/Symbol
/AdobeSansMM
/AdobeSerifMM
/LucidaBright-Demi
/LucidaBright-DemiItalic
/LucidaBright-Italic
/LucidaBright
/LucidaSans-Demi
/LucidaSans
/LucidaSans-TypewriterBold
/LucidaSans-Typewriter
/MT-Extra
/AdobeArabic-Bold
/AdobeArabic-BoldItalic
/AdobeArabic-Italic
/AdobeArabic-Regular
/AdobeHebrew-Bold
/AdobeHebrew-BoldItalic
/AdobeHebrew-Italic
/AdobeHebrew-Regular
/AdobePiStd
/AdobeThai-Bold
/AdobeThai-BoldItalic
/AdobeThai-Italic
/AdobeThai-Regular
/CourierStd-Bold
/CourierStd-BoldOblique
/CourierStd-Oblique
/CourierStd
/MinionPro-Bold
/MinionPro-BoldIt
/MinionPro-It
/MinionPro-Regular
/MyriadPro-Bold
/MyriadPro-BoldIt
/MyriadPro-It
/MyriadPro-Regular
/Symbol
/AdobeSansMM
/AdobeSerifMM
/Courier-BoldOblique
/Courier-Bold
/Courier
/Courier-Oblique
/AppleGothic
/AppleMyungjo
/Beijing
/DFKaiShu-SB-Estd-BF
/FutoGoB101-Bold
/FutoMinA101-Bold
/GothicBBB-Medium
/GothicMB101-Bold
/GothicMB101-hea
/GothicMB101-Ult
/HeiseiKakuGo-W3
/HeiseiKakuGo-W5
/HeiseiKakuGo-W7
/HeiseiKakuGo-W9
/HeiseiMaruGo-W4
/HeiseiMin-W3
/HeiseiMin-W3H
/HeiseiMin-W5
/HeiseiMin-W7
/HeiseiMin-W9
/HonMincho-M
/HYGoThic-Medium
/HYGungSo-Bold
/HYKHeadLine-Bold
/HYKHeadLine-Medium
/HYRGoThic-Medium
/HYSMyeongJo-Medium
/JCfg
/JCkg
/Jun101-Light
/Jun34-Medium
/Jun501-Bold
/KozMin-Bold
/KozMin-ExtraLight
/KozMin-Heavy
/KozMin-Light
/KozMin-Medium
/KozMin-Regular
/KyokaICA-Light
/KyokaICA-Medium
/KyokaICA-regular
/LiGothicMed
/LiSungLight
/LogoArl-Bold
/LogoArl-Light
/LogoArl-Medium
/LogoArl-Ultra
/LogoCut-Bold
/LogoCut-Light
/LogoCut-Medium
/LogoCut-Ultra
/LogoLine-Bold
/LogoLine-Light
/LogoLine-Medium
/LogoLine-Ultra
/MaruGothic-M
/MHei-Medium
/MidashiGo-MB31
/MidashiMin-MA31
/MKai-Medium
/MSung-Light
/MSung-Medium
/Munhwa-Regular
/MunhwaGothic-Regular
/Osaka
/Osaka-Mono
/Ryumin-Bold
/Ryumin-heavy
/Ryumin-Light
/Ryumin-Medium
/Ryumin-regular
/Ryumin-Ultra
/Seoul
/ShinGo-Bold
/ShinGo-Light
/ShinGo-Medium
/ShinGo-regular
/ShinGo-Ultra
/ShinseiKai-CBSK1
/SIL-FangSong-
/SIL-FangSong-Reg-Jian
/SIL-Hei-Med-Jian
/SIL-Kai-
/SIL-Kai-Reg-Jian
/SIL-Song-Reg-Jian
/SMGothic-Bold
/SMGothic-DemiBold
/SMGothic-Light
/SMGothic-Medium
/SMMyungjo-Bold
/SMMyungjo-DemiBold
/SMMyungjo-Light
/SMMyungjo-Medium
/STFangsong-Light
/STHeiti-Regular
/STKaiti-Regular
/STSong-Light
/Taipei
/TBKomachiG-B
/TBKomachiG-DB
/TBKomachiG-E
/TBKomachiG-hv
/TBKomachiG-M
/TBKomachiG-R
/TBKomachiM-DE
/TBKomachiM-E
/TBKomachiM-hv
/TBKomachiM-M
/TBKomachiRG-R
/TBKoudoukenG-B
/TBKoudoukenG-DB
/TBKoudoukenG-E
/TBKoudoukenG-hv
/TBKoudoukenG-M
/TBKoudoukenG-R
/TBKoudoukenM-DE
/TBKoudoukenM-E
/TBKoudoukenM-hv
/TBKoudoukenM-M
/TBKoudoukenRG-R
/TBRyokanG-B
/TBRyokanG-DB
/TBRyokanG-E
/TBRyokanG-hv
/TBRyokanG-M
/TBRyokanG-R
/TBRyokanM-DE
/TBRyokanM-E
/TBRyokanM-hv
/TBRyokanM-M
/TBRyokanRG-R
/TBTsukijiG-B
/TBTsukijiG-DB
/TBTsukijiG-E
/TBTsukijiG-hv
/TBTsukijiG-M
/TBTsukijiG-R
/TBTsukijiM-DE
/TBTsukijiM-E
/TBTsukijiM-hv
/TBTsukijiM-M
/TBTsukijiRG-R
/TBYukinariG-B
/TBYukinariG-DB
/TBYukinariG-E
/TBYukinariG-hv
/TBYukinariG-M
/TBYukinariG-R
/TBYukinariM-DE
/TBYukinariM-E
/TBYukinariM-hv
/TBYukinariM-M
/TBYukinariRG-R
/TypeBankG-b
/TypeBankG-db
/TypeBankG-e
/TypeBankG-hv
/TypeBankG-m
/TypeBankG-r
/TypeBankM-de
/TypeBankM-e
/TypeBankM-hv
/TypeBankM-m
/TypeBankMaruG-r
/CGBM-PropRoman
/ChuGothicBBB-Medium-PropRoman
/FutoMinA101-Bold-PropRoman
/HeiseiKakuGothic-W5-PropRoman
/HeiseiMincho-W3-PropRoman
/HonMincho-M-PropRoman
/HYFix
/JL-PropRoman
/Jun101-Light-PropRoman
/MaruGothic-M-PropRoman
/MidashiMin-MA31-PropRoman
/Mincho-PC-Hiragana
/Mincho-PC-Katakana
/MMMA-PropRoman
/NotDefFont
/Osaka-MonoRoman
/Osaka-PropRoman
/RLKL-PropRoman
/Ryumin-Light-KL-PropRoman
/SMFix

Start Time: 30 March 2009 at 09:12:34
Source: test.prn
Destination: C:\Documents and Settings\cnewell.BLACKSUN\Desktop\test.pdf
Adobe PDF Settings: C:\Documents and Settings\All Users\Application Data\Adobe\Adobe PDF\Settings\Standard.joboptions
%%[ ProductName: Distiller ]%%
%%[Page: 1]%%
%%[LastPage]%%
Distill Time: 00 Hour(s) : 00 Minute(s) : 05.312 Second(s)
**** End of Job ****

bsteynAuthor Commented:
Just an update on this - a computer that worked well until now has now suddenly stopped embedding the postscript fonts on generated pdfs.

No software or Windows updates have been installed.
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

GlennHarrisCommented:
Can't say; I am using SP2, not SP3 and had no trouble embedding american typewriter using XP and Word 2003. Assuming you can print those fonts to a printer, my next guess is that the job options file is corrupted, instead of Standard use Press Quality, which forces fonts to embed. You can change this via the Adobe PDF menu in word, select Change Conversion Settings, then change Standard to Press Quality. HTH
bsteynAuthor Commented:
Thanks I will try that out.

Just to be clear - the fonts only print out on non postscript printers. however on the main fiery printers (which we use postscript drivers for) the fonts do not print.

bit of a wierd one.
bsteynAuthor Commented:
Just tried different conversion settings with the same result, unfortunately..
GlennHarrisCommented:
Last suggestion: Corrupt user profile; Create a new user and install the printer driver, then the fonts. If the fonts print to a non postscript printer they're being rasterized okay, but then postscript appears to be the problem.
bsteynAuthor Commented:
Different user profiles make no difference  - the font's are not being embedded. Is there an easy way to debug the pdf printer's actions step by step??
bsteynAuthor Commented:
Does anybody else have any ideas on this??

thanks
bsteynAuthor Commented:
I've discovered that a reinstall of XP sp3 solves the problem, but want to get to the bottom of this - ie which file (s) causes this problem.


thanks
GlennHarrisCommented:
Congratulations, I don't know why you bothered to ask the question if you failed to follow any of my suggestions.
bsteynAuthor Commented:
Thanks for your suggestions GlennHarris - none of them were helpful (and yes i tried each one).

If anyone else can shed any light as to why this problem happens I would be very grateful. Obviously reinstalling xp sp3 each time this happens is not an acceptable solution only a short term workaround.

thanks.
GlennHarrisCommented:
assuming you are using adobe type 1 fonts, not open type or true type fonts, realize a font consists of a .pfm and a .pfb component. PFM is postscript font metric and is used by the printer, the .pfb is for the screen display. If the font prints to a non postscript printer it's because it (the .pfb) is being rasterized. My suggestion is that you check your fonts folder to ascertain that you don't also have a truetype version installed, or that windows converted the postscript font to truetype by inadvertant installation into the windows/fonts folder. Also check the C:\Psfonts\pfm folder for the .pfm file for the font, it's likely missing. GL

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bsteynAuthor Commented:
The fonts are type 1 postscript fonts and they are installed correctly (using ATM deluxe) on over 40 windows xp machines.

The problem is that suddenly on a couple of machines no postscript fonts will print to pdf (or to postscript printers). The only way i know to fix this is to reinstall XP service pack 3. For some reason this will restore the correct functionality.

I have made the user of the faulty machine a Power User (he was previously Administrator) to see if this helps.
bsteynAuthor Commented:
Thanks for your help Glenn, has helped me to understand the exact workings of fonts a lot better, but unfortunately, still got the same problem. At least now I am in a better position to troubleshoot the issue.

Thanks again.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Adobe Acrobat

From novice to tech pro — start learning today.