Access 2007 Split forms will not maintain set sizes

I am working with a Split Form in Access 2007 and even though I set the size in design mode and then save the form, the form still opens up huge.   I have the form set to Pop Up with the Border style as Sizable, the Auto Resize = NO, AutoCenter = Yes.  

According to the help on the AutoResize property - When opened, the Form window has the last saved size. To save a window's size, open the form, size the window, save the form by clicking Save on the File menu, and close the form or report. When you next open the form or report, it will be the saved window size.

This seems to work OK with standard forms but with the SplitForm it blows out.  I suspect it has something to do with the data sheet portion of the form.  The Row Source has 12 columns and I hide all but two of them.

All I want to be able to do is resize the form and have it maintain the size next time it is opened.

Any ideas?
BladesAwayAsked:
Who is Participating?
 
ee_autoConnect With a Mentor Commented:
Question PAQ'd, 250 points refunded, and stored in the solution database.
0
 
TextReportCommented:
Can you provide a working example of the problem, I have been unable to recreate.
Also does the form appear to be maximized? Do you have the forms opening as Overlapping Windows or Tabbed Documents, this is set in the Access Options (from the Office Button on the Top Left), Current Database, Application Options, Document Window Option, you should be using Overlapping Windows I beleive.
Cheers, Andrew
0
 
Jeffrey CoachmanMIS LiasonCommented:
Can you define what you are calling "Huge", in terms of an absolute measurement please?
Or provide a screensot of the issue?
(or a sample as Andrew requests)
Thanks.

Like Andew, I could not recreate your issue, for lack of a clear definition of "Huge"

    "The Row Source has 12 columns and I hide all but two of them."
Then why not make the source for the form, just thoes two fields?
(Perhaps the split form considers "All" the available fields?)

I have attached a screenshot of a form I made, as it open normally.

JeffCoachman

untitled.JPG
0
What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

 
hunterdgCommented:
Well I'm not the OP, but i'm experiencing the EXACT same problem..

My wish:  to have the split form open either maximized (with a border) or fullscreen (with no border)
I have tried all combinations of Auto Center, Auto Resize, Fit to Screen, Border Style, Moveable, and even manually adjusting the form's size and saving (not a desirable method for a full-screen popup)

No matter what method I use, I can't get the 'split form' Form to behave.  And the Moveable:No property doesn't behave either..

FYI, as an end-result, I would like to launch this via a shortcut with properties set to 'run minimized'.
Contractor-Sign-in-driving-me-nu.mdb
0
 
Jeffrey CoachmanMIS LiasonCommented:
On the Open Event of the form put this:
   Docmd.Maximize

So the code will look like this:
Private Sub Form_Open(Cancel As Integer)
    DoCmd.Maximize
End Sub


0
 
TextReportCommented:
As boag2000 has said the DoCmd.Maximize should do the trick, try setting the BorderStyle to Thin and include the recordselector as this visible evidence will assis you in gauging what is happening.
Cheers, Andrew
0
 
Jeffrey CoachmanMIS LiasonCommented:
;-)

Yes, by you setting the boderstyle to None, on the opening screen, you in effect, locked me out of the db, forcing me to us the task manager to get out.

If you are going to be submiting samples, please make it easy for the experts to see the issue directly.

;-)

Jeff
0
 
hunterdgCommented:
@ boag2000 --- sorry..

right click>design view works like a charm though..
0
 
Jeffrey CoachmanMIS LiasonCommented:
OK

Keep us posted
0
 
hunterdgCommented:
DoCmd.Maximize sure helps things!

the Moveable property still doesn't work.. I can double click on the title bar to 'restore' the window, and it is once again huge, and moveable..

any thoughts on why this doesn't work without the VBA?

Anyway, to fix the issue, I set border style to none.. now there is no title bar to click on at all!

Thanks for your help!
0
 
Jeffrey CoachmanMIS LiasonCommented:
Yes,

There are many Form properties that interact/conflict with one another.

Click each property and press the F1 Function key for help on it.

;-)

JeffCoachman
0
 
BladesAwayAuthor Commented:
I resolved this issue on my own by taking a different design approach.  I am no longer using split forms.
0
 
hunterdgCommented:
this is valuable information, not to mention the last comment from bladesaway is certainly within the 'last 21 days'.  Bladesaway needs to awed himself with the points, or a force-accept needs to be awarded to boag2000 as he answered the question properly.  
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.