Solved

Boot Priority Problem

Posted on 2009-03-29
15
966 Views
Last Modified: 2012-05-06
I have a HP Pavilion a6242n-b with an AMD Athlong 64x2 Dual Core processor 4800+ 2.50 GHz, with Windows Vista Ultimate 32-bit operating system.   The system will not autorun CD-ROM software programs with I attempt to install them.  Setup refeals that the 2nd Bootn Device is the CD-ROM Group, and it also states that the CD-ROM Group priority is not installed.  I am not able to select the optical drive and manually select setup.  I'd sure appreciate some help with this [rpb;e,/
0
Comment
Question by:dlauseng
  • 8
  • 5
  • 2
15 Comments
 
LVL 7

Expert Comment

by:lucifer82
ID: 24014971
In the BIOS make sure USB is supported during boot up (some are disabled at default, some are not there until you do BIOS firmware update).

Than check your hard disc boot priority sometimes the USB device is in there instead.
0
 
LVL 35

Expert Comment

by:torimar
ID: 24014986
In order to boot from a CDROM, it must be selected as first boot device in BIOS/Setup.

If that still does not solve your problem, consider the fact that the CD-Roms you are trying to boot from may not be bootable. this can happen when you don't burn iso-files correctly as images.

ps:
"The system will not autorun CD-ROM software programs with I attempt to install them"
You do not usually install a software program by booting from its CD. That's the way how you install an Operating System, not simple software.
0
 

Author Comment

by:dlauseng
ID: 24021157
The CD is "CleanMyPC Registry CleanerOner Year Subscription" from registry-cleaner.net.  I've contacted them, but to reply yet.  My concern is "CD-ROM Group priority is not installed"
0
 
LVL 35

Expert Comment

by:torimar
ID: 24021672
It looks to me like there is utter confusion in what you are trying to do.
I'll attempt to sort some things out:

1. The "CleanMyPC" Registry Cleaner does *not* require you to boot from its CD.

2. The "Boot Priority" in the BIOS/Setup (which is the screen of settings you acces by pressing F10 when the computer boots) has got nothing to do with the CDROM autorun feature inside Windows.
You only need to fiddle with this setting when you do *not* want to load Windows, but boot into a Live system or install a new operating system *instead* of loading Windows.

3. The "CD-ROM Group priority" not being installed is nothing to worry about; most modern computer systems do not have more than one CDROM/DVD combo drive. "Group priority" only catches in when you have more than one CDROM/DVD drive and need to establish a boot order between them.


I can only guess what your real problem is (forgive me if I'm wrong here):
Inside Windows Vista you insert the "CleanMyPC" cdrom, because you wish to install that software. But no installation window pops up automatically.
This could have two reasons: a) Autorun is disabled in your Vista; b) there is no autorun file on the CD. No problem.
Click Start > Computer and double-click your CDROM drive. This should show you the contents of the CDROM. Look for a file called "setup"/"setup.exe" or "install" / "install.exe" and double-click it. This should launch the programme installer.


0
 

Author Comment

by:dlauseng
ID: 24082603
    I am nt attempting to boot from the "LightScrive SuperMulti Drive /CD Writer" in the computer.  Rather, I am attempting to install software programs.  The system doesnm't recognize that a disc is in the optical drive after I insert one to install the software.  I've attached my external Memorex CD-RW to a USB port.  The system recognizes the drove amd the nature of the disc inserted, however it will still not autorun.  I can click on that in My Computer or Windows Explorer and install the program by clicking on "setup" or "installl" or whatever.  
     Why will the onboard optical drive not not recoginze an inserted disc, and why will the system not "autorun"?
0
 
LVL 7

Expert Comment

by:lucifer82
ID: 24082616
You must have disabled autorun for that particular device or media type.

there is a part in the control panel to check you autorun. ^_^
0
 
LVL 35

Expert Comment

by:torimar
ID: 24082970
"Why will the onboard optical drive not not recoginze an inserted disc, and why will the system not "autorun"?"

I already gave the answer to this question of yours in my post above:
Quote: "This could have two reasons: a) Autorun is disabled in your Vista; b) there is no autorun file on the CD."

Having autorun disabled in your system is not a bad thing at all, because it protects you from self-installing worms and viruses.
If, however, you want it enabled, try this:
Go to the Device Manager (here's how you do that: http://pcsupport.about.com/od/windowsvista/ht/accessdmcpnva.htm), select your CDROM/DVD drive, right-click, choose Properties > Settings, put a checkmark in the "Auto insert notification" check box. Reboot.

If that does not fix it, check out the following resource for more advanced troubleshooting:
http://www.mydigitallife.info/2008/01/14/autoplayautorun-not-working-or-missing-not-open-in-windows-vista/comment-page-1
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:dlauseng
ID: 24100283
Some additional information:
I purchased the system with Vista Home Premium, and upgraded to Vista Ultimate SP1.
USB support is not addressed in BIOS.
There is an autorun file on the software I am attempting to install.
Autorun is not addressed in the Control Panel.
In Device Manager there is no "Auto insert notification" check b ox for the CDROM/DVD SCSI drive, and the driver is current.
0
 

Author Comment

by:dlauseng
ID: 24260191
I will review again everyone's suggestions and further troubleshoot the problem.  I will award points to contributing solutions or close this inquiry.
0
 
LVL 35

Expert Comment

by:torimar
ID: 24264624
I think there were some good results so far:
We found out that the BIOS and its boot priority have nothing to do with your problem, and that the CDROM device group is nothing to worry about.

We also found out that the only problem you seem to have is a disabled autorun, which is a minor issue (Personally, I disable autorun on purpose on all machines).

If you still want it enabled and you don't mind having to edit your registry, here's how:

- Launch the registry editor by typing "regedit" in the Start Search box:
http://www.computerperformance.co.uk/vista/vista_registry.htm#Getting_Started_with_Regedit

- Make sure to be very careful!

- Browse to the following key (on the left hand panel):
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom

- Click the "Cdrom" folder on the left panel, so that it opens

- In the list box on the right, check for an entry called "Autorun"

- Right-click it and select "Change"

- Set the hexadecimal "Value" to "1"

- Leave the registry editor and reboot.
0
 

Author Comment

by:dlauseng
ID: 24489751
Thank you everyone for your input.  I agree, torimar, that perhaps we are getting somewhere now that is it clear that my problem isn't trying to boot from the CD-ROM drive, but rather, "The system will not autorun CD-ROM software programs when I attempt to install them."  In fact, the drive doesn't recognize that a disc is even present.  I am going to again review all the input so far.
0
 

Author Comment

by:dlauseng
ID: 24492024
Clarification of the problem.  First, lucifer82 and torimar, I apologize for the misleading title "Boot Priority Problem"  The issue has been that autorun does not function when an appropriate disc is inserted into the CD-ROM drive, and that the drive does not recognize the presence of a disc at all.  I've checked AujtoPlay in the Control Panel, and "AutoPlay for all media and devices" is selected.  I've checked the registry entry, and the hexz value is set to "1" for Autorun.

So I inserted an autorun disc into the drive, and it worked.  I tried several, and they all worked.  Then I inserted a data disc, and Windows Explorer listed all its contents.  I was in the process of relaying this information here when the computer froze.  I had to do a cold boot, after which the problem with the CD-ROM drive is back.

When the drive was functioning temporarily, I determined that it is drive E.  My Computer doesn't show a drive E now that the problem has returned.  Also, the BIOS does not recognize the drive.  I am not certain at this point, but it might be a SCSI device.

Any further thoughts on this apparently intermittent problem?

0
 
LVL 35

Accepted Solution

by:
torimar earned 500 total points
ID: 24496266
It is improbable that the device is SCSI; like in practically all home computers, it will be either SATA or EIDE/PATA, but most likely SATA.

What puzzles me is that you say the drive isn't even recognized by your BIOS. Reading back through your previous comments it seems to be clear that when you originally had this problem, you could see the drive in the BIOS as well as in the Windows device manager.

If this is true, then this could very well be a new problem rather than an extension of the old one.
If you are sure that the drive no longer appears in BIOS, and that there are no settings to activate it, then the only explanation would be a hardware issue. Those drives emit a lot of vibration when used, and you had used it before the error occured. A losely connected controller or power cable could be disconnected by those vibrations.
Open the PC and make sure all cables are properly and tightly connected.

Should you find the drive back in the BIOS, however, then this could be a Windows issue. Check out this page for a fix; should the fix not work, try the uninstall/reinstall method under "Next steps": http://support.microsoft.com/?scid=kb%3Ben-us%3B314060

Also, take into consideration that the drive itself might be defective. CD/DVD drives and burners are the type of hardware in a PC most prone to breaking regularly. Everybody knows this: so if the computer is still under warranty, HP will send you a replacement without much hassle, I guess.
0
 

Author Closing Comment

by:dlauseng
ID: 31564073
Thank you, torimar!
0
 

Author Comment

by:dlauseng
ID: 24499342
I opened the tower, blew out the dust, cleaned the vents and fans.  The CD-ROM is a SATA device.  The controller and power cables appeared to be properly connected, however I removed/replaced them.  Put it back together, booted up, and now the optical device is recognized and functioning correctly.

By the way, Device Manager reports the Hitachi hard drive as a SCSI Disk Device, however it is connected to SATA-1 on the motherboard.  Thought I'd seen "SCSI" somewhere while working on this problem.

Thank you torimar and lucifer82 for your comments.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Windows Vista fix 8 523
Windows 8 & Vista Networking 4 581
Profile service not available 6 100
Best practices power settings GPO Win 10 4 60
The Service applet starts in Extended Mode by Default, with a taskpad on the left of the services pane. This view mode was introduced in XP. As I find it not very usefull, I like to use the Standard view as default, and without the Console tree. …
So who is this article for? If you are like most of the computer users out there, you probably only realize the meaning of 'System maintenance' after something goes wrong. This article is for you if you care about keeping your system working opti…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now