?
Solved

Unable to access content on vpn server

Posted on 2009-03-30
8
Medium Priority
?
304 Views
Last Modified: 2012-05-06
I have been asked by a customer to setup a vpn which will consist of a server and no more than three remote clients. They require this in order to share their accounts system. Because I have no experience of vpn implementation I decided to setup a test system using one of my XP Pro machines as server on my cable broadband router ( Linksys BEFW11S4). I set a static ip for the pc and forwarded port 1723 to that ip in the router. I then set another pc as a client (connected wirelessly via a completely separate adsl connection) and was immediately able to make a connection to the server. At least that is to say that network connection icons appeared  on both systems. The problem is that I cannot see any content on the server from the client pc even though there is definitely a folder with full sharing enabled.
So I then tried bypassing the Linksys router altogether just in case there were any settings that I had missed. I plugged the server pc directly into the cable modem. Once again I managed to get a connection but absolutely no content seen.
Can anyone please advise on this? The organisation that wants the work doing is a charity that I do volunteer IT work for so I do not want to let them down. I have set points at 500.
0
Comment
Question by:whitland
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
8 Comments
 
LVL 14

Expert Comment

by:Roachy1979
ID: 24019393
You might want to consider using OpenVPN for stability of connection and the extended functionality that SSL VPN's offer.

http://openvpn.net/

You would need to install the server, generate certificates and install the client certificates on the client pcs.

0
 

Author Comment

by:whitland
ID: 24020571
Thank you roachy1979 for your input. but it  does not answer my question as to why I cannot see the server content from the client machine. I don't really want to have to resort to additional apps in order to achieve the aim of getting a vpn to work successfully between xp systems.
0
 
LVL 14

Expert Comment

by:Roachy1979
ID: 24022616
Ok.....sorry for not picking up on  this sooner......but the accounts system isn't Sage is it?  If it is it's a VERY bad idea running it over a VPN due to the risk of data corruption in the event of disconnection (Sage DB's aren't exactly stable in a LAN environment, never mind over a WAN!)

If it is using Sage, we can get round this using Remote Desktop to a machine on the network using the accounting package, so don;t worry!

If it's not Sage and your accounting package supports connections over a VPN, then to diagnose we'll need to carry out a couple of steps.  First of all, can you ping the server by IP address?  If you can, can you ping the server by DNS name?

How did you set up the PPTP server on XP ?  Did you follow any guides online?  If so, can you advise....

0
Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

 

Author Comment

by:whitland
ID: 24031489
No the accounts package is not Sage.
I setup the server following advice from a Home-Network-Help.Com guide. Steps I took:
I enabled an incoming virtual network connection on the xp pro pc. I also gave that pc a static ip address of 192.168.1.120 I then forwarded port1723 to that ip both in the Linksys befw11s4 router and in the windows firewall exceptions. The internet ip is 82.30.224.15
I then setup a client connection in a laptop running xp which is connected to a totally separate adsl b/band connection wirelessly.
Today I cannot even get a connection. This is getting worse. Hope you can help.
By the way, am I correct in thinking that only one client pc can access a vpn xp server at any time?
0
 

Author Comment

by:whitland
ID: 24033583
Further to previous message I am now connected to the server as at time of first report. The details tab is showing server ip as 192.168.1.121 and client as 192.168.1.122
I have tried entering in "run" on the client //192.168.1.121 but I get an error saying that the address cannot be found.
Sorry to be a bit confusing on this one but as I said I am no expert on vpn.
0
 
LVL 14

Accepted Solution

by:
Roachy1979 earned 2000 total points
ID: 24037915
You will need to be on a different subnet at each site.....This is a common problem, as your machine will not be able to differenciate between what traffic is destined for the local network and what traffic is for the remote network.

If you are using 192.168.1.0 255.255.255.0 for the main network, a remote network could use 192.168.2.0 255.255.255.0.  Then when you connect to the VPN, you will be assigned an address that will allow routing to take place between the networks,....

0
 

Author Comment

by:whitland
ID: 24040972
I have changed the ip, as you suggested, to 192.168.2.1 in the linksys. Once again I can connect from the client laptop to the server(now 192.168.2.121) but I still cannot see any content. I can ping the server from my main pc on the local network ok. When I //192.168.2.121 from the laptop I get an error unable to find address.
0
 

Author Comment

by:whitland
ID: 24041210
roachy1979..All of a sudden the penny dropped and I have liftoff. I suddenly realised that I should be keying \\and the internet ip of the server rather than the 192 blah blah
Anyway I can now see the files etc ok.
Many thanks for your help on this. If you had not advised changing the subnet I would certainly not have got any further. Points awarded.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Secure VPN Connection terminated locally by the Client.  Reason 442: Failed to enable Virtual Adapter. If you receive this error on Windows 8 or Windows 8.1 while trying to connect with the Cisco VPN Client then the solution is a simple registry f…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Suggested Courses
Course of the Month10 days, 14 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question