Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

SMTPException: Failure sending mail

Posted on 2009-03-30
2
Medium Priority
?
2,010 Views
Last Modified: 2013-12-17
Hi

In my asp.net 3.5 web application, I try to send email to multiple persons (almost 100) using for loop.
It works fine when email has no attachment. But, when email contains the large size attachment (300 KB), after sending 25 emails, it gives a smtpexception:"Failure sending mail".

I have tried using different size of attchment files and I noticed that its giving an exception when the email attachment size reached about 7 MB. (total size of the emails sent with attachment).

What should I do to resolve this problem?
0
Comment
Question by:aplusexpert
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 26

Expert Comment

by:jar3817
ID: 24097665
Maybe you're hitting some memory limit for your application. I'm a php guy, so I'm not terribly familiar with asp.net, but I know with php there is a default setting that limits the amount of memory for a script. Maybe you could up this limit to accommodate the size of the email (body + attachment) times the number of recipients.
0
 
LVL 7

Accepted Solution

by:
aplusexpert earned 0 total points
ID: 24877569
Hi

We found that this problem occurs due to the limit of the session size for SMTP server in IIS.  The default size for Limit session size to (KB): is 10240 (10 MB). It is the total size for sending emails for one mail session. So when our application sends email in a loop and the total email size exceeds this limit, it stops. So depending on mail size, you would be able to send x number of mails where x = Limit/Mail Size.
 
Suggested Action:

We can increase the session limit for the session to 50 MB or 100 MB.

This can be done as follows:

1. Start IIS (Internet Information Services).
2. Right click on Default SMTP Virtual Server and select Properties.
3. Select Message tab.
4. There is an option Limit session size to (KB). At present that value for this option has been set to 10240.
5. We can set this value to 51200 (50 MB) or 102400 (100 MB) or anything else as per our requirement.

Thanks.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
We aren’t perfect, just like everyone else.  Check out the email errors our community caught and learn the top errors every email marketer should avoid.
Familiarize people with the process of retrieving data from SQL Server using an Access pass-thru query. Microsoft Access is a very powerful client/server development tool. One of the ways that you can retrieve data from a SQL Server is by using a pa…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
Suggested Courses

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question