[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

553 Requested action not taken: mailbox name not allowed

Posted on 2009-03-30
10
Medium Priority
?
1,536 Views
Last Modified: 2013-11-30
I have a user who tried to send an email and received the following error:

This message has not yet been delivered. Microsoft Exchange will continue to try delivering the message on your behalf.

She then received the message that the delivery had failed:

#550 4.4.7 QUEUE.Expired; message expired ##

I can telnet to their mail server via port 25 from my Exchange Server.

I have protocol logging turned on for my Exchange Server and my Edge Transport Server.

There are no logs in the protocol logging directory on the Exchange Server (Haven't figured out why yet) but there are logs in the protocol logging directory on the Edge Transport Server.  Below is the log data from that particular email that was delayed and then rejected:

2009-03-27T14:01:31.991Z,edgesync - default-first-site-name to internet,08CB7AE3103DAF09,0,,213.180.138.18:25,*,,attempting to connect
2009-03-27T14:01:32.131Z,edgesync - default-first-site-name to internet,08CB7AE3103DAF09,1,192.168.5.25:27299,213.180.138.18:25,+,,
2009-03-27T14:01:33.459Z,edgesync - default-first-site-name to internet,08CB7AE3103DAF09,2,192.168.5.25:27299,213.180.138.18:25,<,220 mx.poczta.onet.pl Service ready,
2009-03-27T14:01:33.459Z,edgesync - default-first-site-name to internet,08CB7AE3103DAF09,3,192.168.15.5:27299,213.180.138.18:25,>,EHLO mail.mycompany.com,
2009-03-27T14:01:33.459Z,edgesync - default-first-site-name to internet,08CB7AE3103DAF09,4,192.168.15.5:27299,213.180.138.18:25,<,503 Bad sequence of commands,
2009-03-27T14:01:33.459Z,edgesync - default-first-site-name to internet,08CB7AE3103DAF09,5,192.168.15.5:27299,213.180.138.18:25,>,HELO mail.mycompany.com,
2009-03-27T14:01:33.600Z,edgesync - default-first-site-name to internet,08CB7AE3103DAF09,6,192.168.15.5:27299,213.180.138.18:25,<,553 Requested action not taken: mailbox name not allowed,
2009-03-27T14:01:33.600Z,edgesync - default-first-site-name to internet,08CB7AE3103DAF09,7,192.168.15.5:27299,213.180.138.18:25,>,QUIT,
2009-03-27T14:01:33.756Z,edgesync - default-first-site-name to internet,08CB7AE3103DAF09,8,192.168.15.25:27299,213.180.138.18:25,<,221 Service closing transmission channel,
2009-03-27T14:01:33.756Z,edgesync - default-first-site-name to internet,08CB7AE3103DAF09,9,192.168.15.25:27299,213.180.138.18:25,-,,Local

Is this on my end or theirs? How do I fix it if I need to.  I've ran a DNS report and all of my "stuff" is correct and functioning properly.
0
Comment
Question by:vetted
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
10 Comments
 
LVL 40

Expert Comment

by:coolsport00
ID: 24018824
Here are a couple posts to look at to see what may be going on:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23176470.html
http://thebackroomtech.com/2008/03/28/troubleshooting-exchange-error-447-delivery-delay-and-failures/

Also, to turn on logging on your server, you need to make sure Verbose is select under the "Protocol Logging Level" in your connectors (receive and send).

Regards.
~coolsport00
0
 

Author Comment

by:vetted
ID: 24018877
I appear to have everything needed per those two posts you suggested.  The only thing possible would be the greylisting if they have it.  How do I go about looking into this further?

I have Verbose selected under Protocol Logging for my send connector on both Exchange and Edge Transport server, however only the Edge Transport server is producing logs.
0
 
LVL 40

Expert Comment

by:coolsport00
ID: 24018942
The only other thing would be to contact the recv'ing org Exchg Admin to see if they have anything setup that would prevent emails from your org getting thru. Another idea is to make sure you have an SPF record setup in your external DNS, if you haven't already (http://www.openspf.org/; have a tool to assist in creating the record on this site, as well).

Logging for send should probably only be seen on your Edge since that is where your email is being routed through. I dont have the Edge setup on my org, just an ISA for my "Edge", so I can't be 100% confident in that answer, but believe it's correct.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:vetted
ID: 24018992
I do have an SPF record and it is correct.  I'll try contacting the other admin and see what I can find out.
0
 

Author Comment

by:vetted
ID: 24063490
I'm thinking perhaps it's my Watchguard firewall blocking it.  I have a request in for support with them.
0
 
LVL 40

Expert Comment

by:coolsport00
ID: 24063532
Hmmm...not sure how that could be, other than if you have header size limitations set on it. I'm not too familiar with firewalls though. Let me know what you find out.

~coolsport00
0
 

Author Comment

by:vetted
ID: 24067199
My Watchguard firewall did have a policy to block the "_" but it was disabled.  I know that Exchange doesn't support all characters.  I'm now wondering if it's coming from my Exchange Server.  Is there a setting in Exchange for this to allow it?

The reason I know it's on my end is because the recipient has offered another address for testing for us (which has an underscore in it but uses a different domain) and that one is hanging in the queue as well.
0
 
LVL 40

Accepted Solution

by:
coolsport00 earned 2000 total points
ID: 24068238
Here's a post of mine from a while back on characters, so not sure if that fits; this person's issue was indeed the firewall
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23488768.html

~coolsport00
0
 

Author Comment

by:vetted
ID: 24073984
It wasn't the firewall after all.  I had that rule set correctly.  As I was continuing to troubleshoot this issue, the "Last Error" in the mail queue on the Exchange server changed from the 553 to one saying that our mail was blocked by that recipients mail server anti-spam.

I have contacted this person and the fix is in progress.  I wish that this was the original error instead of sending me around a loop to find this answer.  Thanks for responding, points awarded.
0
 
LVL 40

Expert Comment

by:coolsport00
ID: 24074054
Thanks for posting and the points 'vetted'; You know technology...it certainly can get under our skin sometimes, but at least it keeps us getting paid! :)

Regards.
~coolsport00
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The main intent of this article is to make you aware of ‘Exchange fail to mount’ error, its effects, causes, and solution.
This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
how to add IIS SMTP to handle application/Scanner relays into office 365.

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question