Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 582
  • Last Modified:

RPC-HTTPS Frontend server not connecting

I Have reconfigured my RPC-HTTP setup following Sembee's instruction:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_22630640.html

But I am facing connectivity problem. when I am in LAN, the Conn status shows TCP/IP,
but when outside, if fails. Also tried with testexchangeconnectity.com, shows failed on the last stage.
I have FE-BE scenario.

The following is my setup:
Backend: Win2003 Sp2 + Exchange 2003 SP2 + RPC-HTTP (Back-end)
         NetBOIS Name: SRV
         Domain: domain.local
         FQDN: mail.domain.com

Frontend:Win2003 SP2 + Exchange 2003 SP2 + RPC Proxy setting
         NetBOIS Name: Webmail
         Domain: domain.local
         FQDN: webmail.domain.com

         HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\RpcProxy
         the values should be entered in the below format:
         SRV:6001-6002; srv.dadholding.local:6001-6002; SRV:6004; srv.dadholding.local:6004;
         SSL Certificate from 3rd party (GeoTrust):
         CN = webmail.domain.com
         O = webmail.domain.com
         IIS Security Authenthication Method:
         Basic authenthication


Outlook Client:
         URL to connect proxy server:
         https:// webmail.domain.com
         Principal name for proxy:
         msstc:webmail.domain.com

Please point my mistake, that i have messed-up, its FE-BE scenario, suppose to be easy setup, but already took 3 days, and counting.

Thanks
0
Wrathyimp
Asked:
Wrathyimp
  • 6
  • 3
2 Solutions
 
MesthaCommented:
If you are in an FE/BE then you shouldn't need my instructions.
The GUI should do everything for you.

As such I would suggest that you reset everything.

Change both servers to not part of the RPC topology in ESM.
Then on any server that has the RPC Proxy installed, remove it and then delete the RPC and RPC-WITH-CERT virtual directories from IIS manager. Then run IISRESET to write the change to the IIS metabase.

Next - reinstall the RPC Proxy component. Finally set the GUI as appropriate and wait 30 minutes.

Inside the LAN you need to ensure the name on the certificate resolves to the INTERNAL IP address of the server.

-M
0
 
WrathyimpAuthor Commented:
I have already tried your suggestion, as you have mentioned in another question before.
I have not done any registry changes as you have mentioned.
Well let me put the actual Domains names, that might point out the problem/conflicts if any.

BackEnd:
NetBIOS: DADSRV
Domain: Dadholding.com
FQDN: mail.dadholding.com

FrontEnd
NetBIOS: DADWEBMAIL
Domain: Dadholding.com
FQDN: webmail.dadholding.com

SSL Certificate from 3rd party (GeoTrust):
CN = webmail.dadholding.com
O = webmail.dadholding.com

Now is there any conflicts in FQDN of the SSL cert and the FE server.
Also I cannot have a HTTPS connection internally to webmail.dadholding.com
www.testexchangeconnectivity.com show a failure at the last stage, the IIS authentication, after passing the SSL certificate and the SSL port 443.

Thank you.
0
 
WrathyimpAuthor Commented:
Sorry the Domain I mentioned is not correct, its the following:
dadholding.local

Backend:
dadsrv.dadholding.local

Frontend:
dadwebmail.dadholding.local

Sorry, for any confusions, little frustrated, due to the problem.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
WrathyimpAuthor Commented:
I am getting RPCPing successful

RPCPinging proxy server webmail.dadholding.com with Echo Request Packet
Sending ping to server
Response from server received: 200
Pinging successfully completed in 172 ms
0
 
WrathyimpAuthor Commented:
but I get Failed if I ping mail.dadholding.com

C:\Program Files\Windows Resource Kits\Tools>rpcping -t ncacn_http -s mail.dadho
lding.com -o RpcProxy=mail.dadholding.com -P user,dadholding.local,* -H 1 -u 10 -
a connect -F 3 -R none -v 3 -E
RPCPing v2.12. Copyright (C) Microsoft Corporation, 2002
OS Version is: 5.2, Service Pack 2
Enter password for RPC/HTTP proxy:

RPCPinging proxy server mail.dadholding.com with Echo Request Packet
Sending ping to server
Error 12175 returned in the WinHttpSendRequest.
Ping failed.
0
 
WrathyimpAuthor Commented:
I have successfully connected with HTTPS.
The problem was using the correct domain name.
I was using the FQDN for my authentication, but it seems to be required to add my local domain, to successfully logon to the RPC proxy.

So I my case, I used dadholding.local\username, and it authenticated me, and I can see now the HTTPS in conn.

but, Now I want to know, how can I save the pasword, so my users need not add the local domain, and username each time the connect outlook, from outside.
0
 
MesthaCommented:
If the machine with Outlook is a member of the domain, then change the authentication from Basic to Integrated/NTLM and change the authentication type in Outlook. Then pass through authentication is enabled.

-M
0
 
WrathyimpAuthor Commented:
Yes, I tested it yesterday.
But looks like Outlook performance decreases, is it due to RPC? or just the machine itself.

thanks again Simon.

0
 
MesthaCommented:
Outlook performance should be unaffected. It takes a few seconds longer to connect, but once it is connected there should be no difference.

-M
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now