?
Solved

virtual consoles scroll and  switching does not work in linux  centos 5 distribution

Posted on 2009-03-30
7
Medium Priority
?
393 Views
Last Modified: 2013-12-16
hi ,
I have centos 5 linux distribution with mal functioning in switching between virtual consoles  using Ctrl-Alt-F[1-7] and  scrolling throug them using Shift-pgdn and Shift-pgup

can any body help
best regards
hatem gamal
0
Comment
Question by:hatem_from_mesr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 43

Expert Comment

by:ravenpl
ID: 24025928
Can You exactly describe Your problem?
Note, that after switching from ftom vt1 to vt2, the history of vt1 is forgotten. Maybe that's Your misfeature?
0
 

Author Comment

by:hatem_from_mesr
ID: 24027399
ravenpl,
>>>Can You exactly describe Your problem?
I'm using x window environment and trying the feature of virtual console
and it does not work that is my problem alse the feature of scrolling up and down between them is not working
is there is a solution for it or centos is an exception in that

regards
hatem gamal
0
 
LVL 43

Expert Comment

by:ravenpl
ID: 24027410
As I mentioned - the ctrl+alt+F? should work, but the scroll history is forgotten as soon as You leaving the console.
You cannot switch between those consoles? what display driver You have running(gfx card)?
0
Is Your Team Achieving Their Full Potential?

74% of employees feel they are not achieving their full potential. With Linux Academy, not only will you strengthen your team's core competencies but also their knowledge of of the newest IT topics.

With new material every week, we'll make sure that you stay ahead of the game.

 

Author Comment

by:hatem_from_mesr
ID: 24027487
>>>what display driver You have running(gfx card)?
vga card is: radeon 9200
0
 
LVL 43

Expert Comment

by:ravenpl
ID: 24027522
add "nomodeset" option to the boot line and verify if it's working now
0
 

Author Comment

by:hatem_from_mesr
ID: 24027571
ravenpl,
>>>add "nomodeset" option to the boot line and verify if it's working now
I'm beginner don't know the file name or the line to change please give me full details
0
 
LVL 43

Accepted Solution

by:
ravenpl earned 2000 total points
ID: 24027625
edit /etc/grub.conf file, to every line starting with "kernel ..." append nomodeset, eg.

        kernel /vmlinuz-2.6.18-92.1.22.el5PAE ro root=LABEL=/ nomodeset
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question