Solved

Exchange 2007 Message Size Limit

Posted on 2009-03-30
14
942 Views
Last Modified: 2012-05-06
I'm trying to increase the mssage size limit on our exchange server.  
Benn getting a fair few complaints recently that people sending mail in has been bouncing back due to size.
I have tried changing this by going into the Exchange Management Console then
Organization Configuration> Hub Transport> Global Settings> Transport Settings and changing the Tansport Limistt here to 20MB.  

I did that and tried sending a mail into the server again but it has bounced back.  
Does the server need to be rebooted for this to be applied or have I done it in the wrong place?
0
Comment
Question by:harris9999
  • 7
  • 6
14 Comments
 
LVL 6

Expert Comment

by:defkamel
ID: 24020975
this link should have all the steps you need http://www.msexchange.org/articles-tutorials/exchange-server-2007/management-administration/exchange-2007-message-size-limits.html  looks like you need to change the transport receive/send size limit.
0
 
LVL 40

Expert Comment

by:coolsport00
ID: 24021080
Here is the MS article:
http://technet.microsoft.com/en-us/library/bb124345.aspx
(a good one)

Once you make changes, you will need to restart the Transport service and more than likely the Info Store service. "Downtime" is minimal...several seconds.

Regards.
~coolsport00
0
 
LVL 3

Author Comment

by:harris9999
ID: 24021321
I have tried that and the command shell looks like the images below.
I restarted the Transport Service and the Info Store.

And sent another email to it but bounced back with the error:
5.1.0 - Unknown address error 552-'Requested mail action aborted: exceeded storage allocation'


exchange.gif
0
 
LVL 40

Expert Comment

by:coolsport00
ID: 24021675
Be aware that msg size is like disk size. If you place 20MB, the max msg size won't be 20MB, but less. You'll need to do 20x1024=20480KB; That's assuming you used the Console. Did you check the global setting?...Org Config -> Hub -> Global tab then Transport Setting Properites. I guess my question is, where are you wanting to set this up, globally or Hub level? It doesn't matter if you don't have multiple Hubs though. For my config, I have it setup on both the Transport settings and Rec'v connectors. Did you check the individual mailbox your testing to make sure the setting is NOT at a lower limit than 20480KB?
0
 
LVL 3

Author Comment

by:harris9999
ID: 24021805
Yes in the Global Setting I have it at 20480KB.  Thats where I first changed it.  
There is only the 1 server so that should probably be enough?
I have just checked the individual mailboxes and there is nothing set for them so I assume it inherits the default?
0
 
LVL 40

Expert Comment

by:coolsport00
ID: 24021866
Yes, that should certainly be all you need. But, let's go ahead and try setting the same limit on your Rec'v connector as well...both your Client & Default...just to see if that helps. Remember to restart your IS/Transport services. If that doesn't work, just configuring through the EMShell, restart services and see if that then works. I have seen some instances where Console configuration doesn't always work (not sure why) on many things.
0
 
LVL 3

Author Comment

by:harris9999
ID: 24022648
Ok, increased the limit on the Rec'v Connectors on both the CLient and default.  Restarted the services.
Sent the email.  It hasn't bounced back but still haven't got it to the users mailboxes.  
Is there anything I should be checking now?
0
Want to promote your upcoming event?

Are you going to an event? Are you going to be exhibiting at a tradeshow? Talking at a conference? Using a promotional banner in your email signature ensures that your organization’s most important contacts stay in the know and can potentially spread the word about the event.

 
LVL 40

Expert Comment

by:coolsport00
ID: 24022722
Not sure why haven't recv'd the email. It's a pretty seamless process, not much to it. Maybe have the user close Outlook then open it back up...
0
 
LVL 3

Author Comment

by:harris9999
ID: 24022763
Tried that.  Connecting into server remotely and opening the users email boxes.  i've sent emails to them after I sent the large one and they have went through alright.
0
 
LVL 40

Expert Comment

by:coolsport00
ID: 24022861
Here's a potential article to look at: http://support.microsoft.com/kb/298572/en-us

Also, I saw elsewhere that you need to restart the IS service and Sys ATTENDANT service. Try doing this 1st to see if it works, then go to the article.
0
 
LVL 3

Author Comment

by:harris9999
ID: 24024273
Actually the messages sent earlier did bounce back.  Took a bit longer this time though:
Status: 5.0.0 (permanent failure)
Remote-MTA: dns; [ipaddress]
Diagnostic-Code: smtp; 5.1.0 - Unknown address error 552-'Requested mail action aborted: exceeded storage allocation' (delivery attempts: 2)

I got the exchange server rebooted but still got the same problem.  
0
 
LVL 40

Expert Comment

by:coolsport00
ID: 24027726
OK...well, let's try and narrow this down more. You never mentioned specifically if you tried using the Shell as opposed to the Console. This DOES make a difference in some cases (for example, Exchange Stor Grp Restore), etc. If you haven't tried setting the limit using the Shell, I recommend doing so.

Also, you can type: Get-ReceiveConnector | List  to see what your rec'v connectors are saying (your global setting scrnshot above looks good, as already noted).  Use: Get-TransportServer | List  to list all transport settings to see where the issue "may" be. Gosh...I'm running out of answers here. :(
0
 
LVL 3

Author Comment

by:harris9999
ID: 24033620
I never tried using the Shell.  
What command should I type in there?

The Get-ReceiveConnector | List  is attached.
I don't see anything obvious.

ReceiveConnectorList.txt
0
 
LVL 40

Accepted Solution

by:
coolsport00 earned 500 total points
ID: 24038216
You've never tried using the Shell?????...well "harris.."....you'd better start! :P No, seriously, MS took a lot of stuff out of the GUI, for example, if you want to look at everyone's mailbox size, you have to use the Shell to see it! Isn't that dumb!? Anyway, I won't go off on that tangent. :)  Some things, even though they can be configured in the GUI (Console), just don't 'take' unless you use the Shell. Don't ask me why, I can't explain it...just is (for now, I'm hoping...heck they have Rollup7, you'd think they'd a fixed this stuff by now!).

OK...so, in reviewing your output, everything looks to be at 20MB, so the next step, even though your GUI is configured and shows correctly, is to use the Shell to set the size.
http://www.msexchange.org/articles-tutorials/exchange-server-2007/management-administration/exchange-2007-message-size-limits.html
http://www.exchange-genie.com/2007/11/how-to-set-message-size-limits-in-exchange-2007/
http://exchangepedia.com/blog/2007/09/exchange-server-2007-setting-message-size.html

When you're done, don't forget to restart your Exchg services.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Utilizing an array to gracefully append to a list of EmailAddresses
Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
This video discusses moving either the default database or any database to a new volume.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now