Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange 2007 Unable to Create Shared Mailbox Resource

Posted on 2009-03-30
4
Medium Priority
?
674 Views
Last Modified: 2012-05-06
I am trying to create a shared mailbox resource and am not able to. No matter how I do the Database name I keep getting these errors.

[PS] C:\Windows\System32>new-mailbox -alias "GenifaxTest" -Name "GenifaxTest" -d
atabase "PEA1DIR2EXCH01\SG2\SG2_MBDB02_500MB\SG2_MBDB02_500MB" -org "company.com/Charlotte/GenifaxTest OU" -shared -UserPrincipalName "genifaxtest@company.com"

New-Mailbox : Cannot bind parameter 'Database'. Cannot convert value
"PEA1DIR2EXCH01\SG2\SG2_MBDB02_500MB\SG2_MBDB02_500MB" to type
"Microsoft.Exchange.Configuration.Tasks.DatabaseIdParameter". Error: "'PEA1DIR2EXCH01\SG2\SG2_MBDB02_500MB\SG2_MBDB02_500MB' is not a valid value for the identity.
Parameter name: Identity"
At line:1 char:63
+ new-mailbox -alias "GenifaxTest" -Name "GenifaxTest" -database  <<<< "PEA1DIR2EXCH01\SG2\SG2_MBDB02_500MB\SG2_MBDB02_500MB" -org "company.com/Charlotte/GenifaxTest OU" -shared -UserPrincipalName "genifaxtest@company.com"
[PS] C:\Windows\System32>

My database Info
ClusterName: EXCH2K7CCR011
Server Name: PEA1DIR2EXCH01
Storage Group: SG2
Database: SG2_MBDB02_500MB
Path: I:\Exch\SG2\MBDB02\SG2_MBDB02_500MB.edb
0
Comment
Question by:jwhitepnv
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 1

Expert Comment

by:shodan15
ID: 24020860
"PEA1DIR2EXCH01\SG2\SG2_MBDB02_500MB\SG2_MBDB02_500MB"


Why SG2_MBDB02_500MB apear twice in your database name?  
0
 

Author Comment

by:jwhitepnv
ID: 24020971
If I pull one of them out I get this error:
Database "PEA1DIR2EXCH01\SG2\SG2_MBDB02_500MB" was not found. Please make sure
you have typed it correctly.
At line:1 char:1
+ n <<<< ew-mailbox -alias "GenifaxTest" -Name "GenifaxTest" -database "PEA1DIR
2EXCH01\SG2\SG2_MBDB02_500MB" -org "direct-general.com/Charlotte/GenifaxTest OU
" -shared -UserPrincipalName "genifaxtest@company.com"
0
 
LVL 1

Expert Comment

by:shodan15
ID: 24021233
Try to use ClusterName in place of ServerName.
Or you can use database GUID insted of "server\storageGroup\Database".
You can find Database GUID by issuing command:
     Get-MailboxDatabase |Format-List
0
 

Accepted Solution

by:
jwhitepnv earned 0 total points
ID: 24021328
Thanks for the help. I figured it out. The cluster resources have been moved to the other server so I was running these commands on the passive node which is why I guess it was not able to see the DB.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New style of hardware planning for Microsoft Exchange server.
Know the reasons and solutions to move/import EDB to New Exchange Server. Also, find out how to recover an Exchange .edb file and to restore the file back.
This video discusses moving either the default database or any database to a new volume.
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question