Solved

Exchange 2007 Unable to Create Shared Mailbox Resource

Posted on 2009-03-30
4
665 Views
Last Modified: 2012-05-06
I am trying to create a shared mailbox resource and am not able to. No matter how I do the Database name I keep getting these errors.

[PS] C:\Windows\System32>new-mailbox -alias "GenifaxTest" -Name "GenifaxTest" -d
atabase "PEA1DIR2EXCH01\SG2\SG2_MBDB02_500MB\SG2_MBDB02_500MB" -org "company.com/Charlotte/GenifaxTest OU" -shared -UserPrincipalName "genifaxtest@company.com"

New-Mailbox : Cannot bind parameter 'Database'. Cannot convert value
"PEA1DIR2EXCH01\SG2\SG2_MBDB02_500MB\SG2_MBDB02_500MB" to type
"Microsoft.Exchange.Configuration.Tasks.DatabaseIdParameter". Error: "'PEA1DIR2EXCH01\SG2\SG2_MBDB02_500MB\SG2_MBDB02_500MB' is not a valid value for the identity.
Parameter name: Identity"
At line:1 char:63
+ new-mailbox -alias "GenifaxTest" -Name "GenifaxTest" -database  <<<< "PEA1DIR2EXCH01\SG2\SG2_MBDB02_500MB\SG2_MBDB02_500MB" -org "company.com/Charlotte/GenifaxTest OU" -shared -UserPrincipalName "genifaxtest@company.com"
[PS] C:\Windows\System32>

My database Info
ClusterName: EXCH2K7CCR011
Server Name: PEA1DIR2EXCH01
Storage Group: SG2
Database: SG2_MBDB02_500MB
Path: I:\Exch\SG2\MBDB02\SG2_MBDB02_500MB.edb
0
Comment
Question by:jwhitepnv
  • 2
  • 2
4 Comments
 
LVL 1

Expert Comment

by:shodan15
ID: 24020860
"PEA1DIR2EXCH01\SG2\SG2_MBDB02_500MB\SG2_MBDB02_500MB"


Why SG2_MBDB02_500MB apear twice in your database name?  
0
 

Author Comment

by:jwhitepnv
ID: 24020971
If I pull one of them out I get this error:
Database "PEA1DIR2EXCH01\SG2\SG2_MBDB02_500MB" was not found. Please make sure
you have typed it correctly.
At line:1 char:1
+ n <<<< ew-mailbox -alias "GenifaxTest" -Name "GenifaxTest" -database "PEA1DIR
2EXCH01\SG2\SG2_MBDB02_500MB" -org "direct-general.com/Charlotte/GenifaxTest OU
" -shared -UserPrincipalName "genifaxtest@company.com"
0
 
LVL 1

Expert Comment

by:shodan15
ID: 24021233
Try to use ClusterName in place of ServerName.
Or you can use database GUID insted of "server\storageGroup\Database".
You can find Database GUID by issuing command:
     Get-MailboxDatabase |Format-List
0
 

Accepted Solution

by:
jwhitepnv earned 0 total points
ID: 24021328
Thanks for the help. I figured it out. The cluster resources have been moved to the other server so I was running these commands on the passive node which is why I guess it was not able to see the DB.
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question