Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1050
  • Last Modified:

iMac 4.1 with Intel Core Duo processor but Safari thinks it's a PowerPC.

My iMac has an Intel Core Duo processor but Safari thinks it's a PowerPC. Hence I can't watch my Netflix movies on my Mac.

What can I do to make Safari properly broadcast that my Mac has an Intel Core Duo and not a PowerPC?

By the way, Firefox reports the CPU correctly and does allow me to watch Netflix movies, but I want to use Safari.

Kevin
0
zorvek (Kevin Jones)
Asked:
zorvek (Kevin Jones)
  • 5
  • 3
3 Solutions
 
Eoin OSullivanConsultantCommented:
Quit Safari

Enable the Safari debug menu - http://www.macosxhints.com/article.php?story=20030110063041629

You will now have the option to change how your Browser appears when online.

BTW. What version of 10.4.?? are you running?  And what version of Safari?
0
 
Philip_SparkCommented:
the develop menu debug link is 5 years old

newer versions of safari let you turn the developer menu on and off through the advanced section in safari's preferences
0
 
Eoin OSullivanConsultantCommented:
Point taken Philip ... thanks
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
zorvek (Kevin Jones)ConsultantAuthor Commented:
Thanks...I'll do this tomorrow when at my Mac and get back to you.

Kevin
0
 
zorvek (Kevin Jones)ConsultantAuthor Commented:
This is what the user agent string is:

Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_4_11; en) AppleWebKit/525.27.1 (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1

What do I change in order for it to properly broadcast that the Mac is an Intel Mac?

Kevin
0
 
zorvek (Kevin Jones)ConsultantAuthor Commented:
My guess is this but I would like someone to confirm:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_4_11; en) AppleWebKit/525.27.1 (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1

Kevin
0
 
zorvek (Kevin Jones)ConsultantAuthor Commented:
The user agent "fix" isn't really a fix as it only works for a single page at a time.

I found a fix: find Safari in the Applications folder, open the "Get Info" dialog, and uncheck "Open using Rosetta".

Kevin
0
 
Eoin OSullivanConsultantCommented:
I hadn't even considered that you were using Rosetta.  There should be no reason to enable this checkbox in the first place so I guess it is a hang-over from your system settings .. did you upgrade from an earlier version of OSX or copy your system from an older Mac?
0
 
zorvek (Kevin Jones)ConsultantAuthor Commented:
It's not my Mac, it's my Dad's. I am pretty sure he has done some upgrades because he has had the same box for about three years. I have no idea what "Rosetta" even is...I just found the fix on another web site while doing some searches.

Kevin
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now