Bash: Ifconfig command not found

Hi,

I have just downloaded the virtual applicance for groundworks monitor community edition.

I don't want to be restricted to using the console of the machine it's located on - I would like to point the web browser on my machine to the applicance, so need to know it's IP address.

I opened a terminal window and typed ifconfig (which is what I seem to recall as being the linux equivalent to ipconfig) but get told bash: ifconfig: Command not found.

How can I find the IP of my applicance?!?!
MDWinterAsked:
Who is Participating?
 
http:// thevpn.guruConnect With a Mentor Commented:
use

/sbin/ifconfig

or when you switch to root do

su - root

instead of

su root
0
 
MDWinterAuthor Commented:
su - root worked a charm, many thanks!

0
 
SteveNetwork ManagerCommented:
you dont need to su to root to run the /sbin/ifconfig

just type it from any prompt and it'll give you the IP information for your active interfaces..

0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
http:// thevpn.guruCommented:
@Psycho

on RH or related systems..fedora..centos etc...normally when you switch from a regular user to root ..you will still have the env variables of the regular user this will not include the sbin directory and he wont be able to get ifconfig or any other sbin command to work...


as for your suggestion he tried it ...and it did not work..that is why he did ask in first place. :)
It would work using either sudo..or if you logon as root in the first place..
0
 
SteveNetwork ManagerCommented:
no.. he said he just ran 'ifconfig'

i agreed with you that you need to run the /sbin/ifconfig..

you DONT however have to SU to root to run it..

0
 
http:// thevpn.guruCommented:
true as well..
0
 
fosiul01Commented:
@ Hellow Boss shakoush2000
0
 
http:// thevpn.guruCommented:
Hey Fosiul01 ..you are doing good..great job in the ranking.
0
 
fosiul01Commented:
hahaah Because you are not here!!

stop answering question!!!
Jock... EE needs you..
0
 
azaad_aSr Sys AdminCommented:
On top of what shakous said..Try "locate ifconfig " as root which could give the output of its existence

Rgds
Az
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.