Solved

2003 Server File Backup problem

Posted on 2009-03-31
4
229 Views
Last Modified: 2012-05-06
Hi all,
I installed another file server and wants to move my data files to it. I used the backup software that comes with Server 2003 becsue it backs up all the permissions with it. After that I restore them to the new server and everything went fine. The problem is that all the files on the new server are Read Only and even if I uncheck the box and apply it still shows as Read Only. How do I make those files available to my users once moved.

Thanks
0
Comment
Question by:nmmcfk
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 3

Expert Comment

by:cracksalsa
ID: 24028183
Check the share level permissions on the folder. By default Windows 2003 sets the permissions to read-only on a new share whereas Windows 2000 defaulted to full control. Set your share permissions to full control and then lock down with NTFS permissions.
0
 
LVL 35

Accepted Solution

by:
Joseph Daly earned 500 total points
ID: 24028266
If that doesnt work and you have the ability to start over. I would suggest that you delete the files you copied using the backup program and use a tool like robocopy to copy the files to the destination.

The gui tool is very easy to use
http://technet.microsoft.com/en-us/magazine/2006.11.utilityspotlight.aspx

Off the top of my head for an aplication like yours I think you would want to use the /MIR /SEC /COPYALL /ZB command

The prompts will tell you more about what switches are available and what are tailored to your appliucation better.
0
 

Author Comment

by:nmmcfk
ID: 24028308
Ok thanks guys ... I will give this a try later on today.
0
 
LVL 1

Expert Comment

by:ebyk
ID: 24029607
The problem looks like the way the folder to where you have restored. Since you are restoring data with permissions using ntbackup, you need to make sure that you are not inheriting permissions to this folder from parent. It looks like the parent folder was set to read-only.
To recover from current state, you need to uncheck inherit permissions from parent, apply. make sure all the required users have relevant access set. Then run the following command,
attrib -R d:\restored-data  /S /D
where d:\restored-data is the folder to where th data was restored from backup. Have a good one.
0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

VM backup deduplication is a method of reducing the amount of storage space needed to save VM backups. In most organizations, VMs contain many duplicate copies of data, such as VMs deployed from the same template, VMs with the same OS, or VMs that h…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question