Solved

OWA 2003 does not work externally - DNS issue?

Posted on 2009-03-31
14
325 Views
Last Modified: 2012-05-06
I just setup a new SBS 2003 server. I have 5 pc's in the office connected to the exchange server and two laptops using pop3 accounts. I am trying to setup OWA but am not getting anywhere. I have port 25, 80, 110 and 443 all forwarded correctly to the server. I also have the MX record of mail.mydomain.com pointed to my external IP. What else do I need to do? Also, if you could walk me through it, I am a newbie at this. Thanks a lot!
0
Comment
Question by:knowprob
  • 7
  • 7
14 Comments
 
LVL 14

Expert Comment

by:Raj-GT
ID: 24029631
Open the SBS Management console and run "e-mail and internet connection wizard" - make sure you enter the correct details (post here if you are not sure of anything) and everything should be set-up for you.
0
 

Author Comment

by:knowprob
ID: 24029654
I actually re-ran the CEICW and everything looked fine to me. I still have no access. The url should be https://mail.mydomain.com/exchange, right? Or is it a different url? I've tried with all sorts of variations.

In one step of the wizard it asks for your domain name. It used microsoft.com as an example, so I just put mydomain.com. Should I have put mail.mydomain.com?
0
 
LVL 14

Expert Comment

by:Raj-GT
ID: 24029801
Firstly, are you using SBS Premium with ISA 2004 server? Regardless, you can easily test OWA locally by browsing https://sbsservername/exchange from one of the LAN hosts. If you can login successfully, you can confirm OWA is working.

And for the domain name in CEICW, you have to enter the full public domain name "mail.mydomain.com". Also you only need the MX records for mail delivery, for OWA you need to create an A record.
0
 

Author Comment

by:knowprob
ID: 24029976
Is that something my ISP needs to create?
0
 
LVL 14

Expert Comment

by:Raj-GT
ID: 24030229
Whoever is managing your domain (or whoever created the MX record) can create the 'A' record for OWA. Btw, did you test OWA internally, and is it working?
0
 

Author Comment

by:knowprob
ID: 24049309
When I bring up http://mail.mydomain.com internally, it brings up the SBS 2003 company site. If I click on the Remote E-mail link on the right then it brings up the OWA login screen.
0
 
LVL 14

Expert Comment

by:Raj-GT
ID: 24049645
Sounds like you arre using a split DNS setup. The recommended practice in an SBS network is to use MYDOMAIN.LOCAL internal and MYDOMAIN.COM as external.Since you are able to access OWA internally, you need to check to see whether you have the correct A record to point mail.domain.com to your router's external IP.

You have to test this from an external host outside your LAN - open the command prompt and type
nslookup mail.mydomain.com (substitute mydomain.com with the real domain name you are using ;-)

If you see your routers external IP for the nslookup query above, you have the dns side of everything correctly configured.
0
3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

 

Author Comment

by:knowprob
ID: 24049741
When I tried the nslookup externally, it gives me this message:
*** Can't find server name for address 192.168.1.1: Non-existant domain
*** Default servers are not available
Server: UnKnown
Address: 192.168.1.1

Non-authoritative answer:
Name: mail.mydomain.org
Address: (This is the correct external IP)

If I get the host to add an A record, should this clear itself up?
0
 
LVL 14

Expert Comment

by:Raj-GT
ID: 24050053
Do you use mydomain.com or mydomain.org? If you are getting the correct address resolved, you should be able to access OWA from the internet using https://mail.mydomain.org/exchange, in case you don't have SSL enabled try http://mail.mydomain.org/exchange. If you are still unable to connect, you have to check the router and make sure the port forwarding rules are setup correctly.

However, if you can access your http://mail.mydomain.org from outside and able to see default SBS portal then the rules are working.
0
 

Author Comment

by:knowprob
ID: 24063181
If I go to http://mail.mydomain.org then I get the company's internal website.

If I go to https://mail.mydomain.org then I get nothing.

If I go to https://mail.mydomain.org/exchange OR http://mail.mydomain.org/exchange I get nothing, too.

I double-checked the router and all of the ports are forwarded correctly.

The only thing that hasn't been setup is the "A" record. Would that be what's doing it? I can't see that being the problem since I can see the internal website.
0
 
LVL 14

Accepted Solution

by:
Raj-GT earned 500 total points
ID: 24066479
Since you can access http://mail.mydomain.org internally and externally, you have the correct A record configured. You are also able to access OWA internally, that means OWA is configured and working as well. The only think I would suspect now is the port forwarding on the router. Are you sure TCP 443 is being forwarded to the servers IP?

Btw, you still have't answered few of my questions..
Are you using SBS Premium with ISA 2004 server?
Are you able to access OWA through https://sbsservername/exchange from one of the LAN hosts?
Are you using mydomain.org as your internal domain (AD) as well as external domain?
0
 

Author Comment

by:knowprob
ID: 24109474
Sorry for the long relay in responding.

I am not using SBS Premium with ISA 2004 server.
I am able to access https://servername/exchange from the lan hosts but it gives me a certificate error. I can still continue with the error but would like that to go away as well.
My internal domain is different than the external domain.
The internal domain is: server.mydomain1.local
The external domain is: mail.mydomain.org
Is there something I need setup to get this to work? I re-forwarded port 443 but it still won't work.
0
 
LVL 14

Expert Comment

by:Raj-GT
ID: 24111468
What router are you using to port forward? I still suspect something's wrong with the forwarding rules.
Can you try access your companys site using the public IP from the internet?
http://publicip/
https://publicip/exchange
0
 

Author Closing Comment

by:knowprob
ID: 31564845
You are correct. The router we were using was not saving by configuration, or at least using it. I replaced the router, re-forwarded the ports and it seems to be working fine now. Thank you for all your help! Port 443, FTW!
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now