Solved

Cisco 2960 no port status on CNA after IOS upgrade

Posted on 2009-03-31
5
1,382 Views
Last Modified: 2012-06-21
After upgrading a CISCO WS-C2960-48TT-L from 12.2(46) to 12.2(50) in my Testlab,
I lost the colored port status display on the CNA Verison 5.4. It shows all ports in blue.

I did use c2960-lanbasek9-tar.122-50.SE.tar for the upgrade.

What wrong -- I or Cisco?

As fares the CNA uses http(s) to communicate here the silce from my running config:

version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
service password-encryption
service sequence-numbers
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
aaa authorization network default local
!
!
!
aaa session-id common
crypto pki trustpoint HTTPS_SS_CERT_KEYPAIR
enrollment selfsigned
serial-number
revocation-check none
rsakeypair HTTPS_SS_CERT_KEYPAIR
!
!
crypto pki certificate chain HTTPS_SS_CERT_KEYPAIR
certificate self-signed 01

ip default-gateway uuu.vvv.www.xxx
ip http server
ip http authentication local
ip http secure-server
!
control-plane
!
!
line con 0
line vty 0 4
password 7 xxxxxxxxxxxxxxxxxxxx
length 0
transport input ssh
line vty 5 15
password 7 xxxxxxxxxxxxxxxxxxxx
transport input ssh
0
Comment
Question by:ROMCHCH
  • 2
  • 2
5 Comments
 
LVL 5

Accepted Solution

by:
Melaleuca earned 250 total points
ID: 24035407
Well your running config doesn't show any interfaces, you can roll your image back and see if there is bug. Do you do anything with the command line, if so you can log into the device and do a show controllers. and show interface status
0
 

Author Comment

by:ROMCHCH
ID: 24037277
Below I find the complete running config. With CLI I can show & change any Interface with the OLD & the NEW Verion of IOS.
Only when I use the Cisco Network Assistent with the 12.2(50) IOS then I get no graphical port Status. All are blue instead of green, gray or orange. When I use the inface context menue then I can operate it without problems.
Current configuration : 12037 bytes

!

! No configuration change since last restart

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log datetime

service password-encryption

service sequence-numbers

!

hostname xxxxxxxxxxxxxxxxx

!

boot-start-marker

boot-end-marker

!

enable secret 5 xxxxxxxxxxxxxxxxxxxxxx

enable password 7 xxxxxxxxxxxxxxxxxxxxxxxx

!

username abc privilege 15 password 7 xxxxxxxxxxxxxxxxxxx

username def privilege 15 password 7 xxxxxxxxxxxxxxxxxxxx

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

aaa authorization network default local

!

!

!

aaa session-id common

clock timezone CET 1

clock summer-time CET recurring last Sun Mar 2:00 last Sun Oct 3:00

system mtu routing 1500

udld aggressive
 

ip subnet-zero

!

!

ip domain-name sm.sulzer.com

ip name-server 192.168.1.8

ip name-server 192.168.1.9

!

mls qos map cos-dscp 0 8 16 24 32 46 46 56

mls qos srr-queue input bandwidth 90 10

mls qos srr-queue input threshold 1 8 16

mls qos srr-queue input threshold 2 34 66

mls qos srr-queue input buffers 67 33

mls qos srr-queue input cos-map queue 1 threshold 2  1

mls qos srr-queue input cos-map queue 1 threshold 3  0

mls qos srr-queue input cos-map queue 2 threshold 1  2

mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7

mls qos srr-queue input cos-map queue 2 threshold 3  3 5

mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15

mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7

mls qos srr-queue input dscp-map queue 1 threshold 3  32

mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23

mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48

mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56

mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63

mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31

mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47

mls qos srr-queue output cos-map queue 1 threshold 3  5

mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3  2 4

mls qos srr-queue output cos-map queue 4 threshold 2  1

mls qos srr-queue output cos-map queue 4 threshold 3  0

mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47

mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31

mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55

mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63

mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23

mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39

mls qos srr-queue output dscp-map queue 4 threshold 1  8

mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15

mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7

mls qos queue-set output 1 threshold 1 138 138 92 138

mls qos queue-set output 1 threshold 2 138 138 92 400

mls qos queue-set output 1 threshold 3 36 77 100 318

mls qos queue-set output 1 threshold 4 20 50 67 400

mls qos queue-set output 2 threshold 1 149 149 100 149

mls qos queue-set output 2 threshold 2 118 118 100 235

mls qos queue-set output 2 threshold 3 41 68 100 272

mls qos queue-set output 2 threshold 4 42 72 100 242

mls qos queue-set output 1 buffers 10 10 26 54

mls qos queue-set output 2 buffers 16 6 17 61

!

crypto pki trustpoint HTTPS_SS_CERT_KEYPAIR

 enrollment selfsigned

 serial-number

 revocation-check none

 rsakeypair HTTPS_SS_CERT_KEYPAIR

!

!

crypto pki certificate chain HTTPS_SS_CERT_KEYPAIR

 certificate self-signed 01

  xxxxxxxxxxxxxxxxxxxx

  ............

  ..............

  quit

!

!

macro global description cisco-global

!

!

!

errdisable recovery cause udld

errdisable recovery cause bpduguard

errdisable recovery cause security-violation

errdisable recovery cause channel-misconfig

errdisable recovery cause pagp-flap

errdisable recovery cause dtp-flap

errdisable recovery cause link-flap

errdisable recovery cause sfp-config-mismatch

errdisable recovery cause gbic-invalid

errdisable recovery cause psecure-violation

errdisable recovery cause port-mode-failure

errdisable recovery cause dhcp-rate-limit

errdisable recovery cause mac-limit

errdisable recovery cause vmps

errdisable recovery cause storm-control

errdisable recovery cause inline-power

errdisable recovery cause loopback

errdisable recovery cause small-frame

errdisable recovery interval 60

!

spanning-tree mode rapid-pvst

spanning-tree loopguard default

spanning-tree portfast bpduguard default

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

interface FastEthernet0/1

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/2

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/3

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/4

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/5

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/6

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/7

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/8

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/9

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/10

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/11

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/12

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/13

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/14

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/15

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/16

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/17

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/18

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/19

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/20

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/21

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/22

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/23

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/24

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/25

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/26

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/27

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/28

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/29

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/30

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/31

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/32

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/33

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/34

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/35

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/36

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/37

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/38

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/39

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/40

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/41

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/42

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/43

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/44

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/45

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/46

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/47

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface FastEthernet0/48

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface GigabitEthernet0/1

 switchport mode trunk

 srr-queue bandwidth share 10 10 60 20

 queue-set 2

 priority-queue out

 mls qos trust cos

 macro description cisco-switch

 auto qos voip trust

 spanning-tree link-type point-to-point

!

interface GigabitEthernet0/2

 switchport mode trunk

!

interface Vlan1

 ip address 192.168.1.15 255.255.255.0

 no ip route-cache

!

ip default-gateway 192.168.1.1

ip http server

ip http authentication local

ip http secure-server

!

control-plane

!

!

line con 0

line vty 0 4

 password 7 xxxxxxxxxxxxxxxxxxxx

 length 0

 transport input ssh

line vty 5 15

 password 7 xxxxxxxxxxxxxxxxxxxxxx

 transport input ssh

!

ntp clock-period 36029073

ntp server 192.168.1.1 key 0 prefer

Open in new window

0
 
LVL 5

Expert Comment

by:Melaleuca
ID: 24108676
Sorry for the late response. I am not really sure i don't use CNA, I could be a bug in the version but i don't see anything that should cause it not to work.
0
 

Expert Comment

by:djm17178
ID: 25675613
I just had this same issue.  You need to upgrade CNA to the latest versino (5.5 in my case).  That will fix the problem.

You can even do it within CNA by providing your CCO credentials.  It will automatically download the updates.
0
 

Author Comment

by:ROMCHCH
ID: 25677908
I did also upgraded to CNA version 5.5 before I saw your Comment.

This did fix the problem.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The worst thing when starting a new job is when the previous Network Administrator left behind no documentation. How do you get into the devices? If you've been in this situation or just accidently mistyped your password, this article will hopefully…
I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now