Solved

Cisco Catalyst 2960 / 3560 inter-vlan routing

Posted on 2009-03-31
18
2,224 Views
Last Modified: 2012-06-27
I'm using a pair of 3560s as core switches, and 5 2960s as edge switches.

In the code segment I've put the running config of one of my core switches, and one of my edge switches.

Once upon a time, I had everything configured and everything was working.  I had the 5 edge switches plugged into the 2 core switches, the 2 core switches linked together, and one of the core switches plugged into the production LAN (thus allowing DHCP and internet access).

The DHCP server resides on VLAN1, 192.168.10.0/24 (actual address is 192.168.10.246).  All other VLANs are 10.<dept>.0.0/16.  For example our systems department resides on the 10.16.0.0/16 subnet.

Well, unfortunately I put them aside after they were configured, waiting for a bunch of new cable to arrive so that I could implement the new switches.  I decided to try things out again real quick and make sure that it all works, and sure enough, it does not work.

From both switches I am able to ping the DHCP server via source vlan1, however I am not able to ping via any other source... for example:

SW-CORE-2#ping 192.168.10.246 source vlan1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.246, timeout is 2 seconds:
Packet sent with a source address of 192.168.10.203
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
SW-CORE-2#ping 192.168.10.246 source vlan16

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.246, timeout is 2 seconds:
Packet sent with a source address of 10.16.0.201
.....
Success rate is 0 percent (0/5)
SW-CORE-2#


I have not changed anything on my DHCP, or on the switches... but something must've changed?
::::::CORE SWITCH:::::::

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2009.03.31 10:04:16 =~=~=~=~=~=~=~=~=~=~=~=

sh running-config

Building configuration...
 

Current configuration : 8205 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname SW-CORE-2

!

enable secret 5 $1$BQQ5$UEZGskeubUdSHkSHv1T680

!

no aaa new-model

clock timezone UTC -7

clock summer-time UTC recurring

system mtu routing 1500

ip subnet-zero

!

!

mls qos map cos-dscp 0 8 16 26 32 46 48 56

mls qos srr-queue input bandwidth 90 10

mls qos srr-queue input threshold 1 8 16

mls qos srr-queue input threshold 2 34 66

mls qos srr-queue input buffers 67 33 

mls qos srr-queue input cos-map queue 1 threshold 2  1

mls qos srr-queue input cos-map queue 1 threshold 3  0

mls qos srr-queue input cos-map queue 2 threshold 1  2

mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7

mls qos srr-queue input cos-map queue 2 threshold 3  3 5

mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15

mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7

mls qos srr-queue input dscp-map queue 1 threshold 3  32

mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23

mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48

mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56

mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63

mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31

mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47

mls qos srr-queue output cos-map queue 1 threshold 3  5

mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3  2 4

mls qos srr-queue output cos-map queue 4 threshold 2  1

 --More--         mls qos srr-queue output cos-map queue 4 threshold 3  0

mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47

mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31

mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55

mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63

mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23

mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39

mls qos srr-queue output dscp-map queue 4 threshold 1  8

mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15

mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7

mls qos queue-set output 1 threshold 1 138 138 92 138

mls qos queue-set output 1 threshold 2 138 138 92 400

mls qos queue-set output 1 threshold 3 36 77 100 318

mls qos queue-set output 1 threshold 4 20 50 67 400

mls qos queue-set output 2 threshold 1 149 149 100 149

mls qos queue-set output 2 threshold 2 118 118 100 235

mls qos queue-set output 2 threshold 3 41 68 100 272

mls qos queue-set output 2 threshold 4 42 72 100 242

mls qos queue-set output 1 buffers 10 10 26 54

mls qos queue-set output 2 buffers 16 6 17 61

mls qos

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface Port-channel1

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface GigabitEthernet0/1

 description Link to SW-A

 switchport trunk encapsulation dot1q

 switchport mode trunk

 srr-queue bandwidth share 10 10 60 20

 srr-queue bandwidth shape  10  0  0  0 

 queue-set 2

 mls qos trust cos

 macro description cisco-switch

 --More--          auto qos voip trust 

 spanning-tree link-type point-to-point

!

interface GigabitEthernet0/2

 description Link to SW-B

 switchport trunk encapsulation dot1q

 switchport mode trunk

 srr-queue bandwidth share 10 10 60 20

 srr-queue bandwidth shape  10  0  0  0 

 queue-set 2

 mls qos trust cos

 macro description cisco-switch

 auto qos voip trust 

 spanning-tree link-type point-to-point

!

interface GigabitEthernet0/3

 description Link to SW-C

 switchport trunk encapsulation dot1q

 switchport mode trunk

 srr-queue bandwidth share 10 10 60 20

 srr-queue bandwidth shape  10  0  0  0 

 queue-set 2

 mls qos trust cos

 macro description cisco-switch

 auto qos voip trust 

 spanning-tree link-type point-to-point

!

interface GigabitEthernet0/4

 description Link to SW-D

 switchport trunk encapsulation dot1q

 switchport mode trunk

 srr-queue bandwidth share 10 10 60 20

 srr-queue bandwidth shape  10  0  0  0 

 queue-set 2

 mls qos trust cos

 macro description cisco-switch

 auto qos voip trust 

 spanning-tree link-type point-to-point

!

interface GigabitEthernet0/5

 description Link to SW-E

 switchport trunk encapsulation dot1q

 switchport mode trunk

 --More--          srr-queue bandwidth share 10 10 60 20

 srr-queue bandwidth shape  10  0  0  0 

 queue-set 2

 mls qos trust cos

 macro description cisco-switch

 auto qos voip trust 

 spanning-tree link-type point-to-point

!

interface GigabitEthernet0/6

 description ESX01-1

!

interface GigabitEthernet0/7

 description ESX01-2

!

interface GigabitEthernet0/8

 description ESX02-1

!

interface GigabitEthernet0/9

 description ESX02-2

!

interface GigabitEthernet0/10

 description Reserved for ESX03

!

interface GigabitEthernet0/11

 description Reserved for ESX03

!

interface GigabitEthernet0/12

!

interface GigabitEthernet0/13

 description Firewall

!

interface GigabitEthernet0/14

 description Wireless

!

interface GigabitEthernet0/15

 description Protective South

!

interface GigabitEthernet0/16

 description Firehall North

!

interface GigabitEthernet0/17

 description Shop

!

 --More--         interface GigabitEthernet0/18

!

interface GigabitEthernet0/19

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

 description Trunk Link 1

 switchport trunk encapsulation dot1q

 switchport mode trunk

 srr-queue bandwidth share 10 10 60 20

 srr-queue bandwidth shape  10  0  0  0 

 queue-set 2

 mls qos trust cos

 macro description cisco-switch

 auto qos voip trust 

 channel-group 1 mode desirable

 spanning-tree link-type point-to-point

!

interface GigabitEthernet0/24

 description Trunk Link 2

 switchport trunk encapsulation dot1q

 switchport mode trunk

 srr-queue bandwidth share 10 10 60 20

 srr-queue bandwidth shape  10  0  0  0 

 queue-set 2

 mls qos trust cos

 macro description cisco-switch

 auto qos voip trust 

 channel-group 1 mode desirable

 spanning-tree link-type point-to-point

!

interface GigabitEthernet0/25

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

 --More--         !

interface Vlan1

 ip address 192.168.10.203 255.255.255.0

!

interface Vlan2

 ip address 10.2.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan11

 ip address 10.11.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan12

 ip address 10.12.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan14

 ip address 10.14.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan15

 ip address 10.15.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan16

 ip address 10.16.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan17

 ip address 10.17.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan18

 ip address 10.18.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan19

 ip address 10.19.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan21

 ip address 10.21.0.201 255.255.0.0

 ip helper-address 192.168.10.246

 --More--         !

interface Vlan23

 ip address 10.23.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan24

 ip address 10.24.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan32

 ip address 10.32.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan51

 ip address 10.51.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan61

 ip address 10.61.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan62

 ip address 10.62.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

interface Vlan75

 ip address 10.75.0.201 255.255.0.0

 ip helper-address 192.168.10.246

!

ip default-gateway 192.168.10.200

ip classless

ip http server

!

!

!

control-plane

!

!

line con 0

line vty 0 4

 password marie

 login

 length 0

 --More--         line vty 5 15

 password marie

 login

 length 0

!

end
 

:::::::::EDGE SWITCH::::::::::::::
 

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2009.03.31 10:06:00 =~=~=~=~=~=~=~=~=~=~=~=

sh running-config

Building configuration...
 

Current configuration : 4019 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname SW-C

!

enable secret 5 $1$2M5y$cKW0mRRNQ/j7VzWWsJ98P0

!

no aaa new-model

system mtu routing 1500

ip subnet-zero

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface GigabitEthernet0/1

 switchport mode access

!

interface GigabitEthernet0/2

 switchport access vlan 15

 switchport mode access

!

interface GigabitEthernet0/3

 switchport mode access

!

interface GigabitEthernet0/4

 switchport access vlan 15

 switchport mode access

!

interface GigabitEthernet0/5

 switchport access vlan 11

 switchport mode access

 --More--         !

interface GigabitEthernet0/6

 switchport access vlan 51

 switchport mode access

!

interface GigabitEthernet0/7

 switchport access vlan 51

 switchport mode access

!

interface GigabitEthernet0/8

 switchport access vlan 32

 switchport mode access

!

interface GigabitEthernet0/9

 switchport mode access

!

interface GigabitEthernet0/10

 switchport mode access

!

interface GigabitEthernet0/11

 switchport mode access

!

interface GigabitEthernet0/12

 switchport access vlan 51

 switchport mode access

!

interface GigabitEthernet0/13

 switchport mode access

!

interface GigabitEthernet0/14

 switchport mode access

!

interface GigabitEthernet0/15

 switchport mode access

!

interface GigabitEthernet0/16

 switchport mode access

!

interface GigabitEthernet0/17

 switchport mode access

!

interface GigabitEthernet0/18

 switchport mode access

 --More--         !

interface GigabitEthernet0/19

 switchport mode access

!

interface GigabitEthernet0/20

 switchport access vlan 11

 switchport mode access

!

interface GigabitEthernet0/21

 switchport mode access

!

interface GigabitEthernet0/22

 switchport access vlan 61

 switchport mode access

!

interface GigabitEthernet0/23

 switchport access vlan 17

 switchport mode access

!

interface GigabitEthernet0/24

 switchport access vlan 32

 switchport mode access

!

interface GigabitEthernet0/25

 switchport access vlan 32

 switchport mode access

!

interface GigabitEthernet0/26

 switchport access vlan 17

 switchport mode access

!

interface GigabitEthernet0/27

 switchport access vlan 11

 switchport mode access

!

interface GigabitEthernet0/28

 switchport access vlan 11

 switchport mode access

!

interface GigabitEthernet0/29

 switchport access vlan 61

 switchport mode access

!

 --More--         interface GigabitEthernet0/30

 switchport access vlan 61

 switchport mode access

!

interface GigabitEthernet0/31

 switchport access vlan 11

 switchport mode access

!

interface GigabitEthernet0/32

 switchport mode access

!

interface GigabitEthernet0/33

 switchport access vlan 32

 switchport mode access

!

interface GigabitEthernet0/34

 switchport access vlan 61

 switchport mode access

!

interface GigabitEthernet0/35

 switchport mode access

!

interface GigabitEthernet0/36

 switchport access vlan 17

 switchport mode access

!

interface GigabitEthernet0/37

 switchport mode access

!

interface GigabitEthernet0/38

 switchport access vlan 16

 switchport mode access

!

interface GigabitEthernet0/39

 switchport mode access

!

interface GigabitEthernet0/40

 switchport mode access

!

interface GigabitEthernet0/41

 switchport access vlan 62

 switchport mode access

!

 interface GigabitEthernet0/42

 switchport mode access

!

interface GigabitEthernet0/43

 switchport access vlan 17

 switchport mode access

!

interface GigabitEthernet0/44

 switchport access vlan 15

 switchport mode access

!

interface GigabitEthernet0/45

 switchport access vlan 17

 switchport mode access

!

interface GigabitEthernet0/46

 switchport access vlan 51

 switchport mode access

!

interface GigabitEthernet0/47

 switchport mode trunk

!

interface GigabitEthernet0/48

 switchport mode trunk

!

interface Vlan1

 ip address 192.168.10.237 255.255.255.0

 no ip route-cache

!

ip default-gateway 192.168.10.200

ip http server

!

control-plane

!

!

line con 0

line vty 0 4

 password marie

 login

line vty 5 15

 password marie

 login

!

 --More--         end
 

SW-C#

Open in new window

0
Comment
Question by:lunanat
  • 9
  • 8
18 Comments
 
LVL 23

Expert Comment

by:that1guy15
ID: 24030510
If you have not changed the config in any way double check that the switches are connected properly and that you are using the proper types of cables for your trunk ports (corssover).
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24030532
The DHCP server has a default gateway of 192.168.10.203, right?
0
 
LVL 1

Author Comment

by:lunanat
ID: 24030541
The cables in the trunk ports are not crossover, but they were not crossover in my initial setup either -I'm using the same cables, and I've looked several times to make sure that the ports are all connected the same way as they were before.

I created a lot of reference documentation, and also created port descriptions relating to their function.
0
 
LVL 1

Author Comment

by:lunanat
ID: 24030573
H:\>route print

IPv4 Route Table
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x10003 ...00 50 56 82 6b 6b ...... VMware Accelerated AMD PCNet Adapter
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0   192.168.10.200   192.168.10.246     10
         10.1.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
         10.2.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.11.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.12.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.14.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.15.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.16.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.17.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.18.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.19.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.21.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.23.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.24.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.32.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.51.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.61.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.62.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        10.75.0.0    255.255.255.0   192.168.10.202   192.168.10.246      1
        127.0.0.0        255.0.0.0        127.0.0.1        127.0.0.1      1
     192.168.10.0    255.255.255.0   192.168.10.246   192.168.10.246     10
   192.168.10.246  255.255.255.255        127.0.0.1        127.0.0.1     10
   192.168.10.255  255.255.255.255   192.168.10.246   192.168.10.246     10
        224.0.0.0        240.0.0.0   192.168.10.246   192.168.10.246     10
  255.255.255.255  255.255.255.255   192.168.10.246   192.168.10.246      1
Default Gateway:    192.168.10.200
===========================================================================
Persistent Routes:
  Network Address          Netmask  Gateway Address  Metric
         10.1.0.0    255.255.255.0   192.168.10.202       1
         10.1.0.0    255.255.255.0   192.168.10.203       1
         10.2.0.0    255.255.255.0   192.168.10.202       1
         10.2.0.0    255.255.255.0   192.168.10.203       1
        10.11.0.0    255.255.255.0   192.168.10.202       1
        10.11.0.0    255.255.255.0   192.168.10.203       1
        10.12.0.0    255.255.255.0   192.168.10.202       1
        10.12.0.0    255.255.255.0   192.168.10.203       1
        10.14.0.0    255.255.255.0   192.168.10.202       1
        10.14.0.0    255.255.255.0   192.168.10.203       1
        10.15.0.0    255.255.255.0   192.168.10.202       1
        10.15.0.0    255.255.255.0   192.168.10.203       1
        10.16.0.0    255.255.255.0   192.168.10.202       1
        10.16.0.0    255.255.255.0   192.168.10.203       1
        10.17.0.0    255.255.255.0   192.168.10.202       1
        10.17.0.0    255.255.255.0   192.168.10.203       1
        10.18.0.0    255.255.255.0   192.168.10.202       1
        10.18.0.0    255.255.255.0   192.168.10.203       1
        10.19.0.0    255.255.255.0   192.168.10.202       1
        10.19.0.0    255.255.255.0   192.168.10.203       1
        10.21.0.0    255.255.255.0   192.168.10.202       1
        10.21.0.0    255.255.255.0   192.168.10.203       1
        10.23.0.0    255.255.255.0   192.168.10.202       1
        10.23.0.0    255.255.255.0   192.168.10.203       1
        10.24.0.0    255.255.255.0   192.168.10.202       1
        10.24.0.0    255.255.255.0   192.168.10.203       1
        10.32.0.0    255.255.255.0   192.168.10.202       1
        10.32.0.0    255.255.255.0   192.168.10.203       1
        10.51.0.0    255.255.255.0   192.168.10.202       1
        10.51.0.0    255.255.255.0   192.168.10.203       1
        10.61.0.0    255.255.255.0   192.168.10.202       1
        10.61.0.0    255.255.255.0   192.168.10.203       1
        10.62.0.0    255.255.255.0   192.168.10.202       1
        10.62.0.0    255.255.255.0   192.168.10.203       1
        10.75.0.0    255.255.255.0   192.168.10.202       1
        10.75.0.0    255.255.255.0   192.168.10.203       1

H:\>
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24030631
Okay, so the DHCP server has a route to 10.16.0.0/24 via 192.168.10.202.  I assume 192.168.10.202 is the other core switch.  Can you post its config?
0
 
LVL 1

Author Comment

by:lunanat
ID: 24031159
Yes, .10.202 is the other core switch (and just in case, I'm gonna say this:  There is a route through both .202 and .203, not just .202).

I'm stuck in the middle of a meeting right now that I really don't need to be in, so getting the config will take a bit of time.  I'll post it in a few hours when we are finished here.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24031186
I see that configured but looks like it chose the 202 as the preferred.

Make sure you can ping between cores (ping 202 from 203 and vice versa).
0
 
LVL 1

Author Comment

by:lunanat
ID: 24031223
At the moment 202 is completely unhooked.. not even powered on.  I have 2 core switches with the intent of layer 3 redundancy, allowing a physical hardware failure.

Before I let things sit, I had it configured that things would eventually figure out that the route was dead and failover to the secondary gateway -in my DHCP scope settings, I set 2 gateways for each scope - one for each 3560 switch (the VLAN interface IP address).
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 500 total points
ID: 24031280
Ahh, well, thats the issue.

Remove the .202 routes on the DHCP server until 202 is in place again so the .203 is used.

By the way, your best bet is to run HSRP between the two core switches so you have a single virtual default gateway.
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 
LVL 1

Author Comment

by:lunanat
ID: 24031337
hmm... HSRP you say?

I'll read up on that now.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24031366
Easy to implement and works great.  Here is an example for VLAN1:

Core1:

interface Vlan1
 ip address 192.168.10.202 255.255.255.0
 standby 1 ip 192.168.10.1
 standby 1 priority 110
 standby 1 preempt

Core2:

interface Vlan1
 ip address 192.168.10.203 255.255.255.0
 standby 1 ip 192.168.10.1

The VLAN1 hosts would have a default gateway of 192.168.10.1 (the virtual HSRP IP).


0
 
LVL 1

Author Comment

by:lunanat
ID: 24031389
Interesting.. so then I would only need to configure my DHCP to point to the HSRP virtual IP address as the default gateway on my workstations?

Wouldn't need to configure my edge switches?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24031420
>Interesting.. so then I would only need to configure my DHCP to point to the HSRP virtual IP address as the default gateway on my workstations?

Correct.  Core1 (the one with higher priority) would be the active router.  If core1 died, core2 would pick up the duties.

>Wouldn't need to configure my edge switches?
This doesn't impact the edge switch configuration.  It will remain the same (trunk to both cores).
0
 
LVL 1

Author Comment

by:lunanat
ID: 24031481
And I would then on my DHCP server change the routes from 192.168.10.202 and 192.168.10.203 to the new virtual router IP address?  As per your example, I would then change the route for say vlan 1 from:
192.168.10.0    255.255.255.0   192.168.10.203       1

to:
192.168.10.0    255.255.255.0    192.168.10.1         1

and vlan 16, following the same conventions, would be:
10.16.0.0         255.255.0.0       192.168.10.1     1
Because the 10.1 ends up pointing to the core switch, which is responsible for routing traffic between the subnets?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24031519
Correct.  All routes off the DHCP server subnet (192.168.10.0) would have a next hop of 192.168.10.1.

Furthermore, each subnet/VLAN on the core would have HSRP configured so VLAN16 (10.16.0.x) hosts would have a default gateway of the HSRP virtual IP for VLAN16 (10.16.0.1) for example.

0
 
LVL 1

Author Comment

by:lunanat
ID: 24031536
Thank you so much for giving me such a simpler solution than multiple gateways.

As soon as I'm out of this meeting I'll implement!

You rock!
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24031550
You're welcome.  Good luck.
0
 
LVL 1

Author Closing Comment

by:lunanat
ID: 31564911
Thank you so much!  Not only did you resolve the problem (which in this case was thanks to my half-test and not hooking up the "main" router) you also gave me a much better way to implement my high availability.

Most appreciated.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

I eventually solved a perplexing problem setting up telnet for a new switch.  I installed a new Cisco WS-03560X-24P switch connected to an existing Cisco 4506 running a WS-X4013-10GE Sup II-Plus. After configuring vlans and trunking,  I could no…
If you are thinking of adopting cloud services, or just curious as to what ‘the cloud’ can offer then the leader according to Gartner for Infrastructure as a Service (IaaS) is Amazon Web Services (AWS).  When I started using AWS I was completely new…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now